View Issue Details

IDProjectCategoryView StatusLast Update
0022456LazarusLCLpublic2014-05-07 17:38
ReporterAbou Al Montacir Assigned ToZeljan Rikalo  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformarmelOSDebian GNU/Linux 
Product Version0.9.30.4 
Target Version1.4 
Summary0022456: Lazarus with LCL/Qt can not build on arm CPU
DescriptionLCL compilation fails due to missing API entries

Assembling qtthemes
qtx11.inc(10,44) Error: Identifier not found "QX11Info_isCompositingManagerRunning"
qtx11.inc(16,30) Error: Identifier not found "QX11Info_display"
qtx11.inc(42,30) Error: Identifier not found "QX11Info_display"
qtx11.inc(45,34) Error: Identifier not found "QX11Info_appScreen"
qtx11.inc(93,30) Error: Identifier not found "QX11Info_display"
qtx11.inc(98,34) Error: Identifier not found "QX11Info_appScreen"
qtx11.inc(127,30) Error: Identifier not found "QX11Info_display"
qtx11.inc(132,34) Error: Identifier not found "QX11Info_appScreen"
qtx11.inc(170,30) Error: Identifier not found "QX11Info_display"
qtx11.inc(175,34) Error: Identifier not found "QX11Info_appScreen"
qtx11.inc(229,30) Error: Identifier not found "QX11Info_display"
qtx11.inc(233,34) Error: Identifier not found "QX11Info_appScreen"
qtwinapi.inc(1283,8) Note: User defined: remove ifdef if I'm wrong about DT_WORDBREAK OBSERVATION
qtwinapi.inc(1542,5) Note: User defined: implement EnumFontFamiliesEx for other than default
qtint.pp(473) Fatal: There were 12 errors compiling module, stopping
Fatal: Compilation aborted
make[5]: *** [interfaces.ppu] Error 1
make[5]: Leaving directory `/build/buildd-lazarus_0.9.30.4-2-armel-ZnJTK0/lazarus-0.9.30.4/lcl/interfaces/qt'
make[4]: *** [qt_all] Error 2
make[4]: Leaving directory `/build/buildd-lazarus_0.9.30.4-2-armel-ZnJTK0/lazarus-0.9.30.4/lcl/interfaces'
make[3]: *** [interfaces] Error 2
make[3]: Leaving directory `/build/buildd-lazarus_0.9.30.4-2-armel-ZnJTK0/lazarus-0.9.30.4/lcl'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/build/buildd-lazarus_0.9.30.4-2-armel-ZnJTK0/lazarus-0.9.30.4/lcl'
make[1]: *** [lcl] Error 2
make[1]: Leaving directory `/build/buildd-lazarus_0.9.30.4-2-armel-ZnJTK0/lazarus-0.9.30.4'
make: *** [build-arch-stamp] Error 2
dpkg-buildpackage: error: debian/rules build-arch gave error exit status 2

Please refer to https://buildd.debian.org/fetch.cgi?pkg=lazarus&arch=armel&ver=0.9.30.4-2&stamp=1341267726&file=log for full log
Steps To Reproduce/usr/bin/make -C qt LCL_PLATFORM=qt
Additional InformationQt API entries are missing du to QTOPIA define. Added patch fixes issue
TagsNo tags attached.
Fixed in Revision43901
LazTarget1.4
WidgetsetQT
Attached Files

Activities

2012-07-17 13:25

 

disable-QTOPIA-on-arm-machines.diff (421 bytes)   
diff --git a/lcl/interfaces/qt/qt45.pas b/lcl/interfaces/qt/qt45.pas
index 99ba52c..2074f1f 100644
--- a/lcl/interfaces/qt/qt45.pas
+++ b/lcl/interfaces/qt/qt45.pas
@@ -36,9 +36,9 @@ const
 
 // Set qtopia yourself if using QTOPIA with QVFB on i386
 // ppc386 -dQTOPIA
-{$IFDEF CPUARM}
-  {$DEFINE QTOPIA}
-{$ENDIF}
+//{$IFDEF CPUARM}
+//  {$DEFINE QTOPIA}
+//{$ENDIF}
 
 {$IFDEF QTOPIA}
   Qt4PasLib = 'libQt4Pas.so.5';

Zeljan Rikalo

2014-04-29 13:37

developer   ~0074657

hmm...totally forgot about this issue. Actually qtlcl works on arm eg. Maemo Harmattan (my Nokia N9 happily runs qtlcl apps) since X11 is up.

Zeljan Rikalo

2014-05-07 17:38

developer   ~0074834

Mattias already commited it two months ago. Please close if ok.
NOTE: will be merged to 1.2.4

Issue History

Date Modified Username Field Change
2012-07-17 13:25 Abou Al Montacir New Issue
2012-07-17 13:25 Abou Al Montacir File Added: disable-QTOPIA-on-arm-machines.diff
2012-07-17 13:25 Abou Al Montacir LazTarget => -
2012-07-17 13:25 Abou Al Montacir Widgetset => QT
2012-08-01 12:11 Zeljan Rikalo Status new => assigned
2012-08-01 12:11 Zeljan Rikalo Assigned To => Zeljan Rikalo
2012-10-09 13:53 Zeljan Rikalo LazTarget - => 1.2
2013-09-14 00:42 Martin Friebe Target Version 1.0.0 => 1.2.0
2014-02-15 20:51 Martin Friebe LazTarget 1.2 => 1.4
2014-02-15 20:52 Martin Friebe Target Version 1.2.0 => 1.4
2014-04-29 13:37 Zeljan Rikalo Note Added: 0074657
2014-05-07 17:38 Zeljan Rikalo Fixed in Revision => 43901
2014-05-07 17:38 Zeljan Rikalo Note Added: 0074834
2014-05-07 17:38 Zeljan Rikalo Status assigned => resolved
2014-05-07 17:38 Zeljan Rikalo Resolution open => fixed