View Issue Details

IDProjectCategoryView StatusLast Update
0022506LazarusLazReportpublic2012-10-13 16:05
ReporterChristian OrtizAssigned ToJesus Reyes 
PrioritynormalSeverityblockReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.1 (SVN)Product Build 
Target Version1.0.4Fixed in Version1.0.2 
Summary0022506: Lazarus 0.9.31 - 02/07/2012
DescriptionUsing GTK2 (Ubuntu 12.04)

When i have more than one page, i cannot scroll the next pages. Besides i cannot change the page in any way.
TagsNo tags attached.
Fixed in Revision38955
LazTarget1.0.4
WidgetsetGTK 2
Attached Files

Relationships

related to 0021633 closedJesus Reyes Scrolling in Report Preview dont work 

Activities

Juha Manninen

2012-07-25 00:09

developer   ~0061223

Could you please explain a little more. What page?

Christian Ortiz

2012-08-03 15:47

reporter   ~0061378

Well, i made a report which has more than one page (my report has 45 pages) and when i want to go to the next page (report) the scroll doesnt work.

Christian Ortiz

2012-08-10 17:32

reporter   ~0061561

do u need extra information?

Juha Manninen

2012-08-10 19:58

developer   ~0061562

I had read the issue category poorly when I asked the question.
I don't know LazReport code well. Assigning to Jesus now.

Jesus Reyes

2012-08-24 03:10

developer   ~0061847

please attach a sample project.

Christian Ortiz

2012-09-07 17:20

reporter   ~0062181

use the lazreport example (barcodes) you can not go to the next pages

i tested in Ubuntu 10.04,12.04 and kubuntu 10.04, 12.04 and the error is the same.

Christian Ortiz

2012-09-14 21:44

reporter   ~0062356

do u need some extra information?

Jesus Reyes

2012-10-02 23:03

developer   ~0062837

Tried barcode project, no problem here. advance page button works, mousewheel works, scrollbar works. tested xubuntu 11.10, lazarus trunk.

Please try a snapshot version or compile lazarus from svn and try again.

Reinier Olislagers

2012-10-03 05:43

developer   ~0062841

Tried barcode project, same results as Jesus.

Only slightly strange thing is that the report opens with a small width, just about enough to show the icon; dragging the edge with the mouse does work as expected to widen it. (Could perhaps be caused by running in a small resolution VM image, don't know)

Lazarus trunk, Debian unstable x64, xfce

Martin Friebe

2012-10-13 16:05

manager   ~0063128

No further feedback received.

According to http://forum.lazarus.freepascal.org/index.php/topic,18351.msg104455.html#msg104455 this was fixed in trunk long ago, and has been merged to fixes now.

If the issue still exists in 1.0.2 then please:
- reopen this report
- *AND* give feedback, if the issue is present in 1.1

Issue History

Date Modified Username Field Change
2012-07-24 23:27 Christian Ortiz New Issue
2012-07-24 23:27 Christian Ortiz Widgetset => GTK 2
2012-07-25 00:09 Juha Manninen LazTarget => -
2012-07-25 00:09 Juha Manninen Note Added: 0061223
2012-07-25 00:09 Juha Manninen Status new => feedback
2012-08-03 15:47 Christian Ortiz Note Added: 0061378
2012-08-10 17:32 Christian Ortiz Note Added: 0061561
2012-08-10 19:53 Juha Manninen Status feedback => assigned
2012-08-10 19:53 Juha Manninen Assigned To => Jesus Reyes
2012-08-10 19:58 Juha Manninen Note Added: 0061562
2012-08-24 03:10 Jesus Reyes Note Added: 0061847
2012-08-24 03:10 Jesus Reyes Status assigned => feedback
2012-09-07 17:20 Christian Ortiz Note Added: 0062181
2012-09-14 21:44 Christian Ortiz Note Added: 0062356
2012-10-02 23:03 Jesus Reyes Note Added: 0062837
2012-10-03 05:43 Reinier Olislagers Note Added: 0062841
2012-10-07 15:10 Martin Friebe Relationship added related to 0021633
2012-10-13 16:05 Martin Friebe Fixed in Revision => 38955
2012-10-13 16:05 Martin Friebe LazTarget - => 1.0.4
2012-10-13 16:05 Martin Friebe Status feedback => resolved
2012-10-13 16:05 Martin Friebe Fixed in Version => 1.0.2
2012-10-13 16:05 Martin Friebe Resolution open => fixed
2012-10-13 16:05 Martin Friebe Note Added: 0063128
2012-10-13 16:05 Martin Friebe Target Version => 1.0.4