View Issue Details

IDProjectCategoryView StatusLast Update
0022507LazarusLCLpublic2017-03-03 23:39
ReporteralexP Assigned ToJuha Manninen  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platformx64 fpc2.6.0OSlinux fedora 16 x64 
Product Version1.1 (SVN) 
Summary0022507: error writing accented characters
Descriptionaccented characters are being duplicated see the video
TagsNo tags attached.
Fixed in Revisionr42102, r42581
LazTarget-
WidgetsetGTK 2
Attached Files

Relationships

duplicate of 0024750 feedbackZeljan Rikalo Accents in GTK2 
related to 0015185 resolvedZeljan Rikalo if envement GTK_IM_MODULE set to scim-bridge, input in lazarus is doubled 

Activities

2012-07-25 03:32

 

bug.ogg (1,782,448 bytes)   

Mattias Gaertner

2012-07-25 09:59

manager   ~0061234

The TMemo component is the native gtk2 gtk_text widget. The LCL does not alter the keys of this widget.

What keyboard layout do you use, what keys did you type?

Bart Broersma

2012-07-25 14:18

developer   ~0061242

Maybe related to/or same issue as 0015185 ?

alexP

2012-07-25 21:14

reporter   ~0061249

i use keyboard Portugues Brasil ABNT2

on my keyboard to accentuate vowels I have to type the accent after the letter (~a = ã) do not know if other versions are different

Bart Broersma

2012-07-31 09:32

developer   ~0061308

@alexP: can you look at 0015185 to see if this applies to your situation?

alexP

2012-08-01 01:12

reporter   ~0061337

my english is not very good, but the modules installed rebooted, and used the cmando (env | grep GTK_IM_MODULE) and Lazarus opened and was the same, both in this issue acontence lxde (x64) as in xfce (x32), I believe it is not the same error but from what I understand they said that the error report repeats the other characters and in my case only accentuated.

Juha Manninen

2013-07-16 09:57

developer   ~0068880

The patch in issue 0024750 was applied. Please test.

alexP

2013-07-16 15:08

reporter   ~0068887

unfortunately not copy git updated today (July 16) the problem persists

by I noticed the problem happens in all the characters that need more than one key to be generated (eg ś,ã,á,ẽ and others)

Juha Manninen

2013-07-16 18:01

developer   ~0068889

> unfortunately not copy git updated today (July 16) the problem persists

Does it mean you have a git mirror repo which you just updated?
Ok. It should be up to date then.

Did you build Lazarus and your test project with -dGtk2LatinAccents?

alexP

2013-08-11 01:18

reporter   ~0069322

42267 in reviewing the problem still continues, not found that option-dGtk2LatinAccents not know if there is but I use linux X64.

Juha Manninen

2013-08-11 01:25

developer   ~0069323

> not found that option-dGtk2LatinAccents

You need to define it yourself obviously.
Please look at the patch that was applied. It has effect only when Gtk2LatinAccents is defined.

alexP

2013-09-03 12:58

reporter   ~0069684

checked the patch seems to work, however I could not use, sorry for the lack of experience I do not find this option on the command used in lazarus source code however also not work} {$ DEFINE Gtk2LatinAccents, poreria inform how to use this solution? might be better something like {$ IFDEF Gtk2} activates its function. is just an opnion

Juha Manninen

2013-09-04 02:09

developer   ~0069710

Resolved together with the duplicate issue.

Issue History

Date Modified Username Field Change
2012-07-25 03:32 alexP New Issue
2012-07-25 03:32 alexP File Added: bug.ogg
2012-07-25 03:32 alexP Widgetset => GTK 2
2012-07-25 09:59 Mattias Gaertner Note Added: 0061234
2012-07-25 14:18 Bart Broersma Note Added: 0061242
2012-07-25 21:14 alexP Note Added: 0061249
2012-07-31 09:32 Bart Broersma Note Added: 0061308
2012-08-01 00:42 Juha Manninen Relationship added related to 0015185
2012-08-01 01:12 alexP Note Added: 0061337
2013-07-16 08:52 Juha Manninen Relationship added related to 0024750
2013-07-16 09:10 Juha Manninen Relationship replaced duplicate of 0024750
2013-07-16 09:55 Juha Manninen Assigned To => Juha Manninen
2013-07-16 09:55 Juha Manninen Status new => assigned
2013-07-16 09:57 Juha Manninen LazTarget => -
2013-07-16 09:57 Juha Manninen Note Added: 0068880
2013-07-16 09:57 Juha Manninen Status assigned => feedback
2013-07-16 15:08 alexP Note Added: 0068887
2013-07-16 15:08 alexP Status feedback => assigned
2013-07-16 18:01 Juha Manninen Note Added: 0068889
2013-08-11 01:18 alexP Note Added: 0069322
2013-08-11 01:25 Juha Manninen Note Added: 0069323
2013-09-03 12:58 alexP Note Added: 0069684
2013-09-04 02:09 Juha Manninen Fixed in Revision => r42102, r42581
2013-09-04 02:09 Juha Manninen Note Added: 0069710
2013-09-04 02:09 Juha Manninen Status assigned => resolved
2013-09-04 02:09 Juha Manninen Resolution open => fixed