View Issue Details

IDProjectCategoryView StatusLast Update
0022533PatchesIDEpublic2012-11-25 14:06
ReporterReinier OlislagersAssigned ToMartin Friebe  
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionfixed 
Platformx64OSWindows 
Product Version1.1 (SVN) 
Target Version1.2.0Fixed in Version1.1 (SVN) 
Summary0022533: [Patch] Set up windows installer to allow multiple debuggers using $(TargetCPU)-$(TargetOS)
DescriptionCurrently, the Windows installer installs the debugger into
<LazDir>\mingw\bin\gdb.exe
The default environmentoptions.xml states:
<DebuggerFilename Value="%LazDir%\mingw\bin\gdb.exe">

If you have a 32 bit IDE with 64 bit LCL compiled (or another like wince-arm), you will run the 32 bit gdb for the other LCL.

A solution is to use macros
1. change the 32 bit installer to put 32 bit gdb.exe in
<LazDir>\mingw\bin\x86-win32\gdb.exe
and the 64 bit installer should put gdb.exe in
<LazDir>\mingw\bin\x86_64-win64\gdb.exe

2. change the default environmentoptions.xml to
<DebuggerFilename Value="%LazDir%\mingw\bin\$(TargetCPU)-$(TargetOS)\gdb.exe">

3. devise a migration strategy
Additional InformationAFAIU, step 1 requires modifying the source tree, which is not in the regular Lazars svn tree, and which I haven't done.

Please find attached a patch (debuggermacro.diff) for step 2.

3. Migration from previous versions:
- I added the previous debugger file to the RemovedFiles32.iss and RemovedFiles64.iss (patch debuggerremovefiles.diff)
- presumably a patch to migrate existing environmentoptions.xml could be handy.. or a message in the release notes that people will need to change their setting
Alternatively, no migration strategy could be done for existing installs but that could lead to problems with existing obsolete gdb.exes
Tagsdebugger, gdb, windows
Fixed in Revision39357
LazTarget1.2
WidgetsetWin32/Win64
Attached Files

Activities

2012-07-30 11:24

 

debuggerpatches.zip (873 bytes)

Reinier Olislagers

2012-07-30 11:37

developer   ~0061291

Oops, the path for the 32 bit installer should be
1. change the 32 bit installer to put 32 bit gdb.exe in
<LazDir>\mingw\bin\i386-win32\gdb.exe

Just tested these macros with 32 & 64 bit LCL; they work.

Martin Friebe

2012-07-30 12:44

manager   ~0061294

In order to change the install location, it is necessary to test what happens on upgrades.
A user with an existing config, pointing to the current fixed location, who installs the new version, must not be left with his config broken.

Reinier Olislagers

2012-07-30 15:36

developer   ~0061300

Last edited: 2012-08-02 20:58

See ML discussion http://www.mail-archive.com/lazarus@lists.lazarus.freepascal.org/msg31772.html

Related to (child of): 22539 [Patch] Setup/initial dialog: check for debugger and make check in GUI instead of silently changing config

I got mixed up with the paths again in the patch for 22539: the existing fpc\bin\<cpu>-<os> arrangement is too strong for me.

Changed patches here to match patch 22539:
$(LazarusDir)/mingw/$(TargetCPU)-$(TargetOS)/bin/gdb.exe

2012-07-30 15:37

 

debugbatch.diff (657 bytes)   
Index: tools/install/win/create_installer.bat
===================================================================
--- tools/install/win/create_installer.bat	(revision 38091)
+++ tools/install/win/create_installer.bat	(working copy)
@@ -107,8 +107,8 @@
 if not exist %BUILDDIR%\lazarus.exe goto END
 if not exist %BUILDDIR%\startlazarus.exe goto END
 
-:: copy gdb into build dir
-if exist %GDBDIR% %SVN% export %GDBDIR% %BUILDDIR%\mingw
+:: copy gdb below the build dir for the proper os/cpu combination
+if exist %GDBDIR% %SVN% export %GDBDIR% %BUILDDIR%\mingw\bin\%FPCFULLTARGET%\
 
 :: create the installer
 IF [%BUILDLAZRELEASE%]==[] GOTO SNAPSHOT
debugbatch.diff (657 bytes)   

2012-07-30 15:39

 

debuggermacro.diff (573 bytes)   
Index: tools/install/win/environmentoptions.xml
===================================================================
--- tools/install/win/environmentoptions.xml	(revision 38091)
+++ tools/install/win/environmentoptions.xml	(working copy)
@@ -13,7 +13,7 @@
     <TestBuildDirectory Value="%Temp%">
     </TestBuildDirectory>
     <Debugger Class="TGDBMIDebugger"/>
-    <DebuggerFilename Value="%LazDir%\mingw\bin\gdb.exe">
+    <DebuggerFilename Value="%LazDir%\mingw\$(TargetCPU)-$(TargetOS)\bin\gdb.exe">
     </DebuggerFilename>
   </EnvironmentOptions>
 </CONFIG>
debuggermacro.diff (573 bytes)   

2012-07-31 12:21

 

debuggermacro_bin_at_end.diff (1,090 bytes)   
Index: tools/install/win/create_installer.bat
===================================================================
--- tools/install/win/create_installer.bat	(revision 38096)
+++ tools/install/win/create_installer.bat	(working copy)
@@ -107,8 +107,16 @@
 if not exist %BUILDDIR%\lazarus.exe goto END
 if not exist %BUILDDIR%\startlazarus.exe goto END
 
-:: copy gdb into build dir
+:: copy gdb into build dir; will create %builddir%\mingw\bin
 if exist %GDBDIR% %SVN% export %GDBDIR% %BUILDDIR%\mingw
+:: We're really interested in the dlls, exes and .manifests, but will just copy everything in bin.
+:: These files should be moved to match the default debuggerfilename setting in environmentoptions.xml
+if not exist %BUILDDIR%\mingw\bin\gdb.exe goto NOGDB
+gmkdir -p %BUILDDIR%\mingw\%FPCFULLTARGET%
+mv --force %BUILDDIR%\mingw\bin %BUILDDIR%\%FPCFULLTARGET%\ >> %LOGFILE%
+:: We can silently and forcefully remove the bin dir in order to reduce confusion on the user's part:
+rm -rf %BUILDDIR%\mingw\bin
+:NOGDB
 
 :: create the installer
 IF [%BUILDLAZRELEASE%]==[] GOTO SNAPSHOT
debuggermacro_bin_at_end.diff (1,090 bytes)   

Reinier Olislagers

2012-08-02 20:56

developer   ~0061363

Last edited: 2012-08-02 20:58

Removed comment spam.

Reworked and tested patch
- Changed batch file gdb.exe handlign. Tested, works on Windows x86 installer with today's Lazarus SVN: installer is created, runs, places gdb.exe in proper location for --setup dialog to accept
- In create_installer.bat, only override CHMHELPFILES environment variable if the argument is specified on the command line (in line with how other parameters are handled)
- typo fixes in batch files (IF [%5]==[] GOTO EMPTY6)
- Updated readme to include details on CHMHELPFILES, PATCHFILE, and IDE_WIDGETSET

Patch debuggerinstaller_OS_CPU.diff; all in one patch that supersedes other patches here

2012-08-02 20:57

 

debuggerinstaller_OS_CPU.diff (6,037 bytes)   
Index: tools/install/win/create_installer.bat
===================================================================
--- tools/install/win/create_installer.bat	(revision 38116)
+++ tools/install/win/create_installer.bat	(working copy)
@@ -36,13 +36,19 @@
 :EMPTY5
 
 :: Name of fpc patch file
-IF [%5]==[] GOTO EMPTY6
-IF [%5]==[""] GOTO EMPTY6
+IF [%6]==[] GOTO EMPTY6
+IF [%6]==[""] GOTO EMPTY6
 IF NOT [%6]==[] SET PATCHFILE=%6
 :EMPTY6
 
-SET CHMHELPFILES=%7
+:: Set directory where .CHM help files and associated index etc files are used
+:: If environment variable is set, use it unless parameter 7 is specified
+IF [%7]==[] GOTO EMPTY7
+IF [%7]==[""] GOTO EMPTY7
+IF NOT [%7]==[] SET CHMHELPFILES=%7
+:EMPTY7
 
+
 ::=====================================================================
 :: no change needed after this.
 
@@ -109,9 +115,19 @@
 if not exist %BUILDDIR%\lazarus.exe goto END
 if not exist %BUILDDIR%\startlazarus.exe goto END
 
-:: copy gdb into build dir
+:: copy gdb into build dir; will create %builddir%\mingw\bin
 if exist %GDBDIR% %SVN% export %GDBDIR% %BUILDDIR%\mingw
+:: We're really interested in the dlls, exes and .manifests, but will just copy everything in bin.
+:: These files should be moved to match the default debuggerfilename setting in environmentoptions.xml
+if not exist %BUILDDIR%\mingw\bin\gdb.exe goto NOGDB
+gmkdir -p %BUILDDIR%\mingw\%FPCFULLTARGET%\bin\
+:: Note: don't add a trailing \ after the directory
+mv --force %BUILDDIR%\mingw\bin\* %BUILDDIR%\mingw\%FPCFULLTARGET%\bin >> %LOGFILE%
+:: We can silently and forcefully remove the bin dir in order to reduce confusion on the user's part:
+rm -rf %BUILDDIR%\mingw\bin
+:NOGDB
 
+
 :: create the installer
 IF [%BUILDLAZRELEASE%]==[] GOTO SNAPSHOT
 SET OutputFileName=lazarus-%LAZVERSION%-fpc-%FPCFULLVERSION%-%FPCTARGETOS%
Index: tools/install/win/RemovedFiles64.iss
===================================================================
--- tools/install/win/RemovedFiles64.iss	(revision 38116)
+++ tools/install/win/RemovedFiles64.iss	(working copy)
@@ -1210,6 +1210,7 @@
 Name: {app}\lcl\units\x86_64-win64\qt\qtwsstdctrls.ppu; Type: files
 Name: {app}\lcl\units\x86_64-win64\win32\win32uxtheme.o; Type: files
 Name: {app}\lcl\units\x86_64-win64\win32\win32uxtheme.ppu; Type: files
+Name: {app}\mingw\bin\gdb.exe; Type: files
 Name: {app}\packager\adddirtopkgdlg.lrs; Type: files
 Name: {app}\packager\addfiletoapackagedlg.lrs; Type: files
 Name: {app}\packager\addtopackagedlg.lrs; Type: files
Index: tools/install/win/readme.txt
===================================================================
--- tools/install/win/readme.txt	(revision 38116)
+++ tools/install/win/readme.txt	(working copy)
@@ -24,23 +24,34 @@
 A.6. The latest release of the fpc compiler
 Currently the latest release is fpc 2.6.0. You need just the ppcXXX.exe (ppc386.exe for win32 and ppcx64.exe for win64) to bootstrap compilation of the current fpc version.
 
+A.7. The CHM help files for Lazarus
+If you want to include CHM help files in the installer, you'll need a directory with the FCL, RTL, LCL etc .CHM files (and associated index etc files, optionally including subdirectories) .
+
 B Adjust create_installer.bat to your configuration
 
 Open the create_installer.bat in a text editor and check the variables, to see if they match your configuration:
 ISCC: Path to the Inno Setup Compiler .exe file.
 BUILDDIR: Path to build directory.
 SVN: Path to the Subversion .exe file.
+Alternatively, you can set these as environment variables before you run the batch script, e.g.:
+SET ISCC="C:\Program Files (x86)\Inno Setup 5\ISCC.exe"
+SET BUILDDIR="c:\temp\lazarusbuild"
+SET SVN="C:\Program Files\SlikSvn\bin\svn.exe"
 
 C Run create_installer.bat
 
 Run the script:
 
-create_installer.bat FPCSVNDIR LAZSVNDIR LAZSVNBINDIR RELEASE_PPC
+create_installer.bat FPCSVNDIR LAZSVNDIR LAZSVNBINDIR RELEASE_PPC IDE_WIDGETSET PATCHFILE CHMHELPFILES
 
 where:
 FPCSVNDIR: Path to the fpc sources checked out of svn (see A.3)
 LAZSVNDIR: Path to the lazarus sources checked out of svn (see A.4)
 LAZSVNBINDIR: Path to the svn lazarus binaries (see A.5)
 RELEASE_PPC: Path to the FPC compiler required to start the build of fpc it FPCSVNDIR (see A.6)
+IDE_WIDGETSET: Optional: IDE widgetset to be created. If not needed: don't enter it or use ""
+PATCHFILE: Optional: name of FPC patch file for the FPC sources. If not needed: don't enter it or use ""
+CHMHELPFILES: Optional: directory containing CHM help files to be included in the installer (see A.7). If not needed: don't enter it or use ""
 
+
 Just do it. Wait about 40 minutes (on 2.6 GHz P-IV). A log file named installer.log will be written to the current directory and setup file will be in the Output subdirectory of the current directory.
Index: tools/install/win/environmentoptions.xml
===================================================================
--- tools/install/win/environmentoptions.xml	(revision 38116)
+++ tools/install/win/environmentoptions.xml	(working copy)
@@ -13,7 +13,7 @@
     <TestBuildDirectory Value="%Temp%">
     </TestBuildDirectory>
     <Debugger Class="TGDBMIDebugger"/>
-    <DebuggerFilename Value="%LazDir%\mingw\bin\gdb.exe">
+    <DebuggerFilename Value="%LazDir%\mingw\$(TargetCPU)-$(TargetOS)\bin\gdb.exe">
     </DebuggerFilename>
   </EnvironmentOptions>
 </CONFIG>
Index: tools/install/win/RemovedFiles32.iss
===================================================================
--- tools/install/win/RemovedFiles32.iss	(revision 38116)
+++ tools/install/win/RemovedFiles32.iss	(working copy)
@@ -1210,6 +1210,7 @@
 Name: {app}\lcl\units\i386-win32\qt\qtwsstdctrls.ppu; Type: files
 Name: {app}\lcl\units\i386-win32\win32\win32uxtheme.o; Type: files
 Name: {app}\lcl\units\i386-win32\win32\win32uxtheme.ppu; Type: files
+Name: {app}\mingw\bin\gdb.exe; Type: files
 Name: {app}\packager\adddirtopkgdlg.lrs; Type: files
 Name: {app}\packager\addfiletoapackagedlg.lrs; Type: files
 Name: {app}\packager\addtopackagedlg.lrs; Type: files
debuggerinstaller_OS_CPU.diff (6,037 bytes)   

Martin Friebe

2012-09-07 12:14

manager   ~0062170

Sorry for the delay. Just looking at the patch.

parts of it seem to already be applied.

About:
 
-:: copy gdb into build dir
+:: copy gdb into build dir; will create %builddir%\mingw\bin
 if exist %GDBDIR% %SVN% export %GDBDIR% %BUILDDIR%\mingw
+:: We're really interested in the dlls, exes and .manifests, but will just copy everything in bin.
+:: These files should be moved to match the default debuggerfilename setting in environmentoptions.xml
+if not exist %BUILDDIR%\mingw\bin\gdb.exe goto NOGDB
+gmkdir -p %BUILDDIR%\mingw\%FPCFULLTARGET%\bin\
+:: Note: don't add a trailing \ after the directory
+mv --force %BUILDDIR%\mingw\bin\* %BUILDDIR%\mingw\%FPCFULLTARGET%\bin >> %LOGFILE%
+:: We can silently and forcefully remove the bin dir in order to reduce confusion on the user's part:
+rm -rf %BUILDDIR%\mingw\bin
+:NOGDB
 

Why export it to one place, then move it. Why not export it to the correct place, right away?

About RemovedFiles32/64:
Shouldn't that include the dll too?

Reinier Olislagers

2012-09-07 12:58

developer   ~0062172

Thanks, Martin.
1. Exporting: fine by me but I don't have much experience with export, that's the reason I did it that way.

2. Removed DLLs: yes, sorry, I suppose so.

Vincent Snijders

2012-09-07 12:59

manager   ~0062174

Why is chosen for
$(LazarusDir)\mingw\$(TargetCPU)-$(TargetOS)\bin\gdb.exe
instead of
$(LazarusDir)\mingw\bin\$(TargetCPU)-$(TargetOS)\gdb.exe

Reinier Olislagers

2012-09-09 09:11

developer   ~0062214

@Vincent: I think either because Martin suggested it in the mailing list discussion or because I implemented it that way in the --setup dialog.
I don't really mind either way - as indicated, the second way seems more logical given the way fpc does things.
However, perhaps gdb has other subdirectories that are architecture dependent and that it may need... which Martin probably nows.

<lazarus>\ide\initialsetupdlgs.pas currently only supports bin at the end; this would have to be modified (or even better: the new location should be added as a test before this so it takes precedence, but existing old setups are still detected).
    // The next 2 locations are locations used by older and newer versions of the Windows installers
    // If other platform installers follow the same strategy, this can be useful.
    // Chances of this are low (gdb is generally installed in the path on Unixy systems), but it can't hurt...
    // and it can be useful for cross compiling/custom setups.

    // Check new installation location: $(LazarusDir)\mingw\$(TargetCPU)-$(TargetOS)\bin\gdb.exe
    if CheckFile(SetDirSeparators('$(LazarusDir)/mingw/$(TargetCPU)-$(TargetOS)/bin/'+DebuggerFileName+GetExecutableExt),Result)
      then exit;

Martin Friebe

2012-09-09 11:32

manager   ~0062220

I think we should change as Vincent suggested.

The --setup code can be changed, it does not need $(LazarusDir)\mingw\$(TargetCPU)-$(TargetOS)\bin\gdb.exe, this was never used.

So it only needs $(LazarusDir)\mingw\bin\$(TargetCPU)-$(TargetOS)\gdb.exe


Do you think you can update the patch, appropriately.

And please keep unrelated cleanup (like the batch argument 7 chm help)in a separate patch. (Not sure why that is needed at all. It will be empty this way or that way)

All gdb related can go in one patch. (batch, iss, pas)

Thanks.

Reinier Olislagers

2012-09-09 12:03

developer   ~0062221

Yes, but I don't think I'll get this in in the near future.

Martin Friebe

2012-09-26 13:00

manager   ~0062643

Decided to keep
  $(LazarusDir)\mingw\$(TargetCPU)-$(TargetOS)\bin\gdb.exe
because
  SVN:\$(TargetCPU)-$(TargetOS)\gdb\
may contain ReadMe or similar together with the bin dir. And those should end up (next to the bin folder) in
  $(LazarusDir)\mingw\$(TargetCPU)-$(TargetOS)\ReadMe

Martin Friebe

2012-09-26 14:49

manager   ~0062648

I applied the patch.

But after installation (upgrade, install over old install), the dbg config was not adapted.

DebuggerPath is still
C:\lazarus\mingw\bin\gdb.exe

Even so, this file does not exist (the folder does exist, but is empty), and the debugger is now in:
C:\lazarus\mingw\i386-win32\bin\gdb.exe


I attach the updated patch. (which include removing old dll)

2012-09-26 14:49

 

install_gdb_location.diff (2,772 bytes)   
Index: tools/install/win/create_installer.bat
===================================================================
--- tools/install/win/create_installer.bat	(revision 38849)
+++ tools/install/win/create_installer.bat	(working copy)
@@ -110,7 +110,10 @@
 if not exist %BUILDDIR%\startlazarus.exe goto END
 
 :: copy gdb into build dir
-if exist %GDBDIR% %SVN% export %GDBDIR% %BUILDDIR%\mingw
+if NOT exist %GDBDIR% goto NOGDB
+gmkdir -p %BUILDDIR%\mingw
+%SVN% export %GDBDIR% %BUILDDIR%\mingw\%FPCFULLTARGET%
+:NOGDB
 
 :: create the installer
 IF [%BUILDLAZRELEASE%]==[] GOTO SNAPSHOT
Index: tools/install/win/environmentoptions.xml
===================================================================
--- tools/install/win/environmentoptions.xml	(revision 38849)
+++ tools/install/win/environmentoptions.xml	(working copy)
@@ -13,7 +13,7 @@
     <TestBuildDirectory Value="%Temp%">
     </TestBuildDirectory>
     <Debugger Class="TGDBMIDebugger"/>
-    <DebuggerFilename Value="%LazDir%\mingw\bin\gdb.exe">
+    <DebuggerFilename Value="%LazDir%\mingw\$(TargetCPU)-$(TargetOS)\bin\gdb.exe">
     </DebuggerFilename>
   </EnvironmentOptions>
 </CONFIG>
Index: tools/install/win/RemovedFiles32.iss
===================================================================
--- tools/install/win/RemovedFiles32.iss	(revision 38849)
+++ tools/install/win/RemovedFiles32.iss	(working copy)
@@ -1217,6 +1217,11 @@
 Name: {app}\lcl\units\i386-win32\qt\qtwsstdctrls.ppu; Type: files
 Name: {app}\lcl\units\i386-win32\win32\win32uxtheme.o; Type: files
 Name: {app}\lcl\units\i386-win32\win32\win32uxtheme.ppu; Type: files
+Name: {app}\mingw\bin\gdb.exe; Type: files
+Name: {app}\mingw\bin\libexpat-1.dll; Type: files
+Name: {app}\mingw\bin\libgcc_s_dw2-1.dll; Type: files
+Name: {app}\mingw\bin\libiconv-2.dll; Type: files
+Name: {app}\mingw\bin\libintl-8.dll; Type: files
 Name: {app}\packager\adddirtopkgdlg.lrs; Type: files
 Name: {app}\packager\addfiletoapackagedlg.lrs; Type: files
 Name: {app}\packager\addtopackagedlg.lrs; Type: files
Index: tools/install/win/RemovedFiles64.iss
===================================================================
--- tools/install/win/RemovedFiles64.iss	(revision 38849)
+++ tools/install/win/RemovedFiles64.iss	(working copy)
@@ -1217,6 +1217,8 @@
 Name: {app}\lcl\units\x86_64-win64\qt\qtwsstdctrls.ppu; Type: files
 Name: {app}\lcl\units\x86_64-win64\win32\win32uxtheme.o; Type: files
 Name: {app}\lcl\units\x86_64-win64\win32\win32uxtheme.ppu; Type: files
+Name: {app}\mingw\bin\gdb.exe; Type: files
+Name: {app}\mingw\bin\libiconv-2.dll; Type: files
 Name: {app}\packager\adddirtopkgdlg.lrs; Type: files
 Name: {app}\packager\addfiletoapackagedlg.lrs; Type: files
 Name: {app}\packager\addtopackagedlg.lrs; Type: files
install_gdb_location.diff (2,772 bytes)   

Martin Friebe

2012-11-23 23:55

manager   ~0063993

Applied.

Fixed the check for the changed gdb in rev 39356

Reinier Olislagers

2012-11-25 14:06

developer   ~0064026

Thanks a lot Martin, tested and works with today's snapshot on x86 Windows.

@"But after installation (upgrade, install over old install), the dbg config was not adapted."
Probably because originally we decided not to modify existing configurations.

Issue History

Date Modified Username Field Change
2012-07-30 11:24 Reinier Olislagers New Issue
2012-07-30 11:24 Reinier Olislagers File Added: debuggerpatches.zip
2012-07-30 11:24 Reinier Olislagers Widgetset => Win32/Win64
2012-07-30 11:37 Reinier Olislagers Note Added: 0061291
2012-07-30 12:31 Martin Friebe Status new => assigned
2012-07-30 12:31 Martin Friebe Assigned To => Martin Friebe
2012-07-30 12:44 Martin Friebe Note Added: 0061294
2012-07-30 15:36 Reinier Olislagers Note Added: 0061300
2012-07-30 15:37 Reinier Olislagers File Added: debugbatch.diff
2012-07-30 15:39 Reinier Olislagers Tag Attached: windows
2012-07-30 15:39 Reinier Olislagers Tag Attached: debugger
2012-07-30 15:39 Reinier Olislagers Tag Attached: gdb
2012-07-30 15:39 Reinier Olislagers File Added: debuggermacro.diff
2012-07-30 15:41 Reinier Olislagers Note Edited: 0061300
2012-07-31 07:21 Reinier Olislagers Note Edited: 0061300
2012-07-31 10:03 Reinier Olislagers Note Edited: 0061300
2012-07-31 12:21 Reinier Olislagers File Added: debuggermacro_bin_at_end.diff
2012-08-02 20:56 Reinier Olislagers Note Added: 0061363
2012-08-02 20:56 Reinier Olislagers Note Edited: 0061363
2012-08-02 20:57 Reinier Olislagers File Added: debuggerinstaller_OS_CPU.diff
2012-08-02 20:57 Reinier Olislagers Note Edited: 0061300
2012-08-02 20:57 Reinier Olislagers Note Edited: 0061300
2012-08-02 20:58 Reinier Olislagers Note Edited: 0061300
2012-08-02 20:58 Reinier Olislagers Note Edited: 0061363
2012-09-07 12:14 Martin Friebe Note Added: 0062170
2012-09-07 12:58 Reinier Olislagers Note Added: 0062172
2012-09-07 12:59 Vincent Snijders Note Added: 0062174
2012-09-09 09:11 Reinier Olislagers Note Added: 0062214
2012-09-09 11:32 Martin Friebe Note Added: 0062220
2012-09-09 12:03 Reinier Olislagers Note Added: 0062221
2012-09-26 13:00 Martin Friebe Note Added: 0062643
2012-09-26 14:49 Martin Friebe LazTarget => -
2012-09-26 14:49 Martin Friebe Note Added: 0062648
2012-09-26 14:49 Martin Friebe Status assigned => feedback
2012-09-26 14:49 Martin Friebe File Added: install_gdb_location.diff
2012-11-23 23:55 Martin Friebe Fixed in Revision => 39357
2012-11-23 23:55 Martin Friebe LazTarget - => 1.2
2012-11-23 23:55 Martin Friebe Status feedback => resolved
2012-11-23 23:55 Martin Friebe Fixed in Version => 1.1 (SVN)
2012-11-23 23:55 Martin Friebe Resolution open => fixed
2012-11-23 23:55 Martin Friebe Note Added: 0063993
2012-11-23 23:55 Martin Friebe Target Version => 1.2.0
2012-11-25 14:06 Reinier Olislagers Status resolved => closed
2012-11-25 14:06 Reinier Olislagers Note Added: 0064026