View Issue Details

IDProjectCategoryView StatusLast Update
0022609LazarusIDEpublic2013-12-29 17:54
ReporterGraeme Geldenhuys Assigned ToJuha Manninen  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinuxOSOpenSUSE 
Product Version1.0.0RC1 
Summary0022609: Project Inspector doesn't remember settings
DescriptionIn the Project Inspector I activated the "Sort files alphabetically" button. But when I restart the IDE and load that same project, the units are not sorted, and the button is not activated like I had it last.

The same thing happens with the "Show directory hierarchy" toggle button.
Tags1.0 rc1
Fixed in Revisionr43612
LazTarget1.2
Widgetset
Attached Files

Relationships

duplicate of 0022448 resolvedJuha Manninen State of 'Show Directory Hierarchy' and 'Sort Files alphabetically' buttons not saved 

Activities

Mattias Gaertner

2012-08-09 13:23

manager   ~0061533

It's feature request, so it will not be implemented in 1.0.

2012-10-16 18:30

 

ProjInsp_sorting.patch (457 bytes)   
diff --git a/ide/projectinspector.pas b/ide/projectinspector.pas
index e60bf44..b400456 100644
--- a/ide/projectinspector.pas
+++ b/ide/projectinspector.pas
@@ -832,6 +832,8 @@ begin
   inherited Create(TheOwner);
   Name:=NonModalIDEWindowNames[nmiwProjectInspector];
   Caption:=lisMenuProjectInspector;
+  FSortAlphabetically := True;
+  SortAlphabeticallyButton.Down := FSortAlphabetically;
   KeyPreview:=true;
   SetupComponents;
   KeyPreview:=true;
ProjInsp_sorting.patch (457 bytes)   

Graeme Geldenhuys

2012-10-16 18:33

reporter   ~0063205

I haven't had time to implement this feature yet, but it was driving me crazy. So for now I simply created a patch that changes the default value to Sorted, instead of unsorted.

I know this is not the real solution, but it is a temporary work-around in the mean time (for those interested). ;-) See the attached patch file.

Juha Manninen

2012-10-20 10:32

developer   ~0063310

I applied the patch in r39145, thanks.
I will implement saving the state later.

Juha Manninen

2013-12-29 17:54

developer   ~0072084

Done.

Issue History

Date Modified Username Field Change
2012-08-09 10:22 Graeme Geldenhuys New Issue
2012-08-09 11:14 Graeme Geldenhuys Tag Attached: 1.0 rc1
2012-08-09 13:23 Mattias Gaertner Note Added: 0061533
2012-08-10 20:31 Juha Manninen Relationship added duplicate of 0022448
2012-08-14 23:07 Mattias Gaertner LazTarget => 1.2
2012-10-16 18:30 Graeme Geldenhuys File Added: ProjInsp_sorting.patch
2012-10-16 18:33 Graeme Geldenhuys Note Added: 0063205
2012-10-20 10:06 Juha Manninen Status new => assigned
2012-10-20 10:06 Juha Manninen Assigned To => Juha Manninen
2012-10-20 10:32 Juha Manninen Note Added: 0063310
2013-12-29 17:54 Juha Manninen Fixed in Revision => r43612
2013-12-29 17:54 Juha Manninen Note Added: 0072084
2013-12-29 17:54 Juha Manninen Status assigned => resolved
2013-12-29 17:54 Juha Manninen Resolution open => fixed