View Issue Details

IDProjectCategoryView StatusLast Update
0022618LazarusLCLpublic2012-08-24 12:27
ReporterErwin van den Bosch Assigned ToZeljan Rikalo  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.0.0RC1 
Summary0022618: QT: TPageControl: Tabimage can not be cleared.
DescriptionUnder QT the image of a tabsheet can not be cleared. Normaly that can be done with tabsheet.imageindex := -1; but nothing happend.

It does work under Windows but not under Linux/QT.

Another problem is the property editor of the ItemIndex. You can not select -1 (or no image).
TagsNo tags attached.
Fixed in Revision38320,38321,38325
LazTarget-
WidgetsetQT
Attached Files

Activities

Zeljan Rikalo

2012-08-21 07:24

developer   ~0061788

Can you test with trunk ? I think it's fixed there ... so maybe I'll merge that revisions.

Zeljan Rikalo

2012-08-21 08:03

developer   ~0061790

Please attach example

Zeljan Rikalo

2012-08-22 07:39

developer   ~0061801

qt is fixed in 38320, part of LCL is fixed in 38321 ... still got problems with TTabSheet.ImageIndex editor, since -1 value isn't in the list but duplicate 0 value.

Zeljan Rikalo

2012-08-22 08:42

developer   ~0061803

Please test and close if ok.

Erwin van den Bosch

2012-08-24 12:27

reporter   ~0061856

Works perfect now Zeljan. Thanks for the fix!

Issue History

Date Modified Username Field Change
2012-08-10 20:53 Erwin van den Bosch New Issue
2012-08-10 20:53 Erwin van den Bosch Widgetset => QT
2012-08-21 07:24 Zeljan Rikalo LazTarget => -
2012-08-21 07:24 Zeljan Rikalo Note Added: 0061788
2012-08-21 07:24 Zeljan Rikalo Status new => feedback
2012-08-21 07:25 Zeljan Rikalo Status feedback => assigned
2012-08-21 07:25 Zeljan Rikalo Assigned To => Zeljan Rikalo
2012-08-21 08:03 Zeljan Rikalo Note Added: 0061790
2012-08-22 07:39 Zeljan Rikalo Note Added: 0061801
2012-08-22 08:42 Zeljan Rikalo Fixed in Revision => 38320,38321,38325
2012-08-22 08:42 Zeljan Rikalo Status assigned => resolved
2012-08-22 08:42 Zeljan Rikalo Resolution open => fixed
2012-08-22 08:42 Zeljan Rikalo Note Added: 0061803
2012-08-24 12:27 Erwin van den Bosch Status resolved => closed
2012-08-24 12:27 Erwin van den Bosch Note Added: 0061856