View Issue Details

IDProjectCategoryView StatusLast Update
0022681FPCDocumentationpublic2012-08-21 06:27
ReporterMario Ray Mahardhika Assigned ToMichael Van Canneyt  
PrioritynormalSeverityfeatureReproducibilityalways
Status closedResolutionfixed 
Target Version2.6.1Fixed in Version3.0.0 
Summary0022681: FPC seems to support Slice(), yet it's nowhere documented
DescriptionThe following program compiles fine:

{$mode objfpc}

procedure tryslice(arr: array of integer);
begin
  //
end;

begin
  tryslice(slice([1,2,3],2));
end.

but the documentation doesn't mention it anywhere
TagsNo tags attached.
Fixed in Revision941
FPCOldBugId
FPCTarget
Attached Files

Relationships

child of 0004872 closedFlorian Slice (dynarray,x) doesn't work. 

Activities

Marco van de Voort

2012-08-20 07:38

manager   ~0061744

IIRC slice is an addition that came fairly late (2.2.0?) Maybe that is the reason it wasn't documented.

Mario Ray Mahardhika

2012-08-20 10:15

reporter   ~0061747

Time to document then, I guess :"> (2.2.0 is around 5 years ago, right?)

Michael Van Canneyt

2012-08-20 22:58

administrator   ~0061785

Fixed. I didn't even know this function existed. learned something new myself :)

Issue History

Date Modified Username Field Change
2012-08-20 04:42 Mario Ray Mahardhika New Issue
2012-08-20 04:42 Mario Ray Mahardhika Status new => assigned
2012-08-20 04:42 Mario Ray Mahardhika Assigned To => Michael Van Canneyt
2012-08-20 07:38 Marco van de Voort Note Added: 0061744
2012-08-20 07:38 Marco van de Voort Relationship added child of 0004872
2012-08-20 10:15 Mario Ray Mahardhika Note Added: 0061747
2012-08-20 22:58 Michael Van Canneyt Fixed in Revision => 941
2012-08-20 22:58 Michael Van Canneyt Status assigned => resolved
2012-08-20 22:58 Michael Van Canneyt Fixed in Version => 2.7.1
2012-08-20 22:58 Michael Van Canneyt Resolution open => fixed
2012-08-20 22:58 Michael Van Canneyt Note Added: 0061785
2012-08-20 22:58 Michael Van Canneyt Target Version => 2.6.1
2012-08-21 06:27 Mario Ray Mahardhika Status resolved => closed