View Issue Details

IDProjectCategoryView StatusLast Update
0022715LazarusWidgetsetpublic2016-02-18 15:42
ReporterValdas Jankūnas Assigned ToZeljan Rikalo  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
PlatformLinux 3.5.0-4-generic x86_64OSKubuntu 
Product Version1.1 (SVN) 
Summary0022715: [Qt] symbol '>' confuses MemoAppend
Description I found that if I append text which contains symbol '>' to Memo end then that line appears before last line in Memo. Try attached example.
 In GTK2 ws this bug not occurs.
Steps To ReproducePlace Memo on form and do this code:
    Memo1.Append('2');
    Memo1.Append('1');

    Memo1.Append('3');
    Memo1.Append('4>');
After execution I got in Memo:
2
1
4>
3
TagsNo tags attached.
Fixed in Revision38365,38367
LazTarget-
WidgetsetQT
Attached Files

Relationships

related to 0029670 resolvedZeljan Rikalo Insert fails when the count is less than three 

Activities

2012-08-24 19:01

 

LazarusTestas_01.tar.gz (128,228 bytes)

Zeljan Rikalo

2012-08-25 06:51

developer   ~0061873

Please test and close if ok. Note that with this fix Qt TMemo will be slower because we are using internal TQtTextEdit.insertLine() instead of TQtTextEdit.Append().Final solution is to use QPlainTextEdit instead of QTextEdit class from Qt, but problem is that QPlainTextEdit does not have alignment property (and probably some others), so TMemo will be incompleted in that case.

Zeljan Rikalo

2012-08-25 07:24

developer   ~0061874

Workaround for slowness: when inserting a lot of lines, disable wordwrap and then enable it again.

Zeljan Rikalo

2012-08-25 10:09

developer   ~0061877

Reopened to add speed improvement revision

Zeljan Rikalo

2012-08-25 10:10

developer   ~0061878

Please test and close if ok. Commit r38367 contains speed improvement.

Zeljan Rikalo

2012-08-25 10:46

developer   ~0061879

Also, r38368 and r38369 are needed.

Valdas Jankūnas

2012-08-25 20:32

reporter   ~0061899

Thank You.

Issue History

Date Modified Username Field Change
2012-08-24 19:01 Valdas Jankūnas New Issue
2012-08-24 19:01 Valdas Jankūnas File Added: LazarusTestas_01.tar.gz
2012-08-24 19:01 Valdas Jankūnas Widgetset => QT
2012-08-24 20:19 Zeljan Rikalo Status new => assigned
2012-08-24 20:19 Zeljan Rikalo Assigned To => Zeljan Rikalo
2012-08-25 06:51 Zeljan Rikalo Fixed in Revision => 38365
2012-08-25 06:51 Zeljan Rikalo LazTarget => -
2012-08-25 06:51 Zeljan Rikalo Status assigned => resolved
2012-08-25 06:51 Zeljan Rikalo Resolution open => fixed
2012-08-25 06:51 Zeljan Rikalo Note Added: 0061873
2012-08-25 07:24 Zeljan Rikalo Note Added: 0061874
2012-08-25 10:09 Zeljan Rikalo Status resolved => assigned
2012-08-25 10:09 Zeljan Rikalo Resolution fixed => reopened
2012-08-25 10:09 Zeljan Rikalo Note Added: 0061877
2012-08-25 10:10 Zeljan Rikalo Fixed in Revision 38365 => 38365,38367
2012-08-25 10:10 Zeljan Rikalo Status assigned => resolved
2012-08-25 10:10 Zeljan Rikalo Resolution reopened => fixed
2012-08-25 10:10 Zeljan Rikalo Note Added: 0061878
2012-08-25 10:46 Zeljan Rikalo Note Added: 0061879
2012-08-25 20:32 Valdas Jankūnas Status resolved => closed
2012-08-25 20:32 Valdas Jankūnas Note Added: 0061899
2016-02-18 15:42 Zeljan Rikalo Relationship added related to 0029670