View Issue Details

IDProjectCategoryView StatusLast Update
0022777LazarusIDEpublic2012-10-15 08:21
ReporterEdson Lidorio Assigned ToJuha Manninen  
PrioritynormalSeveritytrivialReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version1.0.0 
Summary0022777: Window Latch Jedi Code Format
DescriptionGood morning,

Please verify that this problem is happening with Lazarus 1.0:

By making the code indentation by Jedi Code Format, and if the code is in error, eg error left "end", the Jedi Code Format window will open on screen and will stay locked on the screen, it just closes with keys ALT + F4.
I'm using 1.0 Lazaru.
Follow the attached image

Edson
TagsNo tags attached.
Fixed in Revisionr39049
LazTarget-
Widgetset
Attached Files

Relationships

has duplicate 0023101 resolvedJuha Manninen Jedi Code Formatter Form does not show ScreenCenter 

Activities

2012-09-02 02:22

 

janela_error.png (52,021 bytes)   
janela_error.png (52,021 bytes)   

Edson Lidorio

2012-09-10 00:38

reporter   ~0062253

This continues bug in versions: 1.0,1.01 and 1.1 of Lazarus. Lazarus is correct in 09.30.4.

Juha Manninen

2012-09-30 09:26

developer   ~0062764

I cannot reproduce, here the window opens correctly.
Please try deleting your local Lazarus configuration. Then default values will be used again.

Juha Manninen

2012-10-07 12:59

developer   ~0062970

Did you try deleting your local Lazarus configuration? Does it work better then?

Edson Lidorio

2012-10-10 14:35

reporter   ~0063058

Hello Juha Manninen,

Already did that, the normal window opens, if any more code is in error, it opens misaligned. Example error "begin End;".

Juha Manninen

2012-10-11 18:58

developer   ~0063087

Ok, the form's Position = poOwnerFormCenter,
but the owner is not a form at all. It is the Application :

  lfParseTree := TfrmShowParseTree.Create(Application);

I changed it to Position = poScreenCenter.
Please test with r39049.

Edson Lidorio

2012-10-12 14:46

reporter   ~0063099

I did a test with rev. Lazarus-1.0.3-39053-fpc-2.6.0-20121012-win32.
Still having the problem. noendereƧo see image below:

http://imagebin.org/231746

Edson Lidorio

2012-10-12 15:07

reporter   ~0063100

Note: The window and frumpy created when a code format vai's even with errors, eg errors "begin end".

Juha Manninen

2012-10-12 19:22

developer   ~0063107

Last edited: 2012-10-12 19:43

You should build clean. The change is only in the .lfm file and the compiler does not always notice it.

Delete your local configuration again to make sure the window location is not saved. Also check that fShowParseTree form has Position = poScreenCenter.
You can experiment with other Position choises, too.

I cannot reproduce the problem but I believe it is solved if the configuration is "clean".

John Landmesser, can you please also test with latest trunk.

Edson Lidorio

2012-10-13 11:59

reporter   ~0063123

Last edited: 2012-10-13 12:00

follows a code attached

reproduir try with this code.

2012-10-13 12:02

 

jedi.7z (60,138 bytes)

2012-10-13 13:17

 

JFCParseTree.jpg (110,027 bytes)   
JFCParseTree.jpg (110,027 bytes)   

Juha Manninen

2012-10-13 13:24

developer   ~0063126

Last edited: 2012-10-13 17:41

For me the window opens at screen center as it is supposed. I attached a screenshot as a proof.

Does John Landmesser still have the same problem? What about others?

Edson, did you build "clean", meaning did you remove old .ppu files?
You can do it also by selecting "Clean all" in Configure Build Lazarus window.

Edson Lidorio

2012-10-14 02:47

reporter   ~0063134

A detail:
I performed a test on the new machine with virtualbox, and the result was this:
With Lazarus below:
Lazarus-1.1-39073-fpc-2.6.0-20121014-win32.exe
The window of the jedi code format appears normal.

Lazarus-1.0.3-39061-fpc-2.6.0-20121013-win32.exe
The jedi code format window appears with the same problem.

2012-10-14 02:48

 

jedi2.PNG (36,220 bytes)   
jedi2.PNG (36,220 bytes)   

Juha Manninen

2012-10-14 11:34

developer   ~0063137

Ok, it means the problem is solved by r39049.
I can mark it for inclusion for Lazarus 1.0.3 fixes branch and Lazarus 1.0.4 will have it.

John Landmesser

2012-10-15 08:21

reporter   ~0063170

i think its fixed now on my:

Lazarus 1.1 r39086 FPC 2.6.1 i386-win32-win32/win64

Issue History

Date Modified Username Field Change
2012-09-02 02:22 Edson Lidorio New Issue
2012-09-02 02:22 Edson Lidorio File Added: janela_error.png
2012-09-10 00:38 Edson Lidorio Note Added: 0062253
2012-09-30 09:24 Juha Manninen Status new => assigned
2012-09-30 09:24 Juha Manninen Assigned To => Juha Manninen
2012-09-30 09:26 Juha Manninen Note Added: 0062764
2012-10-07 12:59 Juha Manninen LazTarget => -
2012-10-07 12:59 Juha Manninen Note Added: 0062970
2012-10-07 12:59 Juha Manninen Status assigned => feedback
2012-10-10 14:35 Edson Lidorio Note Added: 0063058
2012-10-11 18:10 Juha Manninen Relationship added has duplicate 0023101
2012-10-11 18:58 Juha Manninen Note Added: 0063087
2012-10-12 14:46 Edson Lidorio Note Added: 0063099
2012-10-12 15:07 Edson Lidorio Note Added: 0063100
2012-10-12 19:22 Juha Manninen Note Added: 0063107
2012-10-12 19:43 Juha Manninen Note Edited: 0063107
2012-10-13 11:59 Edson Lidorio Note Added: 0063123
2012-10-13 12:00 Edson Lidorio Note Edited: 0063123
2012-10-13 12:02 Edson Lidorio File Added: jedi.7z
2012-10-13 13:17 Juha Manninen File Added: JFCParseTree.jpg
2012-10-13 13:24 Juha Manninen Note Added: 0063126
2012-10-13 17:41 Juha Manninen Note Edited: 0063126
2012-10-14 02:47 Edson Lidorio Note Added: 0063134
2012-10-14 02:48 Edson Lidorio File Added: jedi2.PNG
2012-10-14 11:34 Juha Manninen Status feedback => resolved
2012-10-14 11:34 Juha Manninen Resolution open => fixed
2012-10-14 11:34 Juha Manninen Note Added: 0063137
2012-10-14 11:35 Juha Manninen Fixed in Revision => r39049
2012-10-15 08:21 John Landmesser Note Added: 0063170