View Issue Details

IDProjectCategoryView StatusLast Update
0022779LazarusIDEpublic2020-11-04 10:29
ReporterZaher Dirkey Assigned ToJuha Manninen  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionunable to reproduce 
OSLinux 
Summary0022779: Package: Adding httpd.pas link error in linux
DescriptionIf added httpd unit to one of package units then install it, it make errors when compiling Lazarus in linking.

I use linux OpenSuse 12.1, and same in ubuntu.
and last revision of Lazarus, FPC 2.6

In windows it works fine

The problem not happned if i used httpd.pas in the project directly, but in package it give me that error when linking Lazarus.

I have one httpd, only httpd22
/usr/lib/fpc/2.6.0/units/i386-linux/httpd22
and there is httpd.ppu

discussed here
http://comments.gmane.org/gmane.comp.ide.lazarus.general/63465
Additional Information
And this the error messages with hidden.

--------------------------------------------------
/usr/bin/env: bash
: No such file or directory
make: Entering directory `/mnt/dev/programs/lazarus'
/usr/bin/make -C ide ide
make[1]: Entering directory `/mnt/dev/programs/lazarus/ide'
../tools/svn2revisioninc .. revision.inc
Created /mnt/dev/programs/lazarus/ide/revision.inc for revision: 37853M
/usr/bin/make --assume-new=lazarus.pp lazarus
make[2]: Entering directory `/mnt/dev/programs/lazarus/ide'
/usr/bin/fpc -gl -Sci -dlclgtk2 -Fu../lcl/units/i386-linux -Fu../lcl/units/i386-linux/gtk2 -Fu../components/codetools/units/i386-linux -Fu../components/lazutils/lib/i386-linux -Fu../components/synedit/units/i386-linux/gtk2 -Fu../components/lazcontrols/lib/i386-linux/gtk2 -Fu../components/custom -Fu../ideintf/units/i386-linux/gtk2 -Fu../designer -Fu../debugger -Fu../debugger/frames -Fu../converter -Fu../packager -Fu../packager/frames -Fu../packager/units/i386-linux -Fu../units/i386-linux/gtk2 -Fuframes -Fu. -Fu/usr/lib/fpc/2.6.0/units/i386-linux/rtl -Fu/usr/lib/fpc/2.6.0/units/i386-linux/paszlib -Fu/usr/lib/fpc/2.6.0/units/i386-linux/fcl-process -Fu/usr/lib/fpc/2.6.0/units/i386-linux/hash -Fu/usr/lib/fpc/2.6.0/units/i386-linux/fpmkunit -Fu/usr/lib/fpc/2.6.0/units/i386-linux/regexpr -Fiinclude -Fiinclude/linux -Fi../images -FE.. -FU../units/i386-linux/gtk2 -Fl/usr/lib/gcc/i586-suse-linux/4.6 -Fl/usr/local/lib -Flinclude -Fl/etc/ld.so.conf.d/*.conf -O2 -g- -Xs @/mnt/dev/workspace/lazarus/linux/idemake.cfg -di386 lazarus.pp
Free Pascal Compiler version 2.6.0 [2011/12/23] for i386
Copyright (c) 1993-2011 by Florian Klaempfl and others
Target OS: Linux for i386
Compiling lazarus.pp
Compiling resource ../units/i386-linux/gtk2/lazarus.or
Linking ../lazarus

/usr/bin/ld: warning: ../link.res contains output sections; did you forget -T?
/usr/lib/fpc/2.6.0/units/i386-linux/httpd22/httpd.o: In function `HTTPD_AP_ESCAPE_URI$PAPR_POOL_T$PCHAR$$PCHAR':
httpd.pas:(.text+0x48): undefined reference to `ap_os_escape_path'
/usr/lib/fpc/2.6.0/units/i386-linux/httpd22/apr.o: In function `APR_APR_POOL_CREATE$PPAPR_POOL_T$PAPR_POOL_T$$LONGINT':
apr.pas:(.text+0xa): undefined reference to `apr_pool_create_ex'
/usr/lib/fpc/2.6.0/units/i386-linux/httpd22/apr.o: In function `APR_APR_POOL_SUB_MAKE$PPAPR_POOL_T$PAPR_POOL_T$APR_ABORTFUNC_T$$LONGINT':
apr.pas:(.text+0x29): undefined reference to `apr_pool_create_ex'
lazarus.pp(133,1) Error: Error while linking

/usr/bin/ld: warning: ../link.res contains output sections; did you forget -T?
/usr/lib/fpc/2.6.0/units/i386-linux/httpd22/httpd.o: In function `HTTPD_AP_ESCAPE_URI$PAPR_POOL_T$PCHAR$$PCHAR':
httpd.pas:(.text+0x48): undefined reference to `ap_os_escape_path'
/usr/lib/fpc/2.6.0/units/i386-linux/httpd22/apr.o: In function `APR_APR_POOL_CREATE$PPAPR_POOL_T$PAPR_POOL_T$$LONGINT':
apr.pas:(.text+0xa): undefined reference to `apr_pool_create_ex'
/usr/lib/fpc/2.6.0/units/i386-linux/httpd22/apr.o: In function `APR_APR_POOL_SUB_MAKE$PPAPR_POOL_T$PAPR_POOL_T$APR_ABORTFUNC_T$$LONGINT':
apr.pas:(.text+0x29): undefined reference to `apr_pool_create_ex'
/mnt/dev/programs/lazarus/ide/lazarus.pp(133,1) Error: Error while linking
/mnt/dev/programs/lazarus/ide/lazarus.pp(133,1) Fatal: There were 1 errors compiling module, stopping
--------------------------------------------------
or with compiler flags -vut
----------------------------------------
Options changed, recompiling clean with -B
PPU Loading /usr/lib/fpc/2.6.0/units/i386-linux/rtl/system.ppu
PPU Loading /usr/lib/fpc/2.6.0/units/i386-linux/rtl/lineinfo.ppu
PPU Loading /usr/lib/fpc/2.6.0/units/i386-linux/rtl/exeinfo.ppu
PPU Loading /usr/lib/fpc/2.6.0/units/i386-linux/rtl/strings.ppu
PPU Loading /usr/lib/fpc/2.6.0/units/i386-linux/rtl/fpintres.ppu
PPU Loading /usr/lib/fpc/2.6.0/units/i386-linux/rtl/objpas.ppu
PPU Loading /usr/lib/fpc/2.6.0/units/i386-linux/rtl/sysutils.ppu
PPU Loading /usr/lib/fpc/2.6.0/units/i386-linux/rtl/unix.ppu
PPU Loading /usr/lib/fpc/2.6.0/units/i386-linux/rtl/baseunix.ppu
PPU Loading /usr/lib/fpc/2.6.0/units/i386-linux/rtl/unixtype.ppu
PPU Loading /usr/lib/fpc/2.6.0/units/i386-linux/rtl/unixutil.ppu
PPU Loading /usr/lib/fpc/2.6.0/units/i386-linux/rtl/syscall.ppu
PPU Loading /usr/lib/fpc/2.6.0/units/i386-linux/rtl/errors.ppu
PPU Loading /usr/lib/fpc/2.6.0/units/i386-linux/rtl/sysconst.ppu
PPU Loading /usr/lib/fpc/2.6.0/units/i386-linux/httpd22/httpd.ppu
PPU Loading /usr/lib/fpc/2.6.0/units/i386-linux/httpd22/apr.ppu
PPU Loading /usr/lib/fpc/2.6.0/units/i386-linux/rtl/ctypes.ppu
PPU Loading /usr/lib/fpc/2.6.0/units/i386-linux/httpd22/aprutil.ppu
mod_hello.lpr(45,3) Note: Local variable "Line" not used
mod_hello.lpr(46,3) Note: Local variable "Head" not used
mod_hello.lpr(47,3) Note: Local variable "Access" not used
mod_hello.lpr(141,25) Hint: Parameter "p" not used
PPU Loading /usr/lib/fpc/2.6.0/units/i386-linux/rtl/si_dll.ppu
Project "project1" successfully built
----------------------------------------
Tagsapache
Fixed in Revision
LazTarget-
WidgetsetGTK 2
Attached Files

Activities

2012-09-02 11:52

 

myhttpd.zip (966 bytes)

Juha Manninen

2014-10-19 14:41

developer   ~0078379

Not a bug in Lazarus. Works with right lib versions.

Issue History

Date Modified Username Field Change
2012-09-02 11:52 Zaher Dirkey New Issue
2012-09-02 11:52 Zaher Dirkey File Added: myhttpd.zip
2012-09-02 11:52 Zaher Dirkey Widgetset => GTK 2
2012-09-02 11:54 Zaher Dirkey Tag Attached: apache
2014-10-19 14:41 Juha Manninen LazTarget => -
2014-10-19 14:41 Juha Manninen Note Added: 0078379
2014-10-19 14:41 Juha Manninen Status new => resolved
2014-10-19 14:41 Juha Manninen Resolution open => unable to reproduce
2014-10-19 14:41 Juha Manninen Assigned To => Juha Manninen
2020-11-04 10:29 Zaher Dirkey Status resolved => closed