View Issue Details

IDProjectCategoryView StatusLast Update
0022784FPCRTLpublic2012-09-13 22:41
ReporterGennadiy Assigned ToJonas Maebe  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionno change required 
Platformarm-winceOSWindows 
Product Version2.7.1 
Summary0022784: RTL for arm-wince fails to build
DescriptionThe following error is encountered when building RTL for arm-wince:

Start compiling package chm for target arm-wince.
       Compiling chm\BuildUnit_chm.pp
       Compiling .\chm\src\chmbase.pas
       Compiling .\chm\src\chmtypes.pas
The installer encountered the following error:
External command "C:/Dev/FPC/sources/compiler/ppcrossarm.exe -Twince -FUchm\units\arm-wince\ -FuC:\Dev\FPC\sources\rtl\units\arm-wince\ -FuC:\Dev\FPC\sources\packages\fcl-xml\units\arm-wince\ -FuC:\Dev\FPC\sources\packages\fcl-base\units\arm-wince\ -Fuchm\src -Twince -Parm -XParm-wince- -Xr -Ur -Xs -O2 -n -FuC:/Dev/FPC/sources/rtl/units/arm-wince -darm -dRELEASE -viq chm\BuildUnit_chm.pp" failed with exit code 1. Console output:
Target OS: WinCE for ARM
Compiling chm\BuildUnit_chm.pp
Compiling .\chm\src\chmbase.pas
Assembling chmbase
Compiling .\chm\src\chmtypes.pas
PPU Loading .\fcl-xml\units\arm-wince\xmlcfg.ppu
PPU Source: xmlcfg.pp not available
Recompiling XMLCfg, checksum changed for System
chmtypes.pas(28,21) Fatal: Can't find unit XMLCfg used by chmtypes
Fatal: Compilation aborted

make[2]: *** [all] Error 1
make[2]: Leaving directory `C:/Dev/FPC/sources/packages'
make[1]: *** [packages_all] Error 2
make[1]: Leaving directory `C:/Dev/FPC/sources'
make: *** [build-stamp.arm-wince] Error 2
Steps To Reproducemake distclean
make zipinstall CROSSINSTALL=1 CPU_TARGET=arm OS_TARGET=wince SNAPSHOT=1
Tagsarm, rtl, wince
Fixed in Revision
FPCOldBugId
FPCTarget
Attached Files

Activities

Gennadiy

2012-09-03 19:46

reporter   ~0062051

assembler tag added by accident.

Jonas Maebe

2012-09-13 15:20

manager   ~0062328

Try manually deleting all arm-wince directories under packages. Since the introduction of fpmake "make distclean" sometimes leaves behind some old units directories.

Gennadiy

2012-09-13 20:57

reporter   ~0062339

I've done it hardcore way -- deleted and rechecked all of trunk. And it worked!
Everything is compiling now. Thank you.

Issue History

Date Modified Username Field Change
2012-09-03 19:45 Gennadiy New Issue
2012-09-03 19:45 Gennadiy Tag Attached: arm
2012-09-03 19:45 Gennadiy Tag Attached: wince
2012-09-03 19:45 Gennadiy Tag Attached: assembler
2012-09-03 19:45 Gennadiy Tag Attached: rtl
2012-09-03 19:46 Gennadiy Note Added: 0062051
2012-09-13 15:20 Jonas Maebe Note Added: 0062328
2012-09-13 15:20 Jonas Maebe Tag Detached: assembler
2012-09-13 17:41 Jonas Maebe Status new => feedback
2012-09-13 20:57 Gennadiy Note Added: 0062339
2012-09-13 22:41 Jonas Maebe Status feedback => resolved
2012-09-13 22:41 Jonas Maebe Resolution open => no change required
2012-09-13 22:41 Jonas Maebe Assigned To => Jonas Maebe