View Issue Details

IDProjectCategoryView StatusLast Update
0022823LazarusLCLpublic2012-09-07 14:03
ReporterGiulio BernardiAssigned ToMartin Friebe 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Platform Linux x86_64, fpc 2.6.0OSLinux x86_64 OS VersionFedora 16
Product Version1.1 (SVN)Product Build38549 
Target Version1.2.0Fixed in Version1.1 (SVN) 
Summary0022823: SynEdit: Crash while exporting using a TMultiSyn highlighter
DescriptionThe attached program uses a TSynMultiSyn. The export button should export all lines to the clipboard, but I receive a SIGSEGV in TSynCustomExporter.SetTokenAttribute.
Ok, it is a little bit useless to export html code to html, but it's just to show the bug.
Steps To ReproduceCompile and run the attached program.
Click on Export button.
TagsNo tags attached.
Fixed in Revision38554
LazTarget1.2
WidgetsetGTK 2
Attached Files

Activities

2012-09-07 09:20

 

multisynbug.tar.bz2 (3,409 bytes)

Martin Friebe

2012-09-07 13:38

manager   ~0062165

Please test with rev 38554

Please note, you may need to stick with 1.1 (trunk) as this change will not (or only later) be merged to fixes.

If you wish to use fixes, you can copy the unit syneditexport.pas from trunk. The changes should work with fixes.

Martin Friebe

2012-09-07 13:51

manager   ~0062166

There is some issue with the clipboard (at least on some OS). But SaveToStream works.

Not sure if the clipboard issue is in SynEdit. Investigating...

Giulio Bernardi

2012-09-07 14:03

reporter   ~0062169

It works for me (at least, on Linux), thank you.
Not sure if I should close, given the last comment from yours.

Issue History

Date Modified Username Field Change
2012-09-07 09:20 Giulio Bernardi New Issue
2012-09-07 09:20 Giulio Bernardi File Added: multisynbug.tar.bz2
2012-09-07 09:20 Giulio Bernardi Widgetset => GTK 2
2012-09-07 11:05 Martin Friebe Status new => assigned
2012-09-07 11:05 Martin Friebe Assigned To => Martin Friebe
2012-09-07 13:38 Martin Friebe Fixed in Revision => 38554
2012-09-07 13:38 Martin Friebe LazTarget => 1.2
2012-09-07 13:38 Martin Friebe Status assigned => resolved
2012-09-07 13:38 Martin Friebe Fixed in Version => 1.1 (SVN)
2012-09-07 13:38 Martin Friebe Resolution open => fixed
2012-09-07 13:38 Martin Friebe Note Added: 0062165
2012-09-07 13:38 Martin Friebe Target Version => 1.2.0
2012-09-07 13:51 Martin Friebe Note Added: 0062166
2012-09-07 14:03 Giulio Bernardi Note Added: 0062169