View Issue Details

IDProjectCategoryView StatusLast Update
0022842LazarusIDEpublic2013-03-18 07:37
ReporterGennadiy Assigned ToVincent Snijders  
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
PlatformLinux x86_64OSGentoo Linux 
Product Version1.1 (SVN) 
Summary0022842: Lazarus crashes on first start
DescriptionI built latest trunk Lazarus with latest trunk fpc 2.7.1.
After start, this happens:
1. Splash screen is shown
2. Configuration dialog is shown, in which I specify the path to fpc sources as the only missing setting
3. Then I click "Start IDE" and it throws multiple "Access Violation" and other errors, then hangs.

Inspiron lazarus # lazarus-ide
TMainIDE.ParseCmdLineOptions:
  PrimaryConfigPath="/root/.lazarus"
  SecondaryConfigPath="/etc/lazarus"
NOTE: editor options config file not found - using defaults
NOTE: codetools config file not found - using defaults
Warning: incompatible Lazarus directory: /root/.lazarus
SearchLazarusDirectoryCandidates Value=. File=/root/.lazarus
SearchLazarusDirectoryCandidates Value=/usr/local/share/lazarus File=/usr/local/share/lazarus
SearchLazarusDirectoryCandidates Value=/usr/share/lazarus File=/usr/share/lazarus
SearchLazarusDirectoryCandidates Value=/usr/local/lib/lazarus File=/usr/local/lib/lazarus
SearchLazarusDirectoryCandidates Value=/usr/local/lazarus File=/usr/local/lazarus
SearchLazarusDirectoryCandidates Value=/usr/lib/lazarus File=/usr/lib/lazarus
SearchLazarusDirectoryCandidates Value=/usr/lib/lazarus/1.1 File=/usr/lib/lazarus/1.1
SearchLazarusDirectoryCandidates Value=~/pascal/lazarus File=/root/pascal/lazarus
SearchLazarusDirectoryCandidates Value=~/lazarus File=/root/lazarus
SearchCompilerCandidates Value=/usr/bin/fpc File=/usr/bin/fpc
TFPCTargetConfigCache.NeedsUpdate TargetOS="" TargetCPU="" compiler file changed "/usr/bin/fpc" FileAge=1347168018 StoredAge=1322469112
TFPCTargetConfigCache.Update /usr/bin/fpc TargetOS= TargetCPU= CompilerOptions= ExtraOptions= PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/opt/bin:/usr/x86_64-pc-linux-gnu/gcc-bin/4.5.4:/usr/lib64/subversion/bin
RunTool /usr/bin/fpc -iWTOTP -Px86_64 -Tlinux
RunTool /usr/bin/fpc -va -Px86_64 -Tlinux compilertest.pas
TFPCTargetConfigCache.Update: has changed
SearchCompilerCandidates Value=/usr/local/bin/fpc File=/usr/local/bin/fpc
SearchCompilerCandidates Value=/opt/fpc/fpc File=/opt/fpc/fpc
SearchCompilerCandidates Value=$(LazarusDir)/fpc/bin/$(TargetCPU)-$(TargetOS)/fpc File=/usr/local/share/lazarus/fpc/bin/x86_64-linux/fpc
SearchCompilerCandidates Value=/usr/local/bin/fpc File=/usr/local/bin/fpc
SearchCompilerCandidates Value=/opt/fpc/fpc File=/opt/fpc/fpc
TFPCTargetConfigCache.NeedsUpdate TargetOS="linux" TargetCPU="x86_64" compiler file changed "/usr/bin/fpc" FileAge=1347168018 StoredAge=1322469112
TFPCTargetConfigCache.Update /usr/bin/fpc TargetOS=linux TargetCPU=x86_64 CompilerOptions= ExtraOptions=-Fr/root/.lazarus/components/codetools/fpc.errore.msg PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/opt/bin:/usr/x86_64-pc-linux-gnu/gcc-bin/4.5.4:/usr/lib64/subversion/bin
RunTool /usr/bin/fpc -iWTOTP -Px86_64 -Tlinux -Fr/root/.lazarus/components/codetools/fpc.errore.msg
RunTool /usr/bin/fpc -va -Px86_64 -Tlinux -Fr/root/.lazarus/components/codetools/fpc.errore.msg compilertest.pas
TFPCTargetConfigCache.Update: has changed
SearchFPCSrcDirCandidates Value=$(LazarusDir)/fpc/$(FPCVer)/source File=/usr/local/share/lazarus/fpc/2.7.1/source/
SearchFPCSrcDirCandidates Value=$Path($(CompPath))/../../source File=/source/
SearchFPCSrcDirCandidates Value=/usr/share/fpcsrc/$(FPCVer) File=/usr/share/fpcsrc/2.7.1/
SearchFPCSrcDirCandidates Value=/usr/share/fpcsrc File=/usr/share/fpcsrc/
SearchFPCSrcDirCandidates Value=/usr/local/share/fpcsrc File=/usr/local/share/fpcsrc/
SearchFPCSrcDirCandidates Value=/usr/fpcsrc File=/usr/fpcsrc/
SearchFPCSrcDirCandidates Value=/usr/share/fpc/src File=/usr/share/fpc/src/
SearchFPCSrcDirCandidates Value=/usr/fpc/src File=/usr/fpc/src/
SearchFPCSrcDirCandidates Value=/usr/local/fpc/src File=/usr/local/fpc/src/
SearchFPCSrcDirCandidates Value=/usr/local/share/fpc/src File=/usr/local/share/fpc/src/
SearchFPCSrcDirCandidates Value=/usr/local/src/fpc File=/usr/local/src/fpc/
SearchFPCSrcDirCandidates Value=/usr/lib/fpc/src File=/usr/lib/fpc/src/
SearchFPCSrcDirCandidates Value=/usr/local/lib/fpc/src File=/usr/local/lib/fpc/src/
SearchFPCSrcDirCandidates Value=/vol/fpc/src File=/vol/fpc/src/
SearchFPCSrcDirCandidates Value=/vol/lib/fpc/src File=/vol/lib/fpc/src/
SearchFPCSrcDirCandidates Value=/usr/src/fpc File=/usr/src/fpc/
SearchFPCSrcDirCandidates Value=/vol/src/fpc File=/vol/src/fpc/
SearchMakeExeCandidates Value=make File=/usr/bin/make
SearchMakeExeCandidates Value=/usr/bin/make File=/usr/bin/make
SearchDebuggerCandidates Value=$(LazarusDir)/mingw/$(TargetCPU)-$(TargetOS)/bin/gdb File=/usr/local/share/lazarus/mingw/x86_64-linux/bin/gdb
SearchDebuggerCandidates Value=$(LazarusDir)/mingw/bin/gdb File=/usr/local/share/lazarus/mingw/bin/gdb
SearchDebuggerCandidates Value=gdb File=/usr/bin/gdb
[TMainIDE.Destroy] A
[FORMS.PP] ExceptionOccurred
  Sender=EAccessViolation
  Exception=Access violation
  Stack trace:
  $00000000007786F5
TApplication.HandleException Access violation
  Stack trace:
  $00000000007786F5
[FORMS.PP] ExceptionOccurred
  Sender=EAccessViolation
  Exception=Access violation
  Stack trace:
  $00000000007786F5
TApplication.HandleException Access violation
  Stack trace:
  $00000000007786F5
[FORMS.PP] ExceptionOccurred
  Sender=EAccessViolation
  Exception=Access violation
  Stack trace:
  $00000000007786F5
TApplication.HandleException Access violation
  Stack trace:
  $00000000007786F5
[FORMS.PP] ExceptionOccurred
  Sender=EAccessViolation
  Exception=Access violation
  Stack trace:
  $00000000007786F5
TApplication.HandleException Access violation
  Stack trace:
  $00000000007786F5
[FORMS.PP] ExceptionOccurred
  Sender=EAccessViolation
  Exception=Access violation
  Stack trace:
  $00000000007786F5
TApplication.HandleException Access violation
  Stack trace:
  $00000000007786F5
[FORMS.PP] ExceptionOccurred
  Sender=EAccessViolation
  Exception=Access violation
  Stack trace:
  $00000000007786F5
TApplication.HandleException Access violation
  Stack trace:
  $00000000007786F5
[FORMS.PP] ExceptionOccurred
  Sender=EAccessViolation
  Exception=Access violation
  Stack trace:
  $00000000007786F5
TApplication.HandleException Access violation
  Stack trace:
  $00000000007786F5
[FORMS.PP] ExceptionOccurred
  Sender=EAccessViolation
  Exception=Access violation
  Stack trace:
  $00000000007786F5
TApplication.HandleException Access violation
  Stack trace:
  $00000000007786F5
[FORMS.PP] ExceptionOccurred
  Sender=EAccessViolation
  Exception=Access violation
  Stack trace:
  $00000000007786F5
TApplication.HandleException Access violation
  Stack trace:
  $00000000007786F5
[FORMS.PP] ExceptionOccurred
  Sender=EAccessViolation
  Exception=Access violation
  Stack trace:
  $00000000007786F5
TApplication.HandleException Access violation
  Stack trace:
  $00000000007786F5
[FORMS.PP] ExceptionOccurred
  Sender=EAccessViolation
  Exception=Access violation
  Stack trace:
  $00000000007786F5
TApplication.HandleException Access violation
  Stack trace:
  $00000000007786F5
[FORMS.PP] ExceptionOccurred
  Sender=EAccessViolation
  Exception=Access violation
  Stack trace:
  $00000000007786F5
TApplication.HandleException Access violation
  Stack trace:
  $00000000007786F5
[FORMS.PP] ExceptionOccurred
  Sender=EAccessViolation
  Exception=Access violation
  Stack trace:
  $00000000007786F5
TApplication.HandleException Access violation
  Stack trace:
  $00000000007786F5
[FORMS.PP] ExceptionOccurred
  Sender=EAccessViolation
  Exception=Access violation
  Stack trace:
  $00000000007786F5
TApplication.HandleException Access violation
  Stack trace:
  $00000000007786F5
[FORMS.PP] ExceptionOccurred
  Sender=EAccessViolation
  Exception=Access violation
  Stack trace:
  $00000000007786F5
TApplication.HandleException Access violation
  Stack trace:
  $00000000007786F5
ERROR in LCL:
Creating gdb catchable error:

  $000000000088F1C5
  $00000000007C6746
  $00000000007C487B
  $00000000008A113B
  $00000000008A2683
  $000000000077148F
  $00000000007B83CC
  $000000000077148F
  $00000000007C2B8C
[FORMS.PP] ExceptionOccurred
  Sender=EDivByZero
  Exception=Division by zero
  Stack trace:
  $00000000007C48AC
TApplication.HandleException Division by zero
  Stack trace:
  $00000000007C48AC
[FORMS.PP] ExceptionOccurred
  Sender=EAccessViolation
  Exception=Access violation
  Stack trace:
  $00000000007786F5
TApplication.HandleException Access violation
  Stack trace:
  $00000000007786F5
[FORMS.PP] ExceptionOccurred
  Sender=EAccessViolation
  Exception=Access violation
  Stack trace:
  $00000000007786F5
TApplication.HandleException Access violation
  Stack trace:
  $00000000007786F5
Terminated
Steps To Reproducemake distclean
make all
make install
which lazarus-ide
lazarus-ide
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetGTK 2
Attached Files

Relationships

parent of 0022864 closedFlorian FPC Wrong code generated since r22341 
related to 0022849 resolvedMattias Gaertner Lazarus Lazarus Hangs Upon Exit When Building With Most Recent FPC on i386-win32 

Activities

Mattias Gaertner

2012-09-09 10:09

manager   ~0062208

I get different errors with current 2.7.1. Heaptrc crashes.
Maybe it's an fpc 2.7.1 bug. We have to find out which fpc 2.7.1 revision breaks Lazarus.

Gennadiy

2012-09-09 11:09

reporter   ~0062213

Yes, that seems to be the case. Rebuilt Lazarus with 2.6.0 and it worked fine.

ocean

2012-09-09 17:31

reporter   ~0062233

I started to have problems with 22340, please check that first. But that may not be the only problem..

Mattias Gaertner

2012-09-10 09:30

manager   ~0062255

Last edited: 2012-09-10 10:04

My heaptrc problems are gone with fpc 22363.

Ludo Brands

2012-09-10 09:56

developer   ~0062256

Still problems with fpc 22363 on ubunutu 10.04 x64 GTK2. Stack trace:
TApplication.HandleException Access violation
  Stack trace:
  $080726A6
  $082B1A2C TDEFAULTIMAGELISTIMPLEMENTOR__DRAW, line 120 of ./widgetset/wsimglist.pp
  $082B1DD0 TWSCUSTOMIMAGELIST__DRAW, line 210 of ./widgetset/wsimglist.pp
  $082AF51F TCUSTOMIMAGELIST__DRAW, line 520 of ./include/imglist.inc
  $082AF43B TCUSTOMIMAGELIST__DRAW, line 503 of ./include/imglist.inc
  $082AF3EE TCUSTOMIMAGELIST__DRAW, line 497 of ./include/imglist.inc
  $08257099 TTOOLBUTTON__PAINT, line 356 of ./include/toolbutton.inc
  $082275DB TGRAPHICCONTROL__WMPAINT, line 64 of ./include/graphiccontrol.inc
  $0806D356
  $0821DAD8 TCONTROL__PERFORM, line 1459 of ./include/control.inc
  $08211E53 TWINCONTROL__PAINTCONTROLS, line 4863 of ./include/wincontrol.inc
  $08211C38 TWINCONTROL__PAINTHANDLER, line 4781 of ./include/wincontrol.inc
  $08215796 TWINCONTROL__WMPAINT, line 6624 of ./include/wincontrol.inc
  $08227B22 TCUSTOMCONTROL__WMPAINT, line 112 of ./include/customcontrol.inc
  $0806D356
  $08212FAF TWINCONTROL__WNDPROC, line 5322 of ./include/wincontrol.inc
  $082C7031 DELIVERMESSAGE, line 117 of lclmessageglue.pas

lazarus (rev38607) and fpc build with -g -gl.

Mattias Gaertner

2012-09-10 10:06

manager   ~0062257

Can you reproduce this easily and find the fpc revision that broke it?
We need this to create a bug report for fpc.

Ludo Brands

2012-09-10 10:07

developer   ~0062258

Better bt from gdb:

#0 0x080726a6 in SYSTEM_$$_FINISH_WAITVARLIST$PFREELISTS ()
0000001 0x080726f3 in SYSTEM_$$_TRY_FINISH_WAITVARLIST$PFREELISTS ()
0000002 0x080722a6 in SYSTEM_$$_SYSGETMEM_VAR$LONGWORD$$POINTER ()
0000003 0x080723b8 in SYSTEM_$$_SYSGETMEM$LONGWORD$$POINTER ()
0000004 0x080716c2 in SYSTEM_$$_GETMEM$POINTER$LONGWORD ()
0000005 0x08129100 in TRAWIMAGE__PERFORMEFFECT (ADRAWEFFECT=GDEDISABLED,
    CREATENEWDATA=true, FREEOLDDATA=false, this=...) at graphtype.pp:1640
0000006 0x082b1a2c in TDEFAULTIMAGELISTIMPLEMENTOR__DRAW (AINDEX=76,
    ACANVAS=0xb72689e0, ABOUNDS=..., ADRAWEFFECT=GDEDISABLED, ASTYLE=DSNORMAL,
    this=<error reading variable>) at ./widgetset/wsimglist.pp:120
0000007 0x082b1dd0 in TWSCUSTOMIMAGELIST__DRAW (ALIST=0xb630f020, AINDEX=76,
    ACANVAS=0xb72689e0, ABOUNDS=..., ABKCOLOR=536870911,
    ABLENDCOLOR=536870911, ADRAWEFFECT=GDEDISABLED, ASTYLE=DSNORMAL,
    AIMAGETYPE=ITIMAGE, pvmt=0xb6fbc290) at ./widgetset/wsimglist.pp:210
0000008 0x082af51f in TCUSTOMIMAGELIST__DRAW (ACANVAS=0xb72689e0, AX=3, AY=3,
    AINDEX=76, ADRAWINGSTYLE=DSNORMAL, AIMAGETYPE=ITIMAGE,
    ADRAWEFFECT=GDEDISABLED, this=<error reading variable>)
    at ./include/imglist.inc:520
0000009 0x082af43b in TCUSTOMIMAGELIST__DRAW (ACANVAS=0xb72689e0, AX=3, AY=3,
    AINDEX=76, ADRAWEFFECT=GDEDISABLED, this=<error reading variable>)
    at ./include/imglist.inc:503
0000010 0x082af3ee in TCUSTOMIMAGELIST__DRAW (ACANVAS=0xb72689e0, AX=3, AY=3,
    AINDEX=76, AENABLED=false, this=<error reading variable>)

Ludo Brands

2012-09-10 10:19

developer   ~0062259

> Can you reproduce this easily
Yes. I have a mercurial repo for fpc and lazarus and can revert quite easily. It is on a slow system so it will take a while.

ocean

2012-09-10 10:30

reporter   ~0062260

Lazarus still hangs 22363 win64. Also FPC compile with OPT=-dTEST_WIN64_SEH crashes, last working version is 22339

Ludo Brands

2012-09-10 12:10

developer   ~0062265

Revision 22341 is the culprit. 22340 works fine 22341 is broken as described. Double checked with 22363 and changes in 22341 reverted, works fine also.
Made typo earlier: ubuntu 10.04 i386 (instead of x64)

Ludo Brands

2012-09-10 15:03

developer   ~0062272

Last edited: 2012-09-10 15:09

Did some further debugging and found that pmemchunk_var.freelists of the SplashForm instance gets corrupted while streaming the form. Got as far as TReader.ReadData where loading one of the properties is corrupting the data.
When splashform is destroyed and its memory freed, the corrupted pmemchunk_var.freelists makes SysFreeMem_Var think the memory was allocated in another thread and stores a bad address in waitvar. That causes the crash much later when the waitvars are freed.
Unfortunately there is no way to put a hw watchpoint on heap data and stepping through the reader code is very time consuming.

Florian

2012-09-10 20:48

administrator   ~0062277

r22341 indeed breaks some stuff. The last known issue was fixed in r22362. Is current trunk still broken?

Mattias Gaertner

2012-09-10 21:03

manager   ~0062278

It works for me and Ludo with 22363.
ocean still has some problems on win64. See note 62260 above.

ocean, can you start the IDE in the debugger and see where it hangs?

ocean

2012-09-10 23:37

reporter   ~0062282

Not sure if you mean it like this?

For the hang: gdb lazarus.exe

Program received signal SIGSEGV, Segmentation fault.
0x000000000041239c in SYSTEM_$$_WAITFREE_VAR$PMEMCHUNK_VAR ()

I also tried to use this line, but it doesn't show anything for the hang.

--debug-log=lazarusdebuglog.txt

If I remove Lazarus settings (appdata/lazarus) then last lines in log are:

...
SearchDebuggerCandidates Value=gdb.exe File=
[TMainIDE.Destroy] A
[TMainIDE.Destroy] B -> inherited Destroy... TMainIDE
[TMainIDE.Destroy] END
[FORMS.PP] ExceptionOccurred
  Sender=EAcce

This could be related, If I compile FPC 22369 with OPT=-dTEST_WIN64_SEH I get this kind of crash (Works 22339)

make[6]: Leaving directory `C:/pp/source/compiler/utils'
/pp/bin/x86_64-win64/rm.exe -rf x86_64/units
/pp/bin/x86_64-win64/rm.exe -f x86_64/*.o x86_64/*.ppu x86_64/*.rst x86_64/*.s x
86_64/*.a x86_64/*.so x86_64/*.ppl
/pp/bin/x86_64-win64/rm.exe -f x86_64/ppc386.exe x86_64/ppc68k.exe x86_64/ppcx64
.exe x86_64/ppcppc.exe x86_64/ppcsparc.exe x86_64/ppcppc64.exe x86_64/ppcarm.exe
 x86_64/ppcmips.exe x86_64/ppcmipsel.exe x86_64/ppcjvm.exe x86_64/ppcx64.exe
/pp/bin/x86_64-win64/rm.exe -f ppcx64.exe
/pp/bin/x86_64-win64/gmkdir.exe -p x86_64/units/x86_64-win64
C:/pp/source/compiler/ppc1.exe -Ur -Xs -O2 -n -Fux86_64 -Fusystems -FuC:/pp/sour
ce/rtl/units/x86_64-win64 -Fix86_64 -FE. -FUx86_64/units/x86_64-win64 -dRELEASE
-dTEST_WIN64_SEH -dx86_64 -dGDB -dBROWSERLOG -Fux86 -Sew pp.pas
Fatal: Compilation aborted
An unhandled exception occurred at $000000010016131A:
EAccessViolation: Access violation
  $000000010016131A

Mattias Gaertner

2012-09-10 23:50

manager   ~0062283

The crash about compiling fpc is irrelevant for this lazarus bug report. You can create a fpc bug report for that.

A segmentation fault is not a hang. A hang is an endless loop, dead lock or blocking IO. Of course there can be a hang after a seg fault, but then the hang is irrelevant.

Do you get a hang or a segmentation fault (=crash) with Lazarus?

If you get a segmentation fault, please start the IDE with gdb and create a backtrace of the seg fault.

ocean

2012-09-11 07:27

reporter   ~0062284

Are you sure it's irrelevant? Information could be vital, if it has the same root cause. Fixing that may also fix this. Reverting whole patch serie 62, 43, 42, 41, 40 allows FPC to compile normally and also lazarus works.

Issue is same as 22849. Only difference I get hang much sooner. Hang means Lazarus becomes unresponsive, no visible error messages.

Ludo Brands

2012-09-11 07:58

developer   ~0062285

Last edited: 2012-09-11 08:44

> It works for me and Ludo with 22363.

No. It only works for me with 22363 when changes in r22341 are backed out. 22363 on its own does not work! This was a double check to be sure 22341 was the cause of the problem.

EDIT: tested with 22369 and it also crashes.

Ludo Brands

2012-09-12 12:19

developer   ~0062301

laz 38618 + FPC 22373 still crashes at the same location.

Also reproduced with a fresh fpc/laz installation from svn on ubuntu x64. Stacktrace:

Program received signal SIGSEGV, Segmentation fault.
_$SYSTEM$_Ll7319 (LOC_FREELISTS=0x1baa208) at ../inc/heap.inc:1257
1257 loc_freelists^.waitvar := pmcv^.next_var;
(gdb) bt
#0 _$SYSTEM$_Ll7319 (LOC_FREELISTS=0x1baa208) at ../inc/heap.inc:1257
0000001 0x0000000001baa208 in U_$SYSTEM_$$_FREELISTS ()
0000002 0x0000000000000000 in ?? ()

Same location as on i386. Note that there are no other threads running at the moment of the crash.

Mattias Gaertner

2012-09-12 14:17

manager   ~0062302

Nothing points to a bug in Lazarus, but the fpc revision and Jonas remark on fpc-devel indicates that it is likely a fpc bug.
We have to create a FPC bug report. But I'm not sure what to write. We must give them some more information. The above mem corruption is not very helpful.
Does this bug appear only in the IDE or in some smaller application too?

ocean

2012-09-12 15:33

reporter   ~0062303

startlazarus.exe is also broken. Copy it to some other dir, there is failure on exit

Ludo Brands

2012-09-12 16:03

developer   ~0062304

>Does this bug appear only in the IDE or in some smaller application too?
Only in the IDE. I rebuild a few smaller LCL apps with lazbuild and they run OK.
>The above mem corruption is not very helpful.
Unfortunately it is the only thing we have and it is repeatable. I tried to debug it but this is looking for a needle in a haystack. Even if the location is found where the wrong address is used, there is still the possibility that it is only a side effect of another problem somewhere else. In any case it can still take a very long time before the error in the generated code is found.
There is also the remote possibility that there is indeed a problem in the lazarus or the FCL code that only pops up now because of a different code layout. In that case it is not a compiler problem.

Mattias Gaertner

2012-09-12 16:14

manager   ~0062305

Log entry r22341 | florian | 2012-09-06 17:11:58 +0200 (Thu, 06 Sep 2012) | 1 line

* when creating method pointers, put them into registers

Jonas reply on fpc-devel list:
If it causes problems, it's a bug in FPC. It's only a code generation
optimization.

Ludo Brands

2012-09-12 16:39

developer   ~0062306

> startlazarus.exe is also broken.
Interesting. When running lazarus --nsc the IDE indeed starts but when exiting the IDE it crashes at the same locating in heap.inc. Lazarus --nsc crashes also when closing the form editor or the assembler window (opening existing project). Always same location. Found other malfunctions in codetools: drop a button on form and double click on it to create onclick handler causes a sigsegv. Perhaps this one is easier to debug.

Ludo Brands

2012-09-12 18:03

developer   ~0062307

Submitted 22864. Codetools crash was easier to debug.

John Shand

2012-09-13 11:17

reporter   ~0062324

i am also having the same issue with the newest trunk of fpc 2.7.1 and lazarus 1.1 also.

i start the application from the menu in opensuse 12.2 and it seems to start fine, but when i go to close the current empty project it then brings up an empty message box. so i don't know what error was.

also intermittently it does seem to hang on starting the ide. the error is caught by the operating system and you end up having to force quit

Ludo Brands

2012-09-13 22:15

developer   ~0062344

Tested with fpc 22386 on x64 and the problem is fixed.

Vincent Snijders

2012-09-13 23:00

manager   ~0062345

Fixed in fpc 2.7.1.

Issue History

Date Modified Username Field Change
2012-09-09 09:35 Gennadiy New Issue
2012-09-09 09:35 Gennadiy Widgetset => GTK 2
2012-09-09 10:09 Mattias Gaertner Note Added: 0062208
2012-09-09 11:09 Gennadiy Note Added: 0062213
2012-09-09 17:31 ocean Note Added: 0062233
2012-09-09 21:31 Mattias Gaertner Relationship added related to 0022849
2012-09-10 09:30 Mattias Gaertner Note Added: 0062255
2012-09-10 09:56 Ludo Brands Note Added: 0062256
2012-09-10 10:04 Mattias Gaertner Note Edited: 0062255
2012-09-10 10:06 Mattias Gaertner Note Added: 0062257
2012-09-10 10:07 Ludo Brands Note Added: 0062258
2012-09-10 10:19 Ludo Brands Note Added: 0062259
2012-09-10 10:30 ocean Note Added: 0062260
2012-09-10 12:10 Ludo Brands Note Added: 0062265
2012-09-10 15:03 Ludo Brands Note Added: 0062272
2012-09-10 15:09 Ludo Brands Note Edited: 0062272
2012-09-10 20:48 Florian Note Added: 0062277
2012-09-10 21:03 Mattias Gaertner Note Added: 0062278
2012-09-10 23:37 ocean Note Added: 0062282
2012-09-10 23:50 Mattias Gaertner Note Added: 0062283
2012-09-11 07:27 ocean Note Added: 0062284
2012-09-11 07:58 Ludo Brands Note Added: 0062285
2012-09-11 08:44 Ludo Brands Note Edited: 0062285
2012-09-12 12:19 Ludo Brands Note Added: 0062301
2012-09-12 14:17 Mattias Gaertner Note Added: 0062302
2012-09-12 15:33 ocean Note Added: 0062303
2012-09-12 16:03 Ludo Brands Note Added: 0062304
2012-09-12 16:14 Mattias Gaertner Note Added: 0062305
2012-09-12 16:39 Ludo Brands Note Added: 0062306
2012-09-12 18:03 Ludo Brands Note Added: 0062307
2012-09-13 11:17 John Shand Note Added: 0062324
2012-09-13 11:52 Mattias Gaertner Relationship added child of 0022864
2012-09-13 12:04 Jonas Maebe Relationship replaced parent of 0022864
2012-09-13 22:15 Ludo Brands Note Added: 0062344
2012-09-13 23:00 Vincent Snijders LazTarget => -
2012-09-13 23:00 Vincent Snijders Status new => resolved
2012-09-13 23:00 Vincent Snijders Resolution open => fixed
2012-09-13 23:00 Vincent Snijders Assigned To => Vincent Snijders
2012-09-13 23:00 Vincent Snijders Note Added: 0062345