View Issue Details

IDProjectCategoryView StatusLast Update
0022848LazarusIDEpublic2013-05-03 10:45
ReporterfpbtAssigned ToMartin Friebe 
PrioritynormalSeveritytweakReproducibilityhave not tried
Status closedResolutionfixed 
Product Version1.1 (SVN)Product Build 
Target Version1.0.4Fixed in Version1.1 (SVN) 
Summary0022848: Displayed changes and break points on overview Gutter
DescriptionThe displayed changes aren't correct on overview gutter. Look add file (5 pic)
TagsNo tags attached.
Fixed in Revision39367
LazTarget1.0.4
WidgetsetWin32/Win64
Attached Files

Activities

2012-09-09 16:50

 

Gutter_02.gif (113,877 bytes)
Gutter_02.gif (113,877 bytes)

Martin Friebe

2012-11-25 01:53

manager   ~0064023

Please test and close if ok

2013-01-03 11:21

 

Gutter_7_2.gif (50,601 bytes)
Gutter_7_2.gif (50,601 bytes)

fpbt

2013-01-03 11:27

reporter   ~0064581

Look at the Gutter_7_2.gif file. If everything is good, I will close a question.

tested on Lazarus-1.1-39718-fpc-2.6.1-20130102-win32.exe

Martin Friebe

2013-01-03 12:57

manager   ~0064585

I can not reproduce it, and if I look at the image, the yellow lines are either 1 or 2 pixel to low (definitely not more than 2 pixel).

Do they change position, if you resize the window (reduce height), and then restore the original height)?

If so, attach your file (including lps (session info with breakpoints).

---

For explanation:
  pixels_per_text_line_in_overview = overview_height / lines_count

Say your widow is 300 pixel height, and you have 10 lines, the each line has 30 pixel in the overview.

- The yellow occupies the 30 pixel
- The breakpoint starts, so that the middle of the box is at the top of the 30 pixel (the top of the breakpoint is to high, it will cover part of the previous line).
This choice is good for large files were several textlines share one pixel in the overview, but not ideal for small files.
But it is the current choice. (It also leads to sometimes cutting the box off, if a breakpoint is in the first line.


In addition to the above description, the placement attempts to be smart. (Not always yet)
Set 2 breakpoints So they are close together. reduce the window height. The upper breakpoint will at some time move upwards, (away from it's desired location). It is pushed up so 2 marks can be fully displayed, that would normally overlap. That means the positions can by design go off the desired location.

---
So in your image (and on my PC it does) the yellow lines should start/end in the middle of the breakpoint rectangles (doesn't really make sense, but is the current design)

fpbt

2013-01-04 09:17

reporter   ~0064603

I understood, thanks.
Put resolved status, and then I will be able to close a question.

Martin Friebe

2013-01-04 15:02

manager   ~0064611

I have slightly improved the positioning in rev 39762 (trunk).

If there are enough pixels per textline, the mark is drawn 1 pixel below the yellow start. As pixels per line shrink this goes to 0 pixel (exact at yellow start) and then -1 (which is the marks center being aligned).

Marks that would cut off at the top or bottom will slide in. (Meaning a mark on line 1 and line 2 will merge (if there is not enough space for 2 symbols)) more easily into one symbol, than 2 marks in the middle of the file)

---
If there is a bookmark and a breakpoint on the same line, they will not display both, even if there are enough pixels per line.

Issue History

Date Modified Username Field Change
2012-09-09 16:50 fpbt New Issue
2012-09-09 16:50 fpbt File Added: Gutter_02.gif
2012-09-09 16:50 fpbt Widgetset => Win32/Win64
2012-09-09 17:46 Martin Friebe Status new => assigned
2012-09-09 17:46 Martin Friebe Assigned To => Martin Friebe
2012-11-25 01:53 Martin Friebe Fixed in Revision => 39367
2012-11-25 01:53 Martin Friebe LazTarget => 1.0.4
2012-11-25 01:53 Martin Friebe Status assigned => resolved
2012-11-25 01:53 Martin Friebe Fixed in Version => 1.1 (SVN)
2012-11-25 01:53 Martin Friebe Resolution open => fixed
2012-11-25 01:53 Martin Friebe Note Added: 0064023
2012-11-25 01:53 Martin Friebe Target Version => 1.0.4
2013-01-03 11:21 fpbt File Added: Gutter_7_2.gif
2013-01-03 11:27 fpbt Status resolved => assigned
2013-01-03 11:27 fpbt Resolution fixed => reopened
2013-01-03 11:27 fpbt Note Added: 0064581
2013-01-03 12:57 Martin Friebe Note Added: 0064585
2013-01-04 09:17 fpbt Note Added: 0064603
2013-01-04 15:02 Martin Friebe Status assigned => resolved
2013-01-04 15:02 Martin Friebe Resolution reopened => fixed
2013-01-04 15:02 Martin Friebe Note Added: 0064611
2013-05-03 10:45 fpbt Status resolved => closed