View Issue Details

IDProjectCategoryView StatusLast Update
0022890LazarusIDEpublic2012-09-15 18:25
ReporterValdas JankūnasAssigned ToMartin Friebe 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionfixed 
PlatformLinux 3.5.0-4-generic x86_64 OSKubuntuOS Version 12.04
Product Version1.1 (SVN)Product Build38659 
Target Version1.0.2Fixed in Version1.1 (SVN) 
Summary0022890: Wrong "Delete to end of word" at end_of_line+n when it contains unicode chars and no spaces at end
DescriptionIn editor paste these two lines:

aaaą
bbbb

First line contains unicode char "ą" at end, both lines have no spaces at end.

Now place cursor to beyond of first line (at line end + one space) and press "Delete to end of word" keyboard shortcut (Ctrl + T or Ctrl + Del) - two lines become:

aaa� �bbbb

- last unicode char converted to one space between two question marks (illegal chars?).
If first line contains two unicode chars:

ęaaaą
bbbb

Then after mentioned del operation these lines becomes:

ęaaa ąbbbb

Another example:

čęaaaą
bbbb

Becomes:

čęaa aąbbbb
Additional InformationTested in Qt and in Gtk2.
TagsNo tags attached.
Fixed in Revision
LazTarget1.0.2
Widgetset
Attached Files
  • test_project.tar.gz (1,220 bytes)
  • before__qt.png (37,955 bytes)
    before__qt.png (37,955 bytes)
  • after__qt.png (40,180 bytes)
    after__qt.png (40,180 bytes)
  • before__gtk2.png (34,662 bytes)
    before__gtk2.png (34,662 bytes)
  • after__gtk2.png (34,927 bytes)
    after__gtk2.png (34,927 bytes)
  • logas-qt.txt (502 bytes)
    TMainIDE.ParseCmdLineOptions:
      PrimaryConfigPath="/home/senbuvis/.lazarus"
      SecondaryConfigPath="/etc/lazarus"
    [TCustomSynEdit.KeyDown] 17 [ssCtrl]
    [TCustomSynEdit.KeyDown] 46 [ssCtrl]
    [TCustomSynEdit.CommandProcessor] 503 AChar= Data=0000000000000000
    [TCustomSynEdit.KeyUp] 46 Shift=False Ctrl=True Alt=False
    [TCustomSynEdit.KeyUp] 17 Shift=False Ctrl=False Alt=False
    LAZARUS END - cleaning up ...
    [TMainIDE.Destroy] A 
    [TMainIDE.Destroy] B  -> inherited Destroy... TMainIDE
    [TMainIDE.Destroy] END
    
    logas-qt.txt (502 bytes)

Activities

Martin Friebe

2012-09-15 14:46

manager   ~0062383

Can you please save the example text to a file and attach it? I can not reproduce it, but embedding in the html text (or typing) may loose certain encoding, and the same char may behave differently.

Also try if anything odd happens (additional char appearing) if you select the line char by char from left to right)

2012-09-15 15:38

 

test_project.tar.gz (1,220 bytes)

2012-09-15 15:39

 

before__qt.png (37,955 bytes)
before__qt.png (37,955 bytes)

2012-09-15 15:39

 

after__qt.png (40,180 bytes)
after__qt.png (40,180 bytes)

2012-09-15 15:39

 

before__gtk2.png (34,662 bytes)
before__gtk2.png (34,662 bytes)

2012-09-15 15:40

 

after__gtk2.png (34,927 bytes)
after__gtk2.png (34,927 bytes)

2012-09-15 15:40

 

logas-qt.txt (502 bytes)
TMainIDE.ParseCmdLineOptions:
  PrimaryConfigPath="/home/senbuvis/.lazarus"
  SecondaryConfigPath="/etc/lazarus"
[TCustomSynEdit.KeyDown] 17 [ssCtrl]
[TCustomSynEdit.KeyDown] 46 [ssCtrl]
[TCustomSynEdit.CommandProcessor] 503 AChar= Data=0000000000000000
[TCustomSynEdit.KeyUp] 46 Shift=False Ctrl=True Alt=False
[TCustomSynEdit.KeyUp] 17 Shift=False Ctrl=False Alt=False
LAZARUS END - cleaning up ...
[TMainIDE.Destroy] A 
[TMainIDE.Destroy] B  -> inherited Destroy... TMainIDE
[TMainIDE.Destroy] END
logas-qt.txt (502 bytes)

Valdas Jankūnas

2012-09-15 15:44

reporter   ~0062393

Sending test project (test_project.tar.gz). What I do:
 - open project; editor looks like "before__qt.png" or "before__gtk2.png" - cursor at two spaces after firs line end;
 - press Ctrl + Del; then editor looks like "after__qt.png" or "after__gtk2.png";
 - close Lazarus.
 
 Attached debug log (Lazarus compiled with "VerboseKeys") "logas-qt.txt". This log in Gtk2 ws looks same.

 Also in Gtk2 ws after Ctrl+Del in console repeatedly is printed:

(lazarus:13503): Pango-WARNING **: Invalid UTF-8 string passed to pango_layout_set_text()

 Tested for "odd": nothing odd in Qt and Gtk2 ws.

Martin Friebe

2012-09-15 18:18

manager   ~0062402

Please test with rev 38672 and close if ok

Issue History

Date Modified Username Field Change
2012-09-15 13:02 Valdas Jankūnas New Issue
2012-09-15 14:43 Martin Friebe Status new => assigned
2012-09-15 14:43 Martin Friebe Assigned To => Martin Friebe
2012-09-15 14:46 Martin Friebe LazTarget => -
2012-09-15 14:46 Martin Friebe Note Added: 0062383
2012-09-15 14:46 Martin Friebe Status assigned => feedback
2012-09-15 15:38 Valdas Jankūnas File Added: test_project.tar.gz
2012-09-15 15:39 Valdas Jankūnas File Added: before__qt.png
2012-09-15 15:39 Valdas Jankūnas File Added: after__qt.png
2012-09-15 15:39 Valdas Jankūnas File Added: before__gtk2.png
2012-09-15 15:40 Valdas Jankūnas File Added: after__gtk2.png
2012-09-15 15:40 Valdas Jankūnas File Added: logas-qt.txt
2012-09-15 15:44 Valdas Jankūnas Note Added: 0062393
2012-09-15 16:08 Martin Friebe Status feedback => assigned
2012-09-15 18:18 Martin Friebe LazTarget - => 1.0.2
2012-09-15 18:18 Martin Friebe Status assigned => resolved
2012-09-15 18:18 Martin Friebe Fixed in Version => 1.1 (SVN)
2012-09-15 18:18 Martin Friebe Resolution open => fixed
2012-09-15 18:18 Martin Friebe Note Added: 0062402
2012-09-15 18:18 Martin Friebe Target Version => 1.0.2
2012-09-15 18:25 Valdas Jankūnas Status resolved => closed