View Issue Details

IDProjectCategoryView StatusLast Update
0022926LazarusIDEpublic2012-09-26 09:28
ReporterAlexey KamenskiyAssigned ToMartin Friebe 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Product Version1.0.1 (SVN)Product Build 
Target Version1.2.0Fixed in Version1.1 (SVN) 
Summary0022926: Lazarus IDE hangs if editing in the form module sybmols "№" and "#"
DescriptionWhen editing in the form module sybmols "№" and "#" they aren't printed and lazarus IDE hangs.
TagsNo tags attached.
Fixed in Revision38827
LazTarget1.2
WidgetsetWin32/Win64
Attached Files

Activities

Martin Friebe

2012-09-20 12:02

manager   ~0062512

Last edited: 2012-09-20 12:07

A few questions:

1) "form module". What does that refer to? The object inspector? If yes any property? Maybe attach a screenshot.

2) What locale do you use? What keymap? Which keys produce th №? Does it happen with copy and paste too?

3) "№" and "#". Does that mean it happen for either one, if just ond is entered, or both must be entered together?

4) Please confirm 1.0.1 means "fixes". Lazarus from trunk is 1.0

Alexey Kamenskiy

2012-09-21 13:32

reporter   ~0062539

1) If I write
procedure TMainForm.btnDoClick(Sender: TObject);
var
  Desc : String;
begin
  Desc := 'Document №';
end;
the symbol "№" not visible in editor and lazarus hangs.
2) Russian
3) Not together
4) In lazarus from trunk 1.0

Martin Friebe

2012-09-21 14:27

manager   ~0062542

Ok I can get a drawing error (but no hang)

It might be related, and maybe enough to fix it.
But can you please attach your editoroptions.xml

---
Also

1) Is the crash recent. Did older versions (including 1.0 released and/or fixes branch) work?

2) Can you test with a different font (courier / deja-vu-mono)? What font to you use?

Alexey Kamenskiy

2012-09-21 14:40

reporter   ~0062543

1) Versions from snaphots from Lazarus-1.1-38674-fpc-2.6.1-20120916-win32.exe to Lazarus-1.1-38768-fpc-2.6.1-20120921-win32.exe
2)I use standart font in Windows XP and Windows Vista

Anton

2012-09-21 16:34

reporter   ~0062544

Last edited: 2012-09-21 16:45

endless loop: components\synedit\lazsyntextarea.pp:1834

components\synedit\lazsyntextarea.pp:417: FCurViewToken.Tk.TokenLength becomes<0

Bart Broersma

2012-09-21 18:05

developer   ~0062549

Last edited: 2012-09-21 18:05

FWIW: Lazarus 1.1 r38343 FPC 2.6.0 i386-win32-win32/win64 on Win7.
I can paste the offending code and edit it. The IDE behaves (appr.) normally.
When the cursor moves through the № character it seems to treat it as two characters (the x position gets incremented twice and the cursosn appears between the N and the small o). Delete and Backspace remove the character in 1 keystroke.

Alexey Kamenskiy

2012-09-24 09:31

reporter   ~0062593

The problem is still not resolved.

Martin Friebe

2012-09-24 10:55

manager   ~0062596

I know. It is assigned. And it will get priority, as soon as I have time to do work on Lazarus at all. I was away for a week.

Martin Friebe

2012-09-25 13:52

manager   ~0062618

Please test and close if ok

Alexey Kamenskiy

2012-09-26 09:28

reporter   ~0062634

Corrected

Issue History

Date Modified Username Field Change
2012-09-20 08:43 Alexey Kamenskiy New Issue
2012-09-20 08:43 Alexey Kamenskiy Widgetset => Win32/Win64
2012-09-20 11:21 Zeljan Rikalo Status new => assigned
2012-09-20 11:21 Zeljan Rikalo Assigned To => Martin Friebe
2012-09-20 12:02 Martin Friebe LazTarget => -
2012-09-20 12:02 Martin Friebe Note Added: 0062512
2012-09-20 12:02 Martin Friebe Status assigned => feedback
2012-09-20 12:07 Martin Friebe Note Edited: 0062512
2012-09-21 13:32 Alexey Kamenskiy Note Added: 0062539
2012-09-21 14:27 Martin Friebe Note Added: 0062542
2012-09-21 14:27 Martin Friebe Status feedback => assigned
2012-09-21 14:40 Alexey Kamenskiy Note Added: 0062543
2012-09-21 16:34 Anton Note Added: 0062544
2012-09-21 16:45 Anton Note Edited: 0062544
2012-09-21 18:05 Bart Broersma Note Added: 0062549
2012-09-21 18:05 Bart Broersma Note Edited: 0062549
2012-09-24 09:31 Alexey Kamenskiy Note Added: 0062593
2012-09-24 10:55 Martin Friebe Note Added: 0062596
2012-09-25 13:52 Martin Friebe Fixed in Revision => 38827
2012-09-25 13:52 Martin Friebe LazTarget - => 1.2
2012-09-25 13:52 Martin Friebe Status assigned => resolved
2012-09-25 13:52 Martin Friebe Fixed in Version => 1.1 (SVN)
2012-09-25 13:52 Martin Friebe Resolution open => fixed
2012-09-25 13:52 Martin Friebe Note Added: 0062618
2012-09-25 13:52 Martin Friebe Target Version => 1.2.0
2012-09-26 09:28 Alexey Kamenskiy Status resolved => closed
2012-09-26 09:28 Alexey Kamenskiy Note Added: 0062634