View Issue Details

IDProjectCategoryView StatusLast Update
0023015LazarusLCLpublic2012-09-29 13:28
ReporterJohn Kelly Assigned ToZeljan Rikalo  
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version1.0.1 (SVN) 
Summary0023015: ListViewItem.editCaption only works in vsReport and vsList ViewStyles
DescriptionCalling EditCaption does nothing when TListView is in vsIcon or vsSmallIcon ViewStyle.

Select an item, click the right button to go to the ViewStyle of choice. Click the left button to try EditCaption.

Only works in vsReport and vsList
Additional InformationAlso as a result of creating the test project, I see that changing ViewStyle to vsReport fails to update the component intermittently. I can log a separate ticket for that if you want.

Click the toggle button a few times to see it. vsReport sometimes comes up blank.
TagsNo tags attached.
Fixed in Revision38897
LazTarget-
WidgetsetGTK 2
Attached Files

Activities

2012-09-28 19:25

 

listview.tgz (3,507 bytes)

Zeljan Rikalo

2012-09-29 11:15

developer   ~0062724

Please test and close if ok. Also problem with updating list view when changing should be fixed now since we had an assertion in gtk2.

John Kelly

2012-09-29 13:28

reporter   ~0062728

Now EditCaption works in vsIcon and vsSmallIcon viewstyles. Thanks.

Issue History

Date Modified Username Field Change
2012-09-28 19:25 John Kelly New Issue
2012-09-28 19:25 John Kelly File Added: listview.tgz
2012-09-28 19:25 John Kelly Widgetset => GTK 2
2012-09-29 06:55 Zeljan Rikalo Status new => assigned
2012-09-29 06:55 Zeljan Rikalo Assigned To => Zeljan Rikalo
2012-09-29 11:15 Zeljan Rikalo Fixed in Revision => 38897
2012-09-29 11:15 Zeljan Rikalo LazTarget => -
2012-09-29 11:15 Zeljan Rikalo Status assigned => resolved
2012-09-29 11:15 Zeljan Rikalo Resolution open => fixed
2012-09-29 11:15 Zeljan Rikalo Note Added: 0062724
2012-09-29 13:28 John Kelly Status resolved => closed
2012-09-29 13:28 John Kelly Note Added: 0062728