View Issue Details

IDProjectCategoryView StatusLast Update
0023018LazarusIDEpublic2014-05-21 13:05
Reportersamuel herzogAssigned ToJuha Manninen 
PrioritynormalSeveritytrivialReproducibilityalways
Status closedResolutionfixed 
Platformwin32OSwinxpOS Versionsp3
Product Version1.1 (SVN)Product Buildr38511 
Target Version1.1 (SVN)Fixed in Version1.1 (SVN) 
Summary0023018: Object-Inspector for Boolean-Properties should set the combobox-style to csDropDownlist
DescriptionBoolean-Properties are represented by a combobox in the Object-Inspector.
But you can edit/write into the the combobox. This is not needed. The style of the combobox should be set to csDropDownList.
Steps To Reproduce1.) Create a new project.
2.) press F11 to show the object inspector.
3.) choose a Boolean-Property (e.g. AlphaBlend). You can type whatever you want into the combobox.
TagsNo tags attached.
Fixed in Revisionr38913
LazTarget-
WidgetsetWin32/Win64
Attached Files

Relationships

related to 0023146 closedJuha Manninen Boolean (sets) types in Object Inspector 
related to 0023145 resolvedJuha Manninen TColorPropertyEditor behaves wrong with some widgetsets and Boolean editor type affects it 
related to 0026179 closedJuha Manninen It's possible to write into comboboxes inside the object inspector for boolean values. 

Activities

Juha Manninen

2012-09-29 23:38

developer   ~0062748

Fixed.

samuel herzog

2012-09-30 05:49

developer   ~0062758

Thank you. Works fine.
I wonder if there is a reason for not doing the same for "Enum"-Properties. e.g. BorderStyle. Why should someone be able to type something into a combobox?

Mattias Gaertner

2012-09-30 07:58

manager   ~0062760

Because for copy and paste.

Issue History

Date Modified Username Field Change
2012-09-29 20:13 samuel herzog New Issue
2012-09-29 20:13 samuel herzog LazTarget => -
2012-09-29 20:13 samuel herzog Widgetset => Win32/Win64
2012-09-29 22:57 Juha Manninen Status new => assigned
2012-09-29 22:57 Juha Manninen Assigned To => Juha Manninen
2012-09-29 23:38 Juha Manninen Fixed in Revision => r38913
2012-09-29 23:38 Juha Manninen Status assigned => resolved
2012-09-29 23:38 Juha Manninen Resolution open => fixed
2012-09-29 23:38 Juha Manninen Note Added: 0062748
2012-09-30 05:49 samuel herzog Status resolved => closed
2012-09-30 05:49 samuel herzog Note Added: 0062758
2012-09-30 05:49 samuel herzog Fixed in Version => 1.1 (SVN)
2012-09-30 07:58 Mattias Gaertner Note Added: 0062760
2012-10-17 16:04 Juha Manninen Relationship added related to 0023146
2012-10-17 16:19 Juha Manninen Relationship added related to 0023145
2014-05-18 19:10 Juha Manninen Relationship added related to 0026179