View Issue Details

IDProjectCategoryView StatusLast Update
0023029LazarusLCLpublic2014-04-15 22:49
ReporterVojtech Cihak Assigned ToBart Broersma  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.1 (SVN) 
Summary0023029: Bad anchoring of TEditButton
DescriptionI tried to align EditButton with Edit and I set BorderSpace equal to BorderWidth but a gap appears between Edit and Button.

See screenshot. See Anchor Editor of demo.

I tested in GTK2 and Qt.
Additional InformationI don't think it is duplicate of 12155 ( http://bugs.freepascal.org/view.php?id=12155 )
TagsNo tags attached.
Fixed in Revisionr44623
LazTarget1.4
WidgetsetGTK 2, QT
Attached Files

Relationships

related to 0012155 closedBart Broersma TEditButton aligns incorrect (glyph is not taken into account) 

Activities

2012-09-30 11:28

 

anchor_editbtn.png (4,944 bytes)   
anchor_editbtn.png (4,944 bytes)   

2012-09-30 11:31

 

Anchor_EditBtn.zip (7,735 bytes)

Vojtech Cihak

2012-09-30 11:40

reporter   ~0062766

There is error in description.

I made BorderWidth (in Anchor Editor) equal to ButtonWidth of TEditButton (because Button of TEditButton always overhangs).

Juha Manninen

2012-09-30 13:38

developer   ~0062770

It is a well-known problem. The whole control will be redesigned.

Bart Broersma

2014-04-07 15:59

developer   ~0074185

Should be fixed by new implementation in r44623.

Vojtech Cihak

2014-04-15 22:49

reporter   ~0074419

New implementation resolves this issue. I close.

Issue History

Date Modified Username Field Change
2012-09-30 11:28 Vojtech Cihak New Issue
2012-09-30 11:28 Vojtech Cihak File Added: anchor_editbtn.png
2012-09-30 11:28 Vojtech Cihak Widgetset => GTK 2, QT
2012-09-30 11:31 Vojtech Cihak File Added: Anchor_EditBtn.zip
2012-09-30 11:40 Vojtech Cihak Note Added: 0062766
2012-09-30 13:37 Juha Manninen Relationship added related to 0012155
2012-09-30 13:38 Juha Manninen LazTarget => -
2012-09-30 13:38 Juha Manninen Note Added: 0062770
2012-09-30 13:38 Juha Manninen Status new => acknowledged
2012-09-30 13:39 Juha Manninen LazTarget - => 1.2
2013-12-30 15:14 Juha Manninen LazTarget 1.2 => 1.4
2014-04-07 11:57 Juha Manninen Assigned To => Bart Broersma
2014-04-07 11:57 Juha Manninen Status acknowledged => assigned
2014-04-07 15:59 Bart Broersma Fixed in Revision => r44623
2014-04-07 15:59 Bart Broersma Note Added: 0074185
2014-04-07 15:59 Bart Broersma Status assigned => resolved
2014-04-07 15:59 Bart Broersma Resolution open => fixed
2014-04-15 22:49 Vojtech Cihak Note Added: 0074419
2014-04-15 22:49 Vojtech Cihak Status resolved => closed