View Issue Details

IDProjectCategoryView StatusLast Update
0023046LazarusIDEpublic2012-10-05 00:20
ReporterLucas MartínAssigned ToMaxim Ganetsky 
PrioritynormalSeveritytextReproducibilityhave not tried
Status resolvedResolutionfixed 
PlatformallOSOS Version
Product Version1.1 (SVN)Product Build 
Target Version1.2.0Fixed in Version1.1 (SVN) 
Summary0023046: Translate to spanish for Lazarus
DescriptionHi,

I pascal programmer for many years and I used during my professional career multitude of software for programation and grafic design.
I have always observed from lazarus monitor developments and decided to contribute when you can.
My idea is continue contributing to improving Lazarus

I send you the Spanish translation of the following files:

Translate complete: 100% translated:
/languages/debuggerstrconst.es.po
/languages/gdbmidebugger.es.po
/ideintf/languages/objinspstrconsts.es.po
/doceditor/languages/lazde.es.po
/languages/lazaruside.es.po
/lcl/languages/lclstrconsts.es.po

Release 38948



Thanks for your great work
Please add me to the list of contributors to Lazarus ;)

Lucas Martín (codedeep)
Dinlabs
www.dinlabs.com
TagsNo tags attached.
Fixed in Revision38962, 38965
LazTarget1.2
Widgetset
Attached Files
  • lazaruside.es.po (642,819 bytes)
  • gdbmidebugger.es.po (5,494 bytes)
  • debuggerstrconst.es.po (3,602 bytes)
  • objinspstrconsts.es.po (36,721 bytes)
  • lclstrconsts.es.po (46,472 bytes)
  • lazde.es.po (14,896 bytes)
  • jsonviewer.es.po (7,518 bytes)
  • lazarus_to_spanish_revised.zip (166,828 bytes)
  • pocheckerconsts.es.po (5,527 bytes)
  • README.txt (1,802 bytes)
    Quick Start for translators:
    
    For example finnish translation:
    Search for all *.fi.po files. They are simple text files, with an easy format.
    Edit them with programs like poedit(www.poedit.net) in windows,inux or mac.
    Run 'sh localize.sh'(linux) or 'localize.bat'(windows) to update translations.
    
    Post the updated xxx.fi.po files in Bug Tracker(http://bugs.freepascal.org).
    Also please check your translated .po files with PoChecker tool (lazarus/components/pochecker/) and fix all reported errors in them.
    Do not post diffs for .po files.
    
    
    Now the background:
    
    The <lazarusdir>/languages directory contains all the stuff for
    internationalization of the lazarus IDE.
    
    There are a few other directories for the codetools and the lcl. They work
    all the same. All language files can easily be updated with the
    <lazarusdir>/localize.sh or <lazarusdir>\localize.bat script.
    
    
    All text and messages used in the IDE (except the special designer units)
    should be placed into the unit lazarusidestrconsts.pas. This unit uses a
    resourcestring section, so that the compiler will create the
    <lazarusdir>/lazarusidestrconsts.rst file.
    Since this is a fpc-only format it must be converted with the rstconv program:
    
    cd <lazarusdir>/languages
    rstconv -i ../lazarusidestrconsts.rst -o lazaruside.po
    
    Hint: this is done by <lazarusdir>/localize.sh or <lazarusdir>\localize.bat.
    
    This will create the file lazaruside.po, which should be translated in all
    required languages to a lazaruside.xx.po file (it should have UTF-8 encoding). For the xx see the gettext unit
    in the procedure TranslateResourceStrings.
    
    For example:
    
    German:      lazaruside.de.po
    Russian:     lazaruside.ru.po
    Spanish:     lazaruside.es.po
    French:      lazaruside.fr.po
    Italian:     lazaruside.it.po
    
    README.txt (1,802 bytes)

Activities

2012-10-03 10:14

 

lazaruside.es.po (642,819 bytes)

2012-10-03 10:14

 

gdbmidebugger.es.po (5,494 bytes)

2012-10-03 10:14

 

debuggerstrconst.es.po (3,602 bytes)

2012-10-03 10:15

 

objinspstrconsts.es.po (36,721 bytes)

2012-10-03 10:15

 

lclstrconsts.es.po (46,472 bytes)

2012-10-03 10:15

 

lazde.es.po (14,896 bytes)

2012-10-03 12:07

 

jsonviewer.es.po (7,518 bytes)

Lucas Martín

2012-10-03 12:13

reporter   ~0062843

and also added "jsonviewer.es.po" translated 100%
path: /tools/jsonviewer/languajes/jsonviewer.es.po

Maxim Ganetsky

2012-10-03 22:14

developer   ~0062867

Last edited: 2012-10-03 22:20

I applied objinspstrconsts.es.po, lazaruside.es.po and lclstrconsts.es.po, thanks.

All other files are broken (have invalid UTF-8 sequence). Please look at this. Avoid manual editing of .po files, use a tool like poEdit for this instead.

Also please check your translated .po files with PoChecker tool (lazarus/components/pochecker/) and fix all reported errors in them.

Note that one translation was removed from lazaruside.es.po during its regeneration (apparently opening quotation mark was missing there). Check this too.

2012-10-04 16:43

 

lazarus_to_spanish_revised.zip (166,828 bytes)

Lucas Martín

2012-10-04 16:45

reporter   ~0062877

Done - Revised all files with PoChecker tool(No Error, only warnings reported by CheckDuplicateOriginals)
Done - Revised all files and converted to UTF-8
Done - Revised and Translated some fuzzy entrys in: lazaruside.es.po

Uploaded all in file: lazarus_to_spanish_revised.zip

Thanks

2012-10-04 17:45

 

pocheckerconsts.es.po (5,527 bytes)

Lucas Martín

2012-10-04 17:46

reporter   ~0062879

Uploaded file: pocheckerconsts.es.po 100 %translated (No errors) and converted to UTF-8
path of file: lazarus/components/pochecker/languages/pocheckerconsts.es.po

Lucas Martín

2012-10-04 18:50

reporter   ~0062882

Last edited: 2012-10-04 18:52

README.txt updated with the latest tips and instructions for translators
path of file: /lazarus/languages/README.txt

2012-10-04 18:51

 

README.txt (1,802 bytes)
Quick Start for translators:

For example finnish translation:
Search for all *.fi.po files. They are simple text files, with an easy format.
Edit them with programs like poedit(www.poedit.net) in windows,inux or mac.
Run 'sh localize.sh'(linux) or 'localize.bat'(windows) to update translations.

Post the updated xxx.fi.po files in Bug Tracker(http://bugs.freepascal.org).
Also please check your translated .po files with PoChecker tool (lazarus/components/pochecker/) and fix all reported errors in them.
Do not post diffs for .po files.


Now the background:

The <lazarusdir>/languages directory contains all the stuff for
internationalization of the lazarus IDE.

There are a few other directories for the codetools and the lcl. They work
all the same. All language files can easily be updated with the
<lazarusdir>/localize.sh or <lazarusdir>\localize.bat script.


All text and messages used in the IDE (except the special designer units)
should be placed into the unit lazarusidestrconsts.pas. This unit uses a
resourcestring section, so that the compiler will create the
<lazarusdir>/lazarusidestrconsts.rst file.
Since this is a fpc-only format it must be converted with the rstconv program:

cd <lazarusdir>/languages
rstconv -i ../lazarusidestrconsts.rst -o lazaruside.po

Hint: this is done by <lazarusdir>/localize.sh or <lazarusdir>\localize.bat.

This will create the file lazaruside.po, which should be translated in all
required languages to a lazaruside.xx.po file (it should have UTF-8 encoding). For the xx see the gettext unit
in the procedure TranslateResourceStrings.

For example:

German:      lazaruside.de.po
Russian:     lazaruside.ru.po
Spanish:     lazaruside.es.po
French:      lazaruside.fr.po
Italian:     lazaruside.it.po
README.txt (1,802 bytes)

Maxim Ganetsky

2012-10-05 00:20

developer   ~0062886

Applied, thanks.

You are added to contributors list.

Still no luck with "srkmecselstickyline" string in lazaruside.es.po though.

Please close if ok.

Issue History

Date Modified Username Field Change
2012-10-03 10:14 Lucas Martín New Issue
2012-10-03 10:14 Lucas Martín File Added: lazaruside.es.po
2012-10-03 10:14 Lucas Martín File Added: gdbmidebugger.es.po
2012-10-03 10:14 Lucas Martín File Added: debuggerstrconst.es.po
2012-10-03 10:15 Lucas Martín File Added: objinspstrconsts.es.po
2012-10-03 10:15 Lucas Martín File Added: lclstrconsts.es.po
2012-10-03 10:15 Lucas Martín File Added: lazde.es.po
2012-10-03 11:11 Florian Project FPC => Lazarus
2012-10-03 12:07 Lucas Martín File Added: jsonviewer.es.po
2012-10-03 12:13 Lucas Martín Note Added: 0062843
2012-10-03 12:48 Vincent Snijders LazTarget => 1.2
2012-10-03 12:48 Vincent Snijders Assigned To => Maxim Ganetsky
2012-10-03 12:48 Vincent Snijders Status new => assigned
2012-10-03 12:48 Vincent Snijders Target Version => 1.2.0
2012-10-03 22:14 Maxim Ganetsky Note Added: 0062867
2012-10-03 22:14 Maxim Ganetsky Status assigned => feedback
2012-10-03 22:17 Maxim Ganetsky Fixed in Revision => 38962
2012-10-03 22:17 Maxim Ganetsky Product Version 2.6.1 =>
2012-10-03 22:20 Maxim Ganetsky Note Edited: 0062867
2012-10-03 22:21 Maxim Ganetsky Product Version => 1.1 (SVN)
2012-10-04 16:43 Lucas Martín File Added: lazarus_to_spanish_revised.zip
2012-10-04 16:45 Lucas Martín Note Added: 0062877
2012-10-04 17:45 Lucas Martín File Added: pocheckerconsts.es.po
2012-10-04 17:46 Lucas Martín Note Added: 0062879
2012-10-04 18:50 Lucas Martín Note Added: 0062882
2012-10-04 18:51 Lucas Martín File Added: README.txt
2012-10-04 18:52 Lucas Martín Note Edited: 0062882
2012-10-05 00:20 Maxim Ganetsky Fixed in Revision 38962 => 38962, 38965
2012-10-05 00:20 Maxim Ganetsky Status feedback => resolved
2012-10-05 00:20 Maxim Ganetsky Fixed in Version => 1.1 (SVN)
2012-10-05 00:20 Maxim Ganetsky Resolution open => fixed
2012-10-05 00:20 Maxim Ganetsky Note Added: 0062886