View Issue Details

IDProjectCategoryView StatusLast Update
0023047PackagesLazReportpublic2012-10-07 21:45
ReporterAlexandr Assigned ToBart Broersma  
PrioritynormalSeveritytweakReproducibilityalways
Status closedResolutionduplicate 
PlatformNTOSWindows 
Product Version1.0.0 
Summary0023047: Strings Editor Dialog hides at each "Enter" button press
DescriptionStrings editor dialog hides on each "Enter" press.

I have a ComboBox, Im' need to input same trings in it items.
I'm found "Items" propety and press "..." button.
"Strings Editor Dialog" is opened.
I'm wrote:
Windows //<Now I'm need go to new line, I press "Enter" on keyboard>
//<"Strings Editor Dialog" hidden>
//<I'm found "Items" propety and press "..." button.>
//<"Strings Editor Dialog" showed, and carret change own poosition to 1 line, 1 char>
Steps To ReproduceSee details.
Additional InformationNo.
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetWin32/Win64
Attached Files

Relationships

duplicate of 0022666 closedMattias Gaertner Lazarus ENTER Key behavior on String Editor 

Activities

Bart Broersma

2012-10-03 12:35

developer   ~0062845

Duplicate of 0022666
This issue has been fixed in 1.0.2 and trunk.
As a workaround use Shift+Return in the editor.
You can also apply the changes from revision r38427 and rebuild lazarus.

Please close

Alexandr

2012-10-07 21:45

reporter   ~0062982

Problem resolved.

Issue History

Date Modified Username Field Change
2012-10-03 10:31 Alexandr New Issue
2012-10-03 10:31 Alexandr Widgetset => Win32/Win64
2012-10-03 12:35 Bart Broersma LazTarget => -
2012-10-03 12:35 Bart Broersma Relationship added duplicate of 0022666
2012-10-03 12:35 Bart Broersma Duplicate ID 0 => 22666
2012-10-03 12:35 Bart Broersma Status new => resolved
2012-10-03 12:35 Bart Broersma Resolution open => duplicate
2012-10-03 12:35 Bart Broersma Assigned To => Bart Broersma
2012-10-03 12:35 Bart Broersma Note Added: 0062845
2012-10-07 21:45 Alexandr Status resolved => closed
2012-10-07 21:45 Alexandr Note Added: 0062982