View Issue Details

IDProjectCategoryView StatusLast Update
0023060LazarusLCLpublic2013-09-12 15:16
ReporterStephano Assigned ToJuha Manninen  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.1 (SVN) 
Summary0023060: TClipboard.SetComponent bug
DescriptionThe following code yields a nil result whereas it should clone MyComponent:
  RegisterClass(TMyComponent);
  Clipboard.SetComponent(MyComponent);
  Result:= TMyComponent(Clipboard.GetComponent(Self, Self));

The issue is that TClipboard.GetComponent uses pcfComponent while TClipboard.SetComponent uses pcfCustomData instead. Substituting pcfCustomData by pcfComponent in TClipboard.SetComponent resolves the issue.
TagsNo tags attached.
Fixed in Revisionr42756
LazTarget1.4
Widgetset
Attached Files

Activities

Juha Manninen

2013-09-12 14:46

developer   ~0069975

Fixed. Please test.

Issue History

Date Modified Username Field Change
2012-10-05 07:47 Stephano New Issue
2012-10-05 07:47 Stephano LazTarget => -
2012-10-05 07:49 Stephano Status new => assigned
2012-10-05 07:49 Stephano Assigned To => Mattias Gaertner
2013-09-03 18:07 Stephano LazTarget - => 1.4
2013-09-12 14:36 Juha Manninen Assigned To Mattias Gaertner => Juha Manninen
2013-09-12 14:46 Juha Manninen Fixed in Revision => r42756
2013-09-12 14:46 Juha Manninen Note Added: 0069975
2013-09-12 14:46 Juha Manninen Status assigned => resolved
2013-09-12 14:46 Juha Manninen Resolution open => fixed
2013-09-12 15:16 Stephano Status resolved => closed