View Issue Details

IDProjectCategoryView StatusLast Update
0023131LazarusLCLpublic2019-04-02 08:20
ReporterJohn KozikopoulosAssigned ToJuha Manninen 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.1 (SVN)Product Build 
Target VersionFixed in Version 
Summary0023131: [GTK2+Windows] Backspace on TEdit moves cursor one position to the right
Descriptionwhen you use backspace on a TEdit control to delete a character it moves the cursor one position to the right.
It works as expected when the cursor is just before the last character or the del key is used instead of backspace.

example
123456789|0, pressing backspace everything is ok but
123456|7890, pressing backspace will move the cursor one position to the right eg 123457|890 instead of 12345|7890.

Attached is a small application that reproduces the problem for me.

Version information

SVN Lazarus 1.1 r38674 FPC 2.6.1 i386-win32-win32/win64
Windows 7 32 bit
GTK2 Runtime 2.24.8-2011-12-03-ash
TagsNo tags attached.
Fixed in Revisionr56287
LazTarget-
WidgetsetGTK 2
Attached Files

Relationships

related to 0032321 resolvedMichl TEdit / TDbEdit cursor position after overwrite text 
related to 0030596 resolvedJuha Manninen error in the keyboard backspace key on linux TEdit 
related to 0032630 closedJuha Manninen [patch] Gtk2 TEdit/TMemo: fix text selection, make OnChange event compatible with LCL-Win32 

Activities

2012-10-16 10:24

 

GTK-BackSpace-TestCase.zip (3,214 bytes)

Zeljan Rikalo

2012-10-16 10:52

developer   ~0063189

Under gtk2 linux it works ok.

John Kozikopoulos

2012-10-27 08:54

reporter   ~0063493

that is good to know thank you.

Juha Manninen

2017-10-08 18:03

developer   ~0103260

Apparently this problem has been in some systems and GTK2 versions for a long time.
Can you please test again. Windows versions and GTK2 versions have been updated since 2012.

Juha Manninen

2017-10-21 17:30

developer   ~0103654

No feedback. Detaching myself.

Juha Manninen

2017-11-05 22:52

developer   ~0103891

Fixed, please test.

Issue History

Date Modified Username Field Change
2012-10-16 10:24 John Kozikopoulos New Issue
2012-10-16 10:24 John Kozikopoulos File Added: GTK-BackSpace-TestCase.zip
2012-10-16 10:24 John Kozikopoulos Widgetset => GTK 2
2012-10-16 10:52 Zeljan Rikalo Note Added: 0063189
2012-10-27 08:54 John Kozikopoulos Note Added: 0063493
2012-11-03 11:46 Juha Manninen LazTarget => -
2012-11-03 11:46 Juha Manninen Summary Backspace on an edit the cursor one position to the right. => [GTK2+Windows] Backspace on an edit the cursor one position to the right.
2012-11-03 12:55 Maxim Ganetsky Summary [GTK2+Windows] Backspace on an edit the cursor one position to the right. => [GTK2+Windows] Backspace on TEdit moves cursor one position to the right
2017-08-25 10:13 Juha Manninen Relationship added related to 0032321
2017-10-08 17:55 Juha Manninen Relationship added related to 0030596
2017-10-08 18:03 Juha Manninen Note Added: 0103260
2017-10-08 18:03 Juha Manninen Assigned To => Juha Manninen
2017-10-08 18:03 Juha Manninen Status new => feedback
2017-10-21 17:30 Juha Manninen Note Added: 0103654
2017-10-21 17:30 Juha Manninen Assigned To Juha Manninen =>
2017-10-21 17:30 Juha Manninen Status feedback => new
2017-11-03 18:23 Juha Manninen Relationship added related to 0032630
2017-11-05 22:52 Juha Manninen Fixed in Revision => r56287
2017-11-05 22:52 Juha Manninen Note Added: 0103891
2017-11-05 22:52 Juha Manninen Status new => resolved
2017-11-05 22:52 Juha Manninen Resolution open => fixed
2017-11-05 22:52 Juha Manninen Assigned To => Juha Manninen