View Issue Details

IDProjectCategoryView StatusLast Update
0023133LazarusLazReportpublic2013-11-14 13:20
ReporterTony WhymanAssigned ToJesus Reyes 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.0.2Product Build 
Target Version1.1 (SVN)Fixed in Version1.1 (SVN) 
Summary0023133: Report Designer opens as a narrow vertical rectangle
DescriptionWhen installing a fresh install on Linux 64 bit, the Lazreport report designer (opening an existing form) opens as a long narrow rectangle, with a width no more than the left hand bar and a height almost the screen width.

Additional InformationI fixed the problem on my system by opening the original lfm/pas file in Lazarus and changing the WindowState from wsMaximized to wsNormal. The report designer then opens normally using its default width and height.
TagsNo tags attached.
Fixed in Revision40562
LazTarget1.2
WidgetsetGTK 2
Attached Files

Relationships

related to 0021634 closedJesus Reyes Lazreport Designer is Shown as 10x10px Window 
related to 0023226 closedJesus Reyes lazreport preview and design windows width 

Activities

tintinux

2012-11-13 19:58

reporter   ~0063832

For me, the workaround in "additional information" doesn't change anything...

tintinux

2013-03-19 20:02

reporter   ~0066406

Hi

This is not only with the report designer, but also with the report preview when it is Modal.

If set Report.ModalPreview := False it not better since the calling forms are modal, and the preview is behinf them !


Regards

Jesus Reyes

2013-03-19 20:08

developer   ~0066407

This problem has been solved, forgot there were a couple of reports about it

Issue History

Date Modified Username Field Change
2012-10-16 10:43 Tony Whyman New Issue
2012-10-16 10:43 Tony Whyman Widgetset => GTK 2
2012-10-16 19:36 Jesus Reyes Status new => assigned
2012-10-16 19:36 Jesus Reyes Assigned To => Jesus Reyes
2012-11-05 20:46 Jesus Reyes Relationship added related to 0023226
2012-11-13 19:58 tintinux Note Added: 0063832
2013-03-19 20:02 tintinux Note Added: 0066406
2013-03-19 20:08 Jesus Reyes Fixed in Revision => 40562
2013-03-19 20:08 Jesus Reyes LazTarget => 1.2
2013-03-19 20:08 Jesus Reyes Note Added: 0066407
2013-03-19 20:08 Jesus Reyes Status assigned => resolved
2013-03-19 20:08 Jesus Reyes Fixed in Version => 1.1 (SVN)
2013-03-19 20:08 Jesus Reyes Resolution open => fixed
2013-03-19 20:08 Jesus Reyes Target Version => 1.1 (SVN)
2013-03-19 20:18 Jesus Reyes Relationship added related to 0021634