View Issue Details

IDProjectCategoryView StatusLast Update
0023172LazarusIDEpublic2016-05-02 19:46
ReporterMarcos DouglasAssigned ToJuha Manninen 
PrioritynormalSeveritycrashReproducibilityalways
Status closedResolutionfixed 
Platformi386/x86_64OSWindowsOS VersionXP/7
Product Version1.0.3 (SVN)Product Buildr39145 
Target VersionFixed in Version 
Summary0023172: TActionList Editor: List index (1) out of bounds
Description1- Error using TActionList Editor and Component Treeview
2- To rename an Action only is possible using the component treeview.
Steps To ReproduceTo reproduce the error:
1- put a TActionList on the form;
2- add a new TAction;
3- implement OnExecute event;
4- drop a button and link it with the Action;
5- double click on TActionList;
6- in the ActionList Editor, select the action;

Just a curiosity here: All TAction objects they have the OnExecute
event implemented, do not show the property Name on the Object
Inspector when you click on... why?

7- In Object Inspector tree view components, click on the Action
(TButton->TAction)
Additional InformationLazarus 1.1 r39145 FPC 2.6.1 i386-win32-win32/win64
TagsNo tags attached.
Fixed in Revisionr39184
LazTarget-
WidgetsetWin32/Win64
Attached Files

Relationships

related to 0023181 resolvedJuha Manninen OI: make "show all owned objects in properties" optional 

Activities

Marcos Douglas

2012-10-21 00:18

reporter   ~0063331

See "Steps To Reproduce" for more information, please.

Juha Manninen

2012-10-21 16:38

developer   ~0063355

Strange, I could reproduce this with my mini-laptop but not with the development machine.
I can reproduce some of the related issues though.

Marcos Douglas

2012-10-24 14:17

reporter   ~0063412

Sometimes I can't reproduce too. But most times I can, as I described in "step to reproduce".

Juha Manninen

2012-10-29 22:54

developer   ~0063557

Old behavior returned. Defining ShowOwnedObjectsOI shows all owned objects in OI.

Issue History

Date Modified Username Field Change
2012-10-20 18:52 Marcos Douglas New Issue
2012-10-20 18:52 Marcos Douglas Widgetset => Win32/Win64
2012-10-21 00:18 Marcos Douglas Note Added: 0063331
2012-10-21 14:36 Juha Manninen Relationship added related to 0023181
2012-10-21 16:38 Juha Manninen Note Added: 0063355
2012-10-24 14:17 Marcos Douglas Note Added: 0063412
2012-10-29 22:54 Juha Manninen Fixed in Revision => r39184
2012-10-29 22:54 Juha Manninen LazTarget => -
2012-10-29 22:54 Juha Manninen Status new => resolved
2012-10-29 22:54 Juha Manninen Resolution open => fixed
2012-10-29 22:54 Juha Manninen Assigned To => Juha Manninen
2012-10-29 22:54 Juha Manninen Note Added: 0063557
2016-05-02 19:46 Marcos Douglas Status resolved => closed