View Issue Details

IDProjectCategoryView StatusLast Update
0023181LazarusIDEpublic2016-03-15 13:15
ReporterAlexander S. KleninAssigned ToJuha Manninen 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.1 (SVN)Product Build 
Target VersionFixed in Version 
Summary0023181: OI: make "show all owned objects in properties" optional
DescriptionSince revision 39097 (IDEIntf: OI: component treeview: show all owned objects
in properties), component treeview became less useful,
because it is now cluttered with fields which duplicate object inspector.

(Additionally, this commit introduced a large number of regressions,
but this issue is independent of them).

I can see that for some users this interface may be an improvement,
but it is a regression at least for me.
Please make it optional.
TagsNo tags attached.
Fixed in Revision
LazTarget-
Widgetset
Attached Files

Relationships

related to 0023172 closedJuha Manninen TActionList Editor: List index (1) out of bounds 
related to 0023176 resolvedJuha Manninen [regression] OI: "List index out of bounds" while selecting item in treeview 
related to 0023180 resolvedJuha Manninen [regression] OI: Property names appear and disappear randomly in treeview 
related to 0023179 resolvedJuha Manninen [regression] OI: Duplicate entries on treeview 
related to 0023178 resolvedJuha Manninen [regression] OI: Access violation while trying to modify property 
related to 0023177 resolvedJuha Manninen [regression] OI: Fields disappear from object inspector 
related to 0021010 closedJuha Manninen Object Inspector's Tree View updated badly 

Activities

Ludo Brands

2012-10-21 12:59

developer   ~0063347

Additionally, referenced objects are shown also. A TSQLQuery will show as "child" the connection, transaction and datasource used. TSQLQuery doesn't own any of these but just references them. Mixing "owned by" and "referenced by" in the same tree view is very confusing and redundant.

Example 2: a sqlconnection doesn't work without a transaction linked to it. Now the tree view shows the connection with the transaction as child and the transaction with the connection as child.

It misses also coherence in that only objects on the current form are shown. Referenced objects in fe. a data module are not shown in the treeview.

Juha Manninen

2012-10-21 15:47

developer   ~0063351

This and the related issues are caused by r39097 which tries to solve (among other cases) the 0021010.
Maybe it should be reverted, I don't know.

Juha Manninen

2016-03-15 13:15

developer   ~0091063

Resolving this. The problem was solved differently already some time ago.

Issue History

Date Modified Username Field Change
2012-10-21 12:46 Alexander S. Klenin New Issue
2012-10-21 12:46 Alexander S. Klenin LazTarget => -
2012-10-21 12:59 Ludo Brands Note Added: 0063347
2012-10-21 14:36 Juha Manninen Relationship added related to 0023172
2012-10-21 14:37 Juha Manninen Relationship added related to 0023176
2012-10-21 14:37 Juha Manninen Relationship added related to 0023180
2012-10-21 14:37 Juha Manninen Relationship added related to 0023179
2012-10-21 14:38 Juha Manninen Relationship added related to 0023178
2012-10-21 14:38 Juha Manninen Relationship added related to 0023177
2012-10-21 14:40 Juha Manninen Relationship added related to 0021010
2012-10-21 15:47 Juha Manninen Note Added: 0063351
2016-03-15 13:15 Juha Manninen Note Added: 0091063
2016-03-15 13:15 Juha Manninen Status new => resolved
2016-03-15 13:15 Juha Manninen Resolution open => fixed
2016-03-15 13:15 Juha Manninen Assigned To => Juha Manninen