View Issue Details

IDProjectCategoryView StatusLast Update
0023182LazarusWidgetsetpublic2013-04-22 17:44
ReporterFabrizio Fellini Assigned ToZeljan Rikalo  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product Version1.0.3 (SVN) 
Summary0023182: TEdit component loses cursor position
DescriptionA TEdit, with AutoSelect=False, loses cursor position when I change focus using the keyboard (Tab key or other methods), and its SelStart value is reset to 0. In the test application, using the Tab key, the Label1.Caption, where I save the Edit1.SelStart value when Edit1 loses the focus, is always set to 0.
This error heavily influences all those programming techniques where there is the need to manage cursor position.
In version 0.9.30.4 there isn't this error: it appeared in version 1.0.
TagsNo tags attached.
Fixed in Revision39162
LazTarget-
WidgetsetGTK 2
Attached Files

Relationships

duplicate of 0021897 closedZeljan Rikalo GTK2 TEdit Selstart is always 0 when Focus changes to the TEdit. 
related to 0018164 closedZeljan Rikalo TEdit selection 
related to 0023219 closedZeljan Rikalo TEdit component loses SelStart and SelLength values 
related to 0024308 closedZeljan Rikalo Copy/Paste content of TEdit (gtk2) in linux X11 by mouse middle button does not work 

Activities

2012-10-21 15:52

 

test.zip (2,306 bytes)

Fabrizio Fellini

2012-10-25 00:04

reporter   ~0063426

After a Google search using "tedit gtk2 site:bugs.freepascal.org", I noticed the issue 0018164 (TEdit selection). The result of this issue was the revision 36097.
Then I tried to run my test application with revision 36096: the behavior was correct.
After an update to revision 36097... here is the error!

Zeljan Rikalo

2012-10-25 08:43

developer   ~0063433

Please test and close if ok.

Fabrizio Fellini

2012-10-25 23:14

reporter   ~0063458

Well, the problem is largely solved.
But a small bug is still present: if the text is partially selected, and then SelLength>0, when focus returns to the control the selection is lost.
Under Windows this doesn't happen.
If you, Zeljan, think this bug isn't solvable, let me know, and then I'll close the issue.

Zeljan Rikalo

2012-10-26 08:07

developer   ~0063462

hm...maybe, so scenario is next ? :
1.TEdit.AutoSelect = False
2.You want to remeber cursor postion and selection ?

This issue is about cursor position, so pls. close, open new one and attach example about saving selection.

Fabrizio Fellini

2012-10-26 19:44

reporter   ~0063477

OK, I close this issue and I'll open a new one about that small bug.

Issue History

Date Modified Username Field Change
2012-10-21 15:52 Fabrizio Fellini New Issue
2012-10-21 15:52 Fabrizio Fellini File Added: test.zip
2012-10-21 15:52 Fabrizio Fellini Widgetset => GTK 2
2012-10-25 00:04 Fabrizio Fellini Note Added: 0063426
2012-10-25 02:51 Juha Manninen Relationship added duplicate of 0021897
2012-10-25 02:56 Luiz Americo LazTarget => -
2012-10-25 02:56 Luiz Americo Assigned To => Zeljan Rikalo
2012-10-25 02:56 Luiz Americo Status new => assigned
2012-10-25 07:48 Zeljan Rikalo Relationship added related to 0018164
2012-10-25 08:43 Zeljan Rikalo Fixed in Revision => 39162
2012-10-25 08:43 Zeljan Rikalo Status assigned => resolved
2012-10-25 08:43 Zeljan Rikalo Resolution open => fixed
2012-10-25 08:43 Zeljan Rikalo Note Added: 0063433
2012-10-25 23:14 Fabrizio Fellini Status resolved => assigned
2012-10-25 23:14 Fabrizio Fellini Resolution fixed => reopened
2012-10-25 23:14 Fabrizio Fellini Note Added: 0063458
2012-10-26 08:07 Zeljan Rikalo Status assigned => resolved
2012-10-26 08:07 Zeljan Rikalo Resolution reopened => fixed
2012-10-26 08:07 Zeljan Rikalo Note Added: 0063462
2012-10-26 19:44 Fabrizio Fellini Status resolved => closed
2012-10-26 19:44 Fabrizio Fellini Note Added: 0063477
2012-10-30 23:51 Juha Manninen Relationship added related to 0023219
2013-04-22 17:44 Mattias Gaertner Relationship added related to 0024308