View Issue Details

IDProjectCategoryView StatusLast Update
0023209LazarusIDEpublic2012-10-30 09:43
ReporterJulio Jiménez BorregueroAssigned ToJuha Manninen 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
PlatformOSLinuxOS Version
Product Version1.1 (SVN)Product Build 
Target VersionFixed in Version 
Summary0023209: Object Inspector shows selected tabsheet twice
DescriptionThere is a bug showing the selected tabsheet twice, one in the first position of the list and other in the right position.

If you click the first one it shows the exception 'List Index(1) out of bounds'
Steps To ReproduceDrop a TExtendedNotebook or TPageControl
Add more than one page to it.(right click in the component and select Add Page)
Click in a TabSheet and watch the Object Inspector window.
Additional InformationLazarus 1.1 trunk
FPC 2.6.0
Tested in Gtk2 and QT

Attached image showing the bug
TagsNo tags attached.
Fixed in Revisionr39184
LazTarget-
Widgetset
Attached Files

Relationships

duplicate of 0023179 resolvedJuha Manninen [regression] OI: Duplicate entries on treeview 

Activities

2012-10-25 10:00

 

objectinspectorbug.png (45,551 bytes)
objectinspectorbug.png (45,551 bytes)

Julio Jiménez Borreguero

2012-10-29 09:51

reporter   ~0063537

No longer failing since Revision: 39184

Juha Manninen

2012-10-29 22:37

developer   ~0063554

Old behavior returned. Defining ShowOwnedObjectsOI shows all owned objects in OI.

Julio Jiménez Borreguero

2012-10-30 09:43

reporter   ~0063565

Probably you can mark as resolved also this issue: 0023215

Issue History

Date Modified Username Field Change
2012-10-25 10:00 Julio Jiménez Borreguero New Issue
2012-10-25 10:00 Julio Jiménez Borreguero File Added: objectinspectorbug.png
2012-10-25 11:23 Zeljan Rikalo Status new => assigned
2012-10-25 11:23 Zeljan Rikalo Assigned To => Juha Manninen
2012-10-25 14:25 Alexander S. Klenin Relationship added duplicate of 0023179
2012-10-29 09:51 Julio Jiménez Borreguero Note Added: 0063537
2012-10-29 22:37 Juha Manninen Fixed in Revision => r39184
2012-10-29 22:37 Juha Manninen LazTarget => -
2012-10-29 22:37 Juha Manninen Status assigned => resolved
2012-10-29 22:37 Juha Manninen Resolution open => fixed
2012-10-29 22:37 Juha Manninen Note Added: 0063554
2012-10-30 09:43 Julio Jiménez Borreguero Note Added: 0063565