View Issue Details

IDProjectCategoryView StatusLast Update
0023211LazarusWidgetsetpublic2012-11-04 21:12
ReporterJulio Jiménez BorregueroAssigned ToJesus Reyes 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.1 (SVN)Product Build 
Target Version1.2.0Fixed in Version1.1 (SVN) 
Summary0023211: QT widgetset not working properly in report designer (Lazreport)
DescriptionScreen/Canvas is not updated while dragging/resizing a component in the form editor. This makes QT unusable in Lazreport.

It does work properly using GTK2 and Windows
Steps To ReproduceLazarus compiled for QT
Add a TfrReport in an empty form
Double click on the TfrReport, it will open the report designer
Add a component to the report, for example a Text Objet.
Try to drag the component to another place in the report page
You'll see nothing in the screen (but the object has been dragged to another place) until you do click in the reportpage, then the screen is updated.
Additional InformationIf you close the window (report editor) with an edited report, the save/cancel dialog is hidden behind the report editor form. I don't know if this is related to the same bug or is caused by another one.

If you close the window pressing 'Close' button inside the editor form, all is fine.

QT only too.
TagsNo tags attached.
Fixed in Revision39243
LazTarget1.2
WidgetsetQT
Attached Files

Activities

Julio Jiménez Borreguero

2012-10-25 17:35

reporter   ~0063449

Tested using:
FPC 2.6.0 i386 Linux (Debian SID)
Lazarus 1.1 svn

Zeljan Rikalo

2012-10-25 18:39

developer   ~0063451

That's because lazreport paints outside of paint event.
I'm using FastReports 2.5 (ported to LCL) and currently finish porting of FastReports 4.12 and everything works fine.

Zeljan Rikalo

2012-10-26 08:09

developer   ~0063464

@Jesus, as I already pointed: FastReports 4.12 work without such problem with qt,win32 and gtk2. Can you look into lazreport code and see if it paints outside of paintevent (I guess yes ... because I've fixed same thing in FastReports 2.5 and FastReports 4.12 for lazarus).

Jesus Reyes

2012-11-04 21:01

developer   ~0063667

Applied Patch from Julio
Thanks!

btw, I couldn't reproduce the save/cancel dialgo behind report designer.

Julio Jiménez Borreguero

2012-11-04 21:12

reporter   ~0063668

@Jesus It only happens if you close the desingner form pressing close button on tittle bar. If you press Close button on tool bar, all is fine.

To reproduce it, compile lazreport for QT and run it. Add a TfrReport to an empty form and double click on it to run the designer, add a component to the report and close the designer pressing the close window button (x) on the tittle bar.

The question dialog is behind the form so you can't see it. (Running on Gnome 2/Mate) IIRC it also happens in XFCE, not tried on Kde yet.

Issue History

Date Modified Username Field Change
2012-10-25 17:20 Julio Jiménez Borreguero New Issue
2012-10-25 17:20 Julio Jiménez Borreguero Widgetset => QT
2012-10-25 17:35 Julio Jiménez Borreguero Note Added: 0063449
2012-10-25 18:39 Zeljan Rikalo LazTarget => -
2012-10-25 18:39 Zeljan Rikalo Note Added: 0063451
2012-10-25 18:39 Zeljan Rikalo Status new => acknowledged
2012-10-26 08:09 Zeljan Rikalo Note Added: 0063464
2012-10-26 08:09 Zeljan Rikalo Assigned To => Jesus Reyes
2012-10-26 08:09 Zeljan Rikalo Status acknowledged => assigned
2012-11-04 21:01 Jesus Reyes Fixed in Revision => 39243
2012-11-04 21:01 Jesus Reyes LazTarget - => 1.2
2012-11-04 21:01 Jesus Reyes Status assigned => resolved
2012-11-04 21:01 Jesus Reyes Fixed in Version => 1.1 (SVN)
2012-11-04 21:01 Jesus Reyes Resolution open => fixed
2012-11-04 21:01 Jesus Reyes Note Added: 0063667
2012-11-04 21:01 Jesus Reyes Target Version => 1.2.0
2012-11-04 21:12 Julio Jiménez Borreguero Note Added: 0063668