View Issue Details

IDProjectCategoryView StatusLast Update
0023263PackagesCustom Drawnpublic2012-12-04 21:47
ReporterRasmussen Assigned ToMaxim Ganetsky  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version1.0.2 
Summary0023263: Error while installing LazOpenGlContext 0.0.1 package
DescriptionUnder 64-bit ArchLinux when trying to install package got error:
/usr/lib/lazarus/components/opengl/glqtcontext.pas(150,15) Error: User defined: ToDo: get GLXDrawable

This problem also seen on svn (1.0.3) version.

Additional InformationI use nvidia binary drivers, libgl package isn't installed on my PC due to compatability with that drivers reasons, but as I know, that drivers provides libgl (on nvidia-settings OpenGL seems enabled and working fine on other applications, thats depends of it, e.g. PlayOnLinux).

I am deeply, deeply sorry for my ugly english.
Tagslinux, OpenGL, x86
Fixed in Revision
LazTarget-
WidgetsetQT
Attached Files

Relationships

duplicate of 0015589 resolvedMattias Gaertner Lazarus TOpenGLControl doesn't support QT 

Activities

Felipe Monteiro de Carvalho

2012-12-04 14:19

developer   ~0064137

Unassigning from myself as I rarely work on the opengl stuff

Andrey Zubarev

2012-12-04 17:27

reporter   ~0064142

duplicate http://bugs.freepascal.org/view.php?id=15589

Issue History

Date Modified Username Field Change
2012-11-02 22:20 Rasmussen New Issue
2012-11-02 22:20 Rasmussen Status new => assigned
2012-11-02 22:20 Rasmussen Assigned To => Felipe Monteiro de Carvalho
2012-11-02 22:20 Rasmussen Widgetset => QT
2012-11-02 22:21 Rasmussen Tag Attached: linux
2012-11-02 22:21 Rasmussen Tag Attached: OpenGL
2012-11-02 22:21 Rasmussen Tag Attached: x86
2012-12-04 14:19 Felipe Monteiro de Carvalho Assigned To Felipe Monteiro de Carvalho =>
2012-12-04 14:19 Felipe Monteiro de Carvalho Note Added: 0064137
2012-12-04 17:27 Andrey Zubarev Note Added: 0064142
2012-12-04 21:47 Maxim Ganetsky LazTarget => -
2012-12-04 21:47 Maxim Ganetsky Relationship added duplicate of 0015589
2012-12-04 21:47 Maxim Ganetsky Duplicate ID 0 => 15589
2012-12-04 21:47 Maxim Ganetsky Status assigned => resolved
2012-12-04 21:47 Maxim Ganetsky Resolution open => duplicate
2012-12-04 21:47 Maxim Ganetsky Assigned To => Maxim Ganetsky