View Issue Details

IDProjectCategoryView StatusLast Update
0023345LazarusWidgetsetpublic2018-10-25 10:07
ReporterMaurício Féo RivelloAssigned ToLacaK 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.0.2Product Build 
Target VersionFixed in Version2.1 (SVN) 
Summary0023345: Tedit autoselect on winCE is always ON.
DescriptionWhen you tab to a Tedit on a winCE application, it always select all the text.
When the focus is on the Tedit and you click outside it, the text is also selected.

The same program compiled for win32 works normally according to the autoselect property. For winCE, it acts as described regardless of autoselect value.
Additional InformationBecause of this I'm unable to conclude my virtual keyboard cause everytime I click on a edit and then click on the keyboard, the whole text in the edit is selected and hence every new character replaces all the text.
TagsNo tags attached.
Fixed in Revision59349
LazTarget-
WidgetsetWinCE
Attached Files

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2012-11-18 17:46 Maurício Féo Rivello New Issue
2012-11-18 17:46 Maurício Féo Rivello Widgetset => WinCE
2015-02-06 18:15 Juha Manninen Assigned To => Stephano
2015-02-06 18:15 Juha Manninen Status new => assigned
2018-10-25 10:07 LacaK Fixed in Revision => 59349
2018-10-25 10:07 LacaK LazTarget => -
2018-10-25 10:07 LacaK Status assigned => resolved
2018-10-25 10:07 LacaK Fixed in Version => 2.1 (SVN)
2018-10-25 10:07 LacaK Resolution open => fixed
2018-10-25 10:07 LacaK Assigned To Stephano => LacaK