View Issue Details

IDProjectCategoryView StatusLast Update
0023347LazarusIDEpublic2012-11-19 07:08
ReporterMark T. Assigned ToMattias Gaertner  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
PlatformWin64OSWindows7 Build 7601 
Product Version1.0.2 
Summary0023347: Compile message: - Error: Illegal parameter: -vewnhildmpcx
DescriptionVery similar to Issue ID: 0015872 (closed).
I read "How do I create a bug report". After logging on, searched extensively for the "Reopen Issue button", not found.
When attempt to Build any minimal project (even just a skeliton), get Compile message: - Error: Illegal parameter: -vewnhildmpcx
Steps To ReproduceProject Opetions / verbosity during compilation
select any of the following combinations of verbosity options:
-vewnhildmpcx
-vewnhildmp
-Vmp
-vewnhildmcx
-vewnhildmx
-vewnhilmx
-vewnhimx
-vewnhmx
-Vhmx
-Vmx
-Vmc
Additional InformationThis would have the greatest impact for novice users.
Note: I had installed lazarus-ver1.0.2-FPC-2.6.0-win32 binary package.
TagsNo tags attached.
Fixed in Revision
LazTarget-
Widgetset
Attached Files

Relationships

related to 0015872 closedMattias Gaertner Error: Illegal parameter: -vmc 
related to 0023351 resolvedMattias Gaertner Reopen issue 0015872 and 0023347 Compile message: - Error: Illegal parameter: -vewnhildmpcx 

Activities

Bart Broersma

2012-11-18 22:23

developer   ~0063897

The -v options does not support the letter "m", so all examples will fail.
Which checkbox did you check to get the "m" in there?
It does not list in Lazarus 1.1 r39272 FPC 2.6.0 i386-win32-win32/win64
The longest verbosity param I can get using the project options dialog is "-vewnhilbdutpcx"

Mattias Gaertner

2012-11-18 22:31

manager   ~0063899

-vm is show macros.

It seems any combination with more than 8 codes leads to the error.

Bart Broersma

2012-11-18 22:43

developer   ~0063900

Last edited: 2012-11-18 22:46

@Mattias; Maybe I understand incorrectly, but:
fpc -vewnhilbdutpcx test.pas compiles just fine (>8 codes).

Also "m" as a parameter for -v does not show in help (fpc -h):
(fpc 2.6.0 win32)
(format adjusted for mantis)

  -v<x> Be verbose. <x> is a combination of the following letters:
e : Show errors (default)
0 : Show nothing (except errors)
w : Show warnings
u : Show unit info
n : Show notes
t : Show tried/used files
h : Show hints
c : Show conditionals
i : Show general info
d : Show debug info
l : Show linenumbers
r : Rhide/GCC compatibility mode
s : Show time stamps
q : Show message numbers
a : Show everything
x : Executable info (Win32 only)
b : Write file names messages
p : Write tree.log with parse tree with full path
v : Write fpcdebug.txt with lots of debugging info

Mattias Gaertner

2012-11-18 22:45

manager   ~0063901

Yes, sorry. It was "show defined macros" a long time ago.

Bart Broersma

2012-11-18 22:50

developer   ~0063902

Last edited: 2012-11-18 23:05

fpc -vm test.pas compiles nevertheless without errors.
Any other letter after -vm throws an error.

In 1.0.2 the following arguments for -v will be placed after the "m":
p,c,x.
So selecting any of these will give an error if "show defined macros" is selected.

The -vm option should be removed from the dialog.
Also, fpc should throw an error on -vm (maybe fixed in fpc trunk already?)

Mattias Gaertner

2012-11-18 22:58

manager   ~0063903

See the related bug.

Mark T.

2012-11-19 01:19

reporter   ~0063907

This does not appear to be the same as Issue ID: 0015872. Since the diff file attached to Issue ID: 0015872 to contain a patch for revision 38375.
The latest stable revision I downloaded and reporting on here is revision
39019. It is still an issue. So why is it still reoccurring?

Sven Barth

2012-11-19 07:08

manager   ~0063912

@Matthias: As Jonas wrote on the FPC list there never was an option to "show defined macros".

Regards,
Sven

Issue History

Date Modified Username Field Change
2012-11-18 20:03 Mark T. New Issue
2012-11-18 22:23 Bart Broersma LazTarget => -
2012-11-18 22:23 Bart Broersma Note Added: 0063897
2012-11-18 22:23 Bart Broersma Status new => feedback
2012-11-18 22:31 Juha Manninen Relationship added related to 0015872
2012-11-18 22:31 Mattias Gaertner Note Added: 0063899
2012-11-18 22:43 Bart Broersma Note Added: 0063900
2012-11-18 22:45 Mattias Gaertner Note Added: 0063901
2012-11-18 22:46 Bart Broersma Note Edited: 0063900
2012-11-18 22:50 Bart Broersma Note Added: 0063902
2012-11-18 22:58 Mattias Gaertner Note Added: 0063903
2012-11-18 22:59 Mattias Gaertner Assigned To => Mattias Gaertner
2012-11-18 22:59 Mattias Gaertner Status feedback => resolved
2012-11-18 22:59 Mattias Gaertner Resolution open => duplicate
2012-11-18 23:05 Bart Broersma Note Edited: 0063902
2012-11-19 01:19 Mark T. Status resolved => closed
2012-11-19 01:19 Mark T. Note Added: 0063907
2012-11-19 02:23 Juha Manninen Relationship added related to 0023351
2012-11-19 07:08 Sven Barth Note Added: 0063912