View Issue Details

IDProjectCategoryView StatusLast Update
0023355LazarusDebuggerpublic2012-12-31 15:29
ReporterLuiz AmericoAssigned ToMartin Friebe 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product VersionProduct Build 
Target VersionFixed in Version1.1 (SVN) 
Summary0023355: Range check error when debugging the Lazarus IDE
DescriptionHow to reproduce:

- Install TAChart
- Open lazarus.lpi
- Compile the IDE
- In the compiled IDE:
  - Put a breakpoint in TChartNavScrollBar.ChartExtentChanged (tachart/tanavigation.pas)
  - open tachar/demos/navigatedemo
  - Set Over (F8) until line Position := Round(WeightedAverage(Min, Max, (le.a.X - fe.a.X) / fw));
  - Try to Step In (F7) -> boom!
Exception: ERangeError with message "Range check error"
Context: TGDBMIDebuggerCommandExecute. State: Run

Using Lazarus 1.1 r39307 FPC 2.6.0 x86_64-linux-gtk 2
TagsNo tags attached.
Fixed in Revision39333
LazTarget-
Widgetset
Attached Files

Activities

Martin Friebe

2012-11-20 14:16

manager   ~0063931

I have to try on 64 bit later (does not happen on my 32 bit).

Since there are various other factors that may affect this, please supply a log as described here: http://wiki.lazarus.freepascal.org/GDB_Debugger_Tips#Log_info_for_debug_session

Martin Friebe

2012-11-22 01:03

manager   ~0063960

Does this happen only, if the asm window is open?

Please test with rev 39333

Martin Friebe

2012-12-04 12:42

manager   ~0064130

Please re-open, if issue still occurs

Issue History

Date Modified Username Field Change
2012-11-19 20:57 Luiz Americo New Issue
2012-11-19 20:57 Luiz Americo Status new => assigned
2012-11-19 20:57 Luiz Americo Assigned To => Marc Weustink
2012-11-19 20:57 Luiz Americo LazTarget => -
2012-11-20 13:55 Martin Friebe Assigned To Marc Weustink => Martin Friebe
2012-11-20 14:16 Martin Friebe Note Added: 0063931
2012-11-20 14:16 Martin Friebe Status assigned => feedback
2012-11-22 01:03 Martin Friebe Note Added: 0063960
2012-12-04 12:42 Martin Friebe Fixed in Revision => 39333
2012-12-04 12:42 Martin Friebe Status feedback => resolved
2012-12-04 12:42 Martin Friebe Fixed in Version => 1.1 (SVN)
2012-12-04 12:42 Martin Friebe Resolution open => fixed
2012-12-04 12:42 Martin Friebe Note Added: 0064130
2012-12-31 15:29 Luiz Americo Status resolved => closed