View Issue Details

IDProjectCategoryView StatusLast Update
0023362LazarusWidgetsetpublic2012-11-21 10:34
ReporterValdas Jankūnas Assigned ToZeljan Rikalo  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformLinux 64 bit, 3.5.0-18-genericOSKubuntu 
Product Version1.1 (SVN) 
Summary0023362: [Qt] Tab icon of PageControl is always 16x16
Description In Gtk2 size of picture in Tab of PageControl is same as in ImageList (see screenshot "shot_gtk2.png" - picture size is 32x32), but in Qt displayed picture is always 16x16 (see screenshot "shot_qt.png" - displayed picture is stretched to 16x16).

 Try demonstration project in "bugas.tar.bz2".
TagsNo tags attached.
Fixed in Revision39325
LazTarget-
WidgetsetQT
Attached Files

Activities

2012-11-20 15:06

 

bugas.tar.bz2 (79,963 bytes)

2012-11-20 15:06

 

shot_gtk2.png (29,399 bytes)   
shot_gtk2.png (29,399 bytes)   

2012-11-20 15:06

 

shot_qt.png (32,968 bytes)   
shot_qt.png (32,968 bytes)   

Zeljan Rikalo

2012-11-20 20:20

developer   ~0063936

Keep in mind that maybe qt does not allow bigger images in tabs. Also what with 64x64 image (then tab height should be at least 68-72px) ?

Zeljan Rikalo

2012-11-20 20:23

developer   ~0063937

I'll try to do something with:
http://qt-project.org/doc/qt-4.8/qtabbar.html#iconSize-prop , maybe it'll work.

Valdas Jankūnas

2012-11-20 21:30

reporter   ~0063941

I noticed this because DPI of my screen is 141 and I wanted to adapt image size to font size (21 pixels).

Zeljan Rikalo

2012-11-21 07:44

developer   ~0063947

Please test and close if ok.

Valdas Jankūnas

2012-11-21 10:34

reporter   ~0063951

Works OK.
 Thank you very much!

Issue History

Date Modified Username Field Change
2012-11-20 15:06 Valdas Jankūnas New Issue
2012-11-20 15:06 Valdas Jankūnas File Added: bugas.tar.bz2
2012-11-20 15:06 Valdas Jankūnas Widgetset => QT
2012-11-20 15:06 Valdas Jankūnas File Added: shot_gtk2.png
2012-11-20 15:06 Valdas Jankūnas File Added: shot_qt.png
2012-11-20 20:19 Zeljan Rikalo Status new => assigned
2012-11-20 20:19 Zeljan Rikalo Assigned To => Zeljan Rikalo
2012-11-20 20:20 Zeljan Rikalo LazTarget => -
2012-11-20 20:20 Zeljan Rikalo Note Added: 0063936
2012-11-20 20:20 Zeljan Rikalo Status assigned => feedback
2012-11-20 20:23 Zeljan Rikalo Note Added: 0063937
2012-11-20 21:30 Valdas Jankūnas Note Added: 0063941
2012-11-21 07:44 Zeljan Rikalo Fixed in Revision => 39325
2012-11-21 07:44 Zeljan Rikalo Status feedback => resolved
2012-11-21 07:44 Zeljan Rikalo Resolution open => fixed
2012-11-21 07:44 Zeljan Rikalo Note Added: 0063947
2012-11-21 10:34 Valdas Jankūnas Status resolved => closed
2012-11-21 10:34 Valdas Jankūnas Note Added: 0063951