View Issue Details

IDProjectCategoryView StatusLast Update
0023454LazarusIDEpublic2012-12-09 16:33
ReporterVojtech CihakAssigned ToMartin Friebe 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionfixed 
Product Version1.1 (SVN)Product Build 
Target VersionFixed in Version1.1 (SVN) 
Summary0023454: Source Editor is broken.
DescriptionThis caused revision 39483.

When I press any key, cursor jumps to x-pos 1024.

Lazaru SVN, FPC 2.7.1, Qt, KDE4
TagsNo tags attached.
Fixed in Revision39488
LazTarget-
WidgetsetQT
Attached Files

Activities

Martin Friebe

2012-12-09 14:43

manager   ~0064205

I can not reproduce.

Have you used "make clean" or selected "clean all" when you did rebuild? If not please do and retry.

If the issue persists, please attach your EditorOptions.xml (from the primary config path).

Does this happen on the template "unit1" that you get after selecting "new project / application"? If so specify which line you tried. Specify which key you tried (I did "end", space, backspace / I tried at the end of line, and middle of line)

Do you have 32 or 64 bit?

Can you check, if GTK builds are affected to? (You may want to test, if it hapens in a SynEdit dropped on a Form, then you can build the project for GTK, instead of the IDE. But ensure first under QT that it happens in the project)

Vojtech Cihak

2012-12-09 14:57

reporter   ~0064207

I tried: make clean all LCL_PLATFORM=qt
from console, problem persists. I use 64 bits.
I try to build GTK2.

Martin Friebe

2012-12-09 15:02

manager   ~0064208

Make a copy of your EditorOptions.xml In case the issue depends on that file.

Which revision of FPC?

Vojtech Cihak

2012-12-09 15:08

reporter   ~0064209

Last edited: 2012-12-09 15:14

GTK2 version works fine.
I'm attaching the file.

EDIT: It happens with any key on any row. Character is printed but carret moves somewhere to x-pos 1024. Except Delete key which deletes whole line.
Yes, I tried new project and my projects as well.

EDIT: FPC r. 22689

2012-12-09 15:08

 

editoroptions.xml (7,556 bytes)

Vojtech Cihak

2012-12-09 15:30

reporter   ~0064210

Yesterday (or on Friday) I had a huge update in my distro. It was mainly qt (4.8.3-3 -> 4.8.4-1) and many libs of KDE4.

Now the problem appeared with GTK2 for a while but after "make clean all" from console works fine again. With Qt the problem persists, no matter if I rebuild from console or from IDE.

Martin Friebe

2012-12-09 15:34

manager   ~0064211

Last edited: 2012-12-09 15:36

Did you try and svn update to the version before? To check that the issue goes away then?

When the caret goes to 1024, I assume the editor scroll too? And the statusbar shows the position?

>> FPC r. 22689
That seems an old 2.7.1. current is 23127.
While I do not suspect this to be related, if you can: either update, or try with 2.6.0 or 2.6.1

Vojtech Cihak

2012-12-09 15:40

reporter   ~0064212

Yes, the horizontal scrollbar scrolls to the end. Status bar shows 1024.
I tried 39482 before, it worked fine. Even without make clean all from console.

Martin Friebe

2012-12-09 15:50

manager   ~0064213

Please test with 39488.

It is rather odd this did not happen on any of my builds.

Vojtech Cihak

2012-12-09 16:33

reporter   ~0064215

Tested with r.39489. Works well.
Thank you.

Issue History

Date Modified Username Field Change
2012-12-09 13:52 Vojtech Cihak New Issue
2012-12-09 13:52 Vojtech Cihak Widgetset => QT
2012-12-09 14:04 Martin Friebe Status new => assigned
2012-12-09 14:04 Martin Friebe Assigned To => Martin Friebe
2012-12-09 14:43 Martin Friebe LazTarget => -
2012-12-09 14:43 Martin Friebe Note Added: 0064205
2012-12-09 14:43 Martin Friebe Status assigned => feedback
2012-12-09 14:57 Vojtech Cihak Note Added: 0064207
2012-12-09 15:02 Martin Friebe Note Added: 0064208
2012-12-09 15:08 Vojtech Cihak Note Added: 0064209
2012-12-09 15:08 Vojtech Cihak File Added: editoroptions.xml
2012-12-09 15:13 Vojtech Cihak Note Edited: 0064209
2012-12-09 15:14 Vojtech Cihak Note Edited: 0064209
2012-12-09 15:30 Vojtech Cihak Note Added: 0064210
2012-12-09 15:34 Martin Friebe Note Added: 0064211
2012-12-09 15:36 Martin Friebe Note Edited: 0064211
2012-12-09 15:36 Martin Friebe Note Edited: 0064211
2012-12-09 15:40 Vojtech Cihak Note Added: 0064212
2012-12-09 15:42 Martin Friebe Status feedback => assigned
2012-12-09 15:50 Martin Friebe Fixed in Revision => 39488
2012-12-09 15:50 Martin Friebe Status assigned => resolved
2012-12-09 15:50 Martin Friebe Fixed in Version => 1.1 (SVN)
2012-12-09 15:50 Martin Friebe Resolution open => fixed
2012-12-09 15:50 Martin Friebe Note Added: 0064213
2012-12-09 16:33 Vojtech Cihak Status resolved => closed
2012-12-09 16:33 Vojtech Cihak Note Added: 0064215