View Issue Details

IDProjectCategoryView StatusLast Update
0023459LazarusLCLpublic2018-12-11 18:44
ReporterIan GoddardAssigned ToBart Broersma 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
Product Version1.0.2Product Build 
Target VersionFixed in Version 
Summary0023459: TMaskEdit skips characters
DescriptionI have a mask ###;0;_ (or 9s or 1 in 2nd field). I start to enter 123 as test data. The 1 is entered correctly but the 2nd character position is skipped over leaving an underscore, the 2 gets entered in the 3rd character position & the 3 can't be entered at all so the displayed text is 1_2 & the text property contains 1 2.

Note product version is 1.0.4 but this is not available in the drop-down box.
Additional InformationPlatform is Debian 6, reproducible in 32- & 64-bit. Desktop is Trinity (KDE3 fork)
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetGTK 2
Attached Files

Relationships

related to 0034678 resolvedJuha Manninen TMaskEdit sometimes skips characters 

Activities

Ian Goddard

2012-12-10 20:56

reporter   ~0064225

After further testing it seems to be unique to Trinity desktop. It doesn't happen on Gnome 2, LXDE or XFCE. I'll log it on the Trinity site.

Ian Goddard

2012-12-10 21:33

reporter   ~0064227

Resolved. I added the Trinity version of kde-style-qtcurve package which also adds gtk2-engines-qtcurve. It might be worth determining whether there are equivalent dependencies in KDE4.

Bart Broersma

2012-12-11 09:52

developer   ~0064233

As per original reporter.
It's a WM issue.

Issue History

Date Modified Username Field Change
2012-12-10 17:03 Ian Goddard New Issue
2012-12-10 17:03 Ian Goddard Widgetset => GTK 2
2012-12-10 20:07 Luiz Americo Status new => assigned
2012-12-10 20:07 Luiz Americo Assigned To => Bart Broersma
2012-12-10 20:56 Ian Goddard Note Added: 0064225
2012-12-10 21:33 Ian Goddard Note Added: 0064227
2012-12-11 09:52 Bart Broersma LazTarget => -
2012-12-11 09:52 Bart Broersma Status assigned => resolved
2012-12-11 09:52 Bart Broersma Resolution open => no change required
2012-12-11 09:52 Bart Broersma Note Added: 0064233
2018-12-11 18:44 Bart Broersma Relationship added related to 0034678