View Issue Details

IDProjectCategoryView StatusLast Update
0023639LazarusIDEpublic2013-01-30 20:51
ReporterSalvatore CoppolaAssigned ToMartin Friebe 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformWindowsOSwindows xpOS Version
Product Version1.0.5 (SVN)Product Build 
Target Version1.2.0Fixed in Version1.1 (SVN) 
Summary0023639: Close button in source editor disappeared
DescriptionAlthough "Show close buttons in notebook" is checked, close buttons are disappeared. Also the item in the popup menu isn't there. Only Ctrl+F4 works. See screenshoot
Additional Informationsame bug in 1.04 and trunk
TagsNo tags attached.
Fixed in Revision40061
LazTarget1.2
WidgetsetWin32/Win64
Attached Files

Activities

2013-01-12 14:17

 

Immagine.png (15,944 bytes)
Immagine.png (15,944 bytes)

Martin Friebe

2013-01-12 15:35

manager   ~0064838

The option to show the close button in tabs, should probably be removed in the windows version.
For now, the PageControl does not support that (only qt / gtk).

A quick way of closing a tab is to use the middle mouse. (if enabled, there is an option)

About the menu: The popup menu was split. tab/window related options are available, if you right click the tab.
So the missing "close", if you right click the text-area is by design.

Salvatore Coppola

2013-01-12 23:27

reporter   ~0064840

So this report can be closed although (as far as i remember) the close button was there?

Martin Friebe

2013-01-13 12:15

manager   ~0064846

I take it as a reminder to hide or disable the option on windows, and will close it then.

Martin Friebe

2013-01-30 16:17

manager   ~0065320

On Windows (or any platform not supporting close buttons) the option will now be shown as disabled.

Issue History

Date Modified Username Field Change
2013-01-12 14:17 Salvatore Coppola New Issue
2013-01-12 14:17 Salvatore Coppola File Added: Immagine.png
2013-01-12 14:17 Salvatore Coppola Widgetset => Win32/Win64
2013-01-12 15:35 Martin Friebe Note Added: 0064838
2013-01-12 23:27 Salvatore Coppola Note Added: 0064840
2013-01-13 12:15 Martin Friebe Status new => assigned
2013-01-13 12:15 Martin Friebe Assigned To => Martin Friebe
2013-01-13 12:15 Martin Friebe Note Added: 0064846
2013-01-30 16:17 Martin Friebe Fixed in Revision => 40061
2013-01-30 16:17 Martin Friebe LazTarget => 1.2
2013-01-30 16:17 Martin Friebe Note Added: 0065320
2013-01-30 16:17 Martin Friebe Status assigned => resolved
2013-01-30 16:17 Martin Friebe Fixed in Version => 1.1 (SVN)
2013-01-30 16:17 Martin Friebe Resolution open => fixed
2013-01-30 16:17 Martin Friebe Target Version => 1.2.0
2013-01-30 20:51 Salvatore Coppola Status resolved => closed