View Issue Details

IDProjectCategoryView StatusLast Update
0023841LazarusLCLpublic2013-02-11 08:55
ReporterImantsAssigned ToBart Broersma 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformAllOSOS Version
Product VersionProduct Build 
Target VersionFixed in Version1.1 (SVN) 
Summary0023841: TValueListEditor memory leaks
DescriptionWhen I am using TItemProp in ValueListEditor at the en they are not freed.

Example:

      with lsPropertyes.ItemProps['Key1'] do
      begin
        EditStyle := esPickList;
        ReadOnly := True;
        PickList.Add('Val1');
        PickList.Add('Val2');
      end;
TagsNo tags attached.
Fixed in Revisionr40194, r40195, r40197
LazTarget-
Widgetset
Attached Files

Activities

Vojtech Cihak

2013-02-06 14:24

reporter   ~0065511

I can reproduce leak but I am not sure if it is related to your code. I attached demo (note that there is no code):
1) Run demo
2) Click several times to empty cells
3) Close demo and see output from heaptrace.

Lazarus 1.1 r40097M FPC 2.7.1 x86_64-linux-qt

1 unfreed memory blocks : 72
True heap size : 655360
True free heap : 655136
Should be : 655160
Call trace for block $00007FFFF7FEDEE0 size 72
  $000000000079E4BB line 467 of valedit.pas
  $000000000079EF80 line 564 of valedit.pas
  $00000000007BADC8 line 7708 of grids.pas
  $00000000007B6EB0 line 6887 of grids.pas
  $00000000007B30D6 line 6034 of grids.pas
  $000000000066177C line 2147 of include/control.inc
  $0000000000661F60 line 2281 of include/control.inc
  $000000000045A9F1

Vojtech Cihak

2013-02-06 14:25

reporter  

ValueListEditor.zip (5,751 bytes)

Bart Broersma

2013-02-06 15:22

developer   ~0065514

Fixed in r40194.
Please close if OK.

Imants

2013-02-06 15:33

reporter  

leaks.zip (4,501 bytes)

Imants

2013-02-06 15:34

reporter   ~0065515

I added project which produce same leaks which I detected

Bart Broersma

2013-02-06 16:47

developer   ~0065517

First of all: If you think the issue is not fixed, the re-open it.
Merely adding a note to it will probably not get noticed.

Second.
I cannot reproduce the memory leak with your demo program.
Please try r40197.

Imants

2013-02-06 19:23

reporter   ~0065521

Will check when snapshot will be available

Bart Broersma

2013-02-06 19:48

developer   ~0065522

So, you actually did not even test after I fixed it??

Bart Broersma

2013-02-06 19:49

developer   ~0065523

Please close if OK (with r40197 or later!!), otherwise re-open.

Imants

2013-02-11 08:55

reporter   ~0065632

no leaks detected now

Issue History

Date Modified Username Field Change
2013-02-06 10:06 Imants New Issue
2013-02-06 12:35 Marco van de Voort Project FPC => Lazarus
2013-02-06 14:24 Vojtech Cihak Note Added: 0065511
2013-02-06 14:25 Vojtech Cihak File Added: ValueListEditor.zip
2013-02-06 14:58 Bart Broersma Assigned To => Bart Broersma
2013-02-06 14:58 Bart Broersma Status new => assigned
2013-02-06 15:22 Bart Broersma Fixed in Revision => r40194
2013-02-06 15:22 Bart Broersma LazTarget => -
2013-02-06 15:22 Bart Broersma Note Added: 0065514
2013-02-06 15:22 Bart Broersma Status assigned => resolved
2013-02-06 15:22 Bart Broersma Fixed in Version => 1.1 (SVN)
2013-02-06 15:22 Bart Broersma Resolution open => fixed
2013-02-06 15:33 Imants File Added: leaks.zip
2013-02-06 15:34 Imants Note Added: 0065515
2013-02-06 16:45 Bart Broersma Fixed in Revision r40194 => r40194, r40195, r40197
2013-02-06 16:45 Bart Broersma Product Version 2.7.1 =>
2013-02-06 16:47 Bart Broersma Note Added: 0065517
2013-02-06 16:47 Bart Broersma Status resolved => feedback
2013-02-06 19:23 Imants Note Added: 0065521
2013-02-06 19:23 Imants Status feedback => assigned
2013-02-06 19:48 Bart Broersma Note Added: 0065522
2013-02-06 19:49 Bart Broersma Note Added: 0065523
2013-02-06 19:49 Bart Broersma Status assigned => resolved
2013-02-11 08:55 Imants Note Added: 0065632
2013-02-11 08:55 Imants Status resolved => closed