View Issue Details

IDProjectCategoryView StatusLast Update
0023865LazarusLCLpublic2013-02-13 12:38
ReporterImantsAssigned ToBart Broersma 
PriorityhighSeverityminorReproducibilityalways
Status closedResolutionfixed 
Product VersionProduct Build 
Target VersionFixed in Version1.1 (SVN) 
Summary0023865: TValueListEditor after entering value in cell it lose focuss
Descriptionin TValueListEditor if I type in with keybord I can type only one character after that grid lose focuss and start to focuss other components or resets focuss on editor which makes it to select all text.
TagsNo tags attached.
Fixed in Revisionr40253
LazTarget-
Widgetset
Attached Files

Activities

Imants

2013-02-09 17:55

reporter  

valedit.zip (128,565 bytes)

Bart Broersma

2013-02-10 14:01

developer   ~0065622

It's r40204 that breaks it.

Bart Broersma

2013-02-10 16:19

developer   ~0065625

I disbled hiding the editor in TValueStringList.Put, so it works again.
Please close if OK.

Imants

2013-02-13 12:38

reporter   ~0065660

It looks like that it works now

Issue History

Date Modified Username Field Change
2013-02-09 17:55 Imants New Issue
2013-02-09 17:55 Imants File Added: valedit.zip
2013-02-10 14:01 Bart Broersma LazTarget => -
2013-02-10 14:01 Bart Broersma Note Added: 0065622
2013-02-10 14:01 Bart Broersma Assigned To => Bart Broersma
2013-02-10 14:01 Bart Broersma Status new => confirmed
2013-02-10 14:01 Bart Broersma Status confirmed => assigned
2013-02-10 16:19 Bart Broersma Fixed in Revision => r40253
2013-02-10 16:19 Bart Broersma Note Added: 0065625
2013-02-10 16:19 Bart Broersma Status assigned => resolved
2013-02-10 16:19 Bart Broersma Fixed in Version => 1.1 (SVN)
2013-02-10 16:19 Bart Broersma Resolution open => fixed
2013-02-13 12:38 Imants Note Added: 0065660
2013-02-13 12:38 Imants Status resolved => closed