View Issue Details

IDProjectCategoryView StatusLast Update
0023916FPCPackagespublic2017-02-12 16:48
ReportersilvioprogAssigned ToJonas Maebe 
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionduplicate 
Product VersionProduct Build 
Target VersionFixed in Version 
Summary0023916: BGRABitmap: Internal error 2012090607
DescriptionHello,

I'm trying to compile BGRABitmap (from SVN), but it don't compile.

My environment (Laz and FPC compiled via GIT copy):

Lazarus 1.1 r40315 FPC 2.7.1 x86_64-linux-gtk 2

The error is:

http://imagebin.org/245795

And the log is:

Hint: Start of reading config file /etc/fpc.cfg
Hint: End of reading config file /etc/fpc.cfg
Free Pascal Compiler version 2.7.1 [2013/02/07] for x86_64
Copyright (c) 1993-2013 by Florian Klaempfl and others
Target OS: Linux for x86-64
Compiling bgrabitmappack.pas
Compiling bgraanimatedgif.pas
Compiling bgrabitmap.pas
Compiling bgragtkbitmap.pas
Compiling bgradefaultbitmap.pas
Compiling bgrabitmaptypes.pas
bgrabitmaptypes.pas(2475,29) Note: Local variable "errPos" is assigned but never used
/home/silvioprog/lazpaint/bgrabitmap/bgrabitmaptypes.pas(2744,1) Fatal: Internal error 2012090607

Thank you!
Tagsinternal error
Fixed in Revision
FPCOldBugId
FPCTarget
Attached Files

Relationships

duplicate of 0027580 closedFlorian FPC Internal error 2012090607 
has duplicate 0024169 resolvedSven Barth Lazarus CCR Can´t install BGRABitmap, install stops with internal error in BGRAsse.pas 
has duplicate 0029547 resolvedJonas Maebe FPC Compile fails with Internal error 2012090607 -- function parameter passing 
has duplicate 0031361 resolvedFlorian FPC Fatal: Internal error 2012090607 

Activities

Maxim Ganetsky

2013-02-18 22:27

reporter   ~0065752

This is FPC bug. Moving.

Silvio, please provide full compilable project, preferably not Lazarus-dependent.

silvioprog

2013-02-19 01:12

reporter   ~0065753

I tried to do it (*), but I could not reproduce it without BGRABitmap controls. :/

(*) http://pastebin.com/61j3kaNY - http://pastebin.com/hQWV94t9

silvioprog

2013-02-27 18:29

reporter   ~0065925

I thought that BGRABitmap it was compatible with Linux, but unfortunately I see what is not.

I would use it in system in production, but, I can't compile the BGRABitmap even in a stable version of Lazarus and Free Pascal.

Now, the error is another. It's a very strange error, I'm sending a print screen in attached.

silvioprog

2013-02-27 18:29

reporter  

2013.02.27-14.28.png (239,377 bytes)
2013.02.27-14.28.png (239,377 bytes)

Leonardo M. Ramé

2013-03-19 13:28

reporter   ~0066398

I've found the same error on the same function.

I'm using:
FPC x86_64 svn rev: 23927
Lazarus svn rev: 40590
BraBitmap svn rev: 614

Paul Ishenin

2013-03-19 14:03

developer   ~0066400

This internal error was introduced in r22351 by Florian.

Leonardo M. Ramé

2013-03-19 14:07

reporter   ~0066401

I have to go back to fpc rev 23300 to and and bgrabitmap rev 454 to be able to compile.

hckr

2013-05-01 23:29

reporter   ~0067337

Last edited: 2013-05-01 23:31

View 3 revisions

I have faced exactly the same problem as the screenshot shows.

Lazarus 1.0.8
FPC 2.6.2
Qt and Gtk2
Ubuntu 13.04 64-Bit

BGRABitmap 7.2 and 7.1 from its sourceforge repository.

hckr

2013-05-03 23:28

reporter   ~0067404

Approximately 2 months has been passed and I am still getting the error. Is there any progress?

hckr

2013-05-04 00:48

reporter   ~0067406

Tested on FPC 2.6.3, I still got the error.

Sven Barth

2013-05-05 16:52

manager   ~0067473

@Florian: I assign this to you, because you are more experienced in the area of passing methods in registers.

Regards,
Sven

Boris Popov

2013-05-27 17:40

reporter   ~0067907

I'm getting exactly the same error with fpc 2.7.1 (rev 24623) and lazpaint rev 617. The only difference is the line number:

/home/xd/src/lazarus/components/lazpaint/bgrabitmap/bgrabitmaptypes.pas(2789,1) Fatal: Internal error 2012090607

Are this bug fixable or, may be, workaround could be applied to source code of bgrabitmap?

Jurassic Pork

2013-05-28 14:54

reporter   ~0067924

Last edited: 2013-05-28 16:30

View 2 revisions

Compilation bgrabitmap package now OK :

for error on  function IntersectLine(line1, line2: TLineDef): TPointF; ( BGRABitmapTypes.pas ) :

do :
=======================================================
{$OPTIMIZATION OFF}
function IntersectLine(line1, line2: TLineDef): TPointF;
var parallel: boolean;
begin
  result := IntersectLine(line1,line2,parallel);
end;
{$OPTIMIZATION ON}
============================================================

for all errors ex: bgrasse.pas(322,3) Error: Invalid register used in memory reference expression: "xmm0"
do : replace const by constref
ex :
function DotProduct3D_128_SSE3(const v1,v2: TPoint3D_128): single; assembler;
asm
  movups xmm0, [v1]
  movups xmm1, [v2]
  mulps xmm0, xmm1

replaced by :
   function DotProduct3D_128_SSE3(constref v1,v2: TPoint3D_128): single; assembler;

why ?
because : The parameter passing mode "constref" ensures that something is passed
as reference and never as value.

Eric Kom

2013-12-05 12:51

reporter   ~0071775

I have tried all the version, but still having the same error:

/home/erickom/fpcBuild/lazarus/components/bgrabitmap6.0/bgrabitmaptypes.pas(2356,24) Note: Local variable "errPos" is assigned but never used
/home/erickom/fpcBuild/lazarus/components/bgrabitmap6.0/bgrabitmaptypes.pas(2625,1) Fatal: Internal error 2012090607

Sven Barth

2013-12-05 21:40

manager   ~0071777

Of course, because the bug report still is "assigned" and not "resolved".

Regards,
Sven

Arlen B Taylor

2015-12-31 19:36

reporter   ~0088483

Has there been any movement to get this problem resolved? I am using BGRABitMap version 8.7 and getting an error from part3d.inc(496.1) Error: Internal error 2012090607.

I am using FPC 3.0.0/Lazarus 1.6RC1. Thanks.

Arlen

Issue History

Date Modified Username Field Change
2013-02-18 14:55 silvioprog New Issue
2013-02-18 22:27 Maxim Ganetsky Note Added: 0065752
2013-02-18 22:27 Maxim Ganetsky LazTarget => -
2013-02-18 22:27 Maxim Ganetsky Status new => feedback
2013-02-18 22:27 Maxim Ganetsky Project Lazarus => FPC
2013-02-19 01:12 silvioprog Note Added: 0065753
2013-02-19 01:12 silvioprog Status feedback => new
2013-02-19 10:28 Sven Barth Tag Attached: internal error
2013-02-27 18:29 silvioprog Note Added: 0065925
2013-02-27 18:29 silvioprog File Added: 2013.02.27-14.28.png
2013-03-19 13:28 Leonardo M. Ramé Note Added: 0066398
2013-03-19 14:03 Paul Ishenin Note Added: 0066400
2013-03-19 14:07 Leonardo M. Ramé Note Added: 0066401
2013-03-30 14:05 Sven Barth Relationship added has duplicate 0024169
2013-05-01 23:29 hckr Note Added: 0067337
2013-05-01 23:30 hckr Note Edited: 0067337 View Revisions
2013-05-01 23:31 hckr Note Edited: 0067337 View Revisions
2013-05-03 23:28 hckr Note Added: 0067404
2013-05-04 00:48 hckr Note Added: 0067406
2013-05-05 16:51 Sven Barth Assigned To => Florian Klämpfl
2013-05-05 16:51 Sven Barth Status new => assigned
2013-05-05 16:52 Sven Barth Note Added: 0067473
2013-05-27 17:40 Boris Popov Note Added: 0067907
2013-05-28 14:54 Jurassic Pork Note Added: 0067924
2013-05-28 16:30 Jurassic Pork Note Edited: 0067924 View Revisions
2013-12-05 12:51 Eric Kom Note Added: 0071775
2013-12-05 21:40 Sven Barth Note Added: 0071777
2015-12-31 19:36 Arlen B Taylor Note Added: 0088483
2016-03-05 19:49 Jonas Maebe Relationship added has duplicate 0029547
2016-03-05 19:56 Jonas Maebe Relationship added duplicate of 0027580
2016-03-05 19:56 Jonas Maebe Status assigned => resolved
2016-03-05 19:56 Jonas Maebe Resolution open => duplicate
2016-03-05 19:56 Jonas Maebe Assigned To Florian Klämpfl => Jonas Maebe
2016-03-10 20:11 silvioprog Status resolved => closed
2017-02-12 16:48 Florian Relationship added has duplicate 0031361