View Issue Details

IDProjectCategoryView StatusLast Update
0023956FPCTextmode IDEpublic2020-01-21 18:06
ReporterSkvoznjak Assigned ToMarco van de Voort  
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
Platformx86_64OSLinux 
Product Version2.6.2 
Summary0023956: Incorrect display of the cursor in the window edit code.
DescriptionIn x86_64 linux builds horizontal cursor position spelled incorrectly. Details on screenshot.

To fix the bug need to patch procedure file fpcsrc/ide/wcedit.pas

Patch:

procedure TIndicator.Draw;
var
  Color: Byte;
  Frame: Char;
  L: array[0..1] of Longint;
  S: String[15];
  B: TDrawBuffer;
  K: String; //[[[[[[[[[[[[[[[[[ patch
begin
  if assigned(CodeOwner) and
     (CodeOwner^.ELockFlag>0) then
    begin
      CodeOwner^.IndicatorDrawCalled:=true;
      exit;
    end;
  if (State and sfDragging = 0) and (State and sfActive <> 0) then
   begin
     Color := GetColor(1);
     Frame := 0000205;
   end
  else
   begin
     if (State and sfDragging)<>0 then
      Color := GetColor(2)
     else
      Color := GetColor(3);
     Frame := 0000196;
   end;
  MoveChar(B, Frame, Color, Size.X);
  if State and sfActive<>0 then
   begin
     if Modified then
     WordRec (B[0]).Lo := ord('*');
{$ifdef debug}
     if StoreUndo then
       WordRec (B[1]).Lo := ord('S');
     if SyntaxComplete then
       WordRec(B[2]).lo := ord('C');
     if UseTabs then
       WordRec(B[3]).lo := ord('T');
{$endif debug}
     L[0] := Location.Y + 1;
     L[1] := Location.X + 1;
   //[[[[[[[[[[[[[[ FormatStr(S, ' %d:%d ', L); //patch
     Str(L[0],S); //[[[[[[[[[[[[[[[[[[[[v patch
     if Length(S)<6 then S:=' '+S;
     S:=S+':';
     Str(L[1],K);
     if Length(K)<3 then K:=K+' ';
     S:=S+K; //[[[[[[[[[[[[[[[[[[[[^ patch
     MoveStr(B[8 - Pos(':', S)], S, Color);
   end;
 WriteBuf(0, 0, Size.X, 1, B);
end;
TagsNo tags attached.
Fixed in Revision 23704
FPCOldBugId
FPCTarget
Attached Files

Relationships

duplicate of 0023957 resolvedPierre Muller Incorrect procedure TIndicator.Draw for x86_64 

Activities

Skvoznjak

2013-02-25 21:56

reporter  

b369bfd0d2ac.png (64,988 bytes)   
b369bfd0d2ac.png (64,988 bytes)   

Serg Bormant

2013-02-27 10:50

reporter   ~0065921

This is the same as
0023957 http://mantis.freepascal.org/view.php?id=23957

Marco van de Voort

2013-03-07 21:52

manager   ~0066104

Should be resolved by Pierre (see related)

Issue History

Date Modified Username Field Change
2013-02-25 21:56 Skvoznjak New Issue
2013-02-25 21:56 Skvoznjak File Added: b369bfd0d2ac.png
2013-02-27 10:50 Serg Bormant Note Added: 0065921
2013-02-27 11:41 Reinier Olislagers Relationship added duplicate of 0023957
2013-03-07 21:52 Marco van de Voort Fixed in Revision => 23704
2013-03-07 21:52 Marco van de Voort Note Added: 0066104
2013-03-07 21:52 Marco van de Voort Status new => resolved
2013-03-07 21:52 Marco van de Voort Resolution open => fixed
2013-03-07 21:52 Marco van de Voort Assigned To => Marco van de Voort
2020-01-21 18:06 Marco van de Voort Status resolved => closed