View Issue Details

IDProjectCategoryView StatusLast Update
0024025LazarusLCLpublic2020-03-31 12:04
Reportertekka Assigned ToJuha Manninen  
PriorityurgentSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.1 (SVN) 
Summary0024025: abnormal MDI child behavior
DescriptionCreated 2 forms, Form1 = fsMDIForm, Form2 = fsMDIChild + set parent to Form1.

If I add a panel with align <> alNone to Form1, then Form2 cannot be moved, if align is set to alNone, no problem. (See attached code).

Steps To ReproduceSee attached files
TagsNo tags attached.
Fixed in Revision
LazTarget-
WidgetsetWin32/Win64
Attached Files

Relationships

related to 0036582 resolvedOndrej Pokorny MDI support for Windows (patch and demo included) 

Activities

tekka

2013-03-10 20:16

reporter  

MDITest.zip (3,953 bytes)

josefe

2013-06-16 06:18

reporter   ~0068326

Last edited: 2013-06-16 06:20

View 2 revisions

I have a few problem

open this picture

http://www.subeimagenes.com/img/mdi-666294.jpg

Zeljan Rikalo

2013-06-16 09:39

developer   ~0068328

Widgetset ?

josefe

2013-06-19 00:32

reporter   ~0068388

Last edited: 2013-06-19 00:34

View 4 revisions

The same configuration of the example. I did not change anything.

only happens when I maximize form2.

Zeljan Rikalo

2020-02-29 09:57

developer   ~0121273

Please test if r62685 fixed your problem.

Juha Manninen

2020-03-31 09:53

developer   ~0121789

Most likely fixed. Resolving.
Can be reopened if the problem is still there.

Issue History

Date Modified Username Field Change
2013-03-10 20:16 tekka New Issue
2013-03-10 20:16 tekka File Added: MDITest.zip
2013-06-16 06:18 josefe Note Added: 0068326
2013-06-16 06:20 josefe Note Edited: 0068326 View Revisions
2013-06-16 09:39 Zeljan Rikalo Note Added: 0068328
2013-06-19 00:32 josefe Note Added: 0068388
2013-06-19 00:33 josefe Note Edited: 0068388 View Revisions
2013-06-19 00:33 josefe Note Edited: 0068388 View Revisions
2013-06-19 00:34 josefe Note Edited: 0068388 View Revisions
2020-02-29 09:57 Zeljan Rikalo Relationship added related to 0036582
2020-02-29 09:57 Zeljan Rikalo Note Added: 0121273
2020-02-29 16:04 Bart Broersma Status new => feedback
2020-02-29 16:04 Bart Broersma LazTarget => -
2020-03-31 09:53 Juha Manninen Assigned To => Juha Manninen
2020-03-31 09:53 Juha Manninen Status feedback => resolved
2020-03-31 09:53 Juha Manninen Resolution open => fixed
2020-03-31 09:53 Juha Manninen Widgetset Win32/Win64 => Win32/Win64
2020-03-31 09:53 Juha Manninen Note Added: 0121789