View Issue Details

IDProjectCategoryView StatusLast Update
0024072FPCCompilerpublic2014-06-06 17:39
ReporterMaciej Izak Assigned ToSven Barth  
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.7.1 
Fixed in Version3.0.0 
Summary0024072: Generics fatal error for generic record specialization inside class.
Description"Fatal: Compilation aborted" for attached code:

program project3;

{$mode delphi}

type
  TA<T> = record
  end;

  TB<T> = class
  public
    type
      TC = TA<T>;

      TD = record
        Foo: TC; // ! FATAL !
      end;
  end;

begin
end.
Tagsgenerics, partial specialization
Fixed in Revision27861
FPCOldBugId
FPCTarget
Attached Files

Activities

Maciej Izak

2013-03-18 11:52

reporter  

project3.lpr (218 bytes)

Sven Barth

2013-04-07 15:47

manager   ~0066856

I've fixed the crash in 24180, but the fix for the bug itself needs to wait until I've implemented support for partial specializations, because I don't want to add yet another hack-check...

Regards,
Sven

Sven Barth

2014-06-06 17:39

manager   ~0075531

Please test and close if okay.

Regards,
Sven

Issue History

Date Modified Username Field Change
2013-03-18 11:52 Maciej Izak New Issue
2013-03-18 11:52 Maciej Izak File Added: project3.lpr
2013-03-19 09:08 Sven Barth Tag Attached: generics
2013-04-07 15:47 Sven Barth Note Added: 0066856
2013-04-07 15:47 Sven Barth Tag Attached: partial specialization
2014-06-06 17:39 Sven Barth Fixed in Revision => 27861
2014-06-06 17:39 Sven Barth Note Added: 0075531
2014-06-06 17:39 Sven Barth Status new => resolved
2014-06-06 17:39 Sven Barth Fixed in Version => 2.7.1
2014-06-06 17:39 Sven Barth Resolution open => fixed
2014-06-06 17:39 Sven Barth Assigned To => Sven Barth