View Issue Details

IDProjectCategoryView StatusLast Update
0024126LazarusDebuggerpublic2013-03-24 21:50
ReporterFelipe Monteiro de CarvalhoAssigned ToMartin Friebe 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
Product VersionProduct Build 
Target VersionFixed in Version 
Summary0024126: Cannot step-by-step debug with WinCE because it looks for the source in the wrong place
DescriptionI followed these steps to get step-by-step debugging with the Lazarus latest SVN IDE and the Windows CE emulator: http://wiki.freepascal.org/Windows_CE_Interface#Debugging_Windows_CE_software_on_the_Lazarus_IDE

It runs gdb for wince correctly, it runs the application via ActiveSync in the emulator and even stops in my break point! But after it stops there, it gets lost and shows an error message saying that it cannot find the source code file, but it presents the source code file as a Windows CE path, which is completely wrong, the IDE logically cannot read file in Windows CE, it needs to get the file in my local C:\ dir in Windows, and the corresponding source file (part of Lazarus) is even open in the IDE.

A solution would be greatly appreciated as this completely blocks step-by-step debugging with WinCE
TagsNo tags attached.
Fixed in Revision
LazTarget-
Widgetset
Attached Files

Relationships

duplicate of 0017868 resolvedMarc Weustink When using the Cross-WinCE GDB with a 2.4.2 the IDE can't open any source file 
duplicate of 0017569 resolvedMarc Weustink [arm-wince-gdb] IDE doesn't find source files while debugging 
duplicate of 0021061 assignedMarc Weustink The debugger cannot open my source files (wince 5.0) 

Activities

Felipe Monteiro de Carvalho

2013-03-24 13:37

developer  

screen-capture-6.png (146,641 bytes)
screen-capture-6.png (146,641 bytes)

Sven Barth

2013-03-24 14:58

manager   ~0066522

@Felipe: In 0021061 a workaround is mentioned by adding the driver letter where your sources reside to the "additional sources" path of the project. I've not tested this yet, but at least for the creator of that issue it seems to work.

Regards,
Sven

Martin Friebe

2013-03-24 14:58

manager   ~0066523

Please read the comments on 0021061

There is a workaround in Lazarus, but it must be configured by user (and it may not work if you have files with identical Path and Name, but different drive)

The issue itself is either in fpc, or in gdb. Which one is currently not known.

Martin Friebe

2013-03-24 15:00

manager   ~0066524

Please test, if the workaround applies to your case.

If yes, this can be closed as duplicate.
If not, please give details of where this issue differs from the other.

Felipe Monteiro de Carvalho

2013-03-24 21:50

developer   ~0066534

Didn't know it is a known issue, I'll add this to the wiki.

Issue History

Date Modified Username Field Change
2013-03-24 13:37 Felipe Monteiro de Carvalho New Issue
2013-03-24 13:37 Felipe Monteiro de Carvalho Status new => assigned
2013-03-24 13:37 Felipe Monteiro de Carvalho Assigned To => Martin Friebe
2013-03-24 13:37 Felipe Monteiro de Carvalho File Added: screen-capture-6.png
2013-03-24 14:54 Martin Friebe Relationship added duplicate of 0017868
2013-03-24 14:55 Martin Friebe Relationship added duplicate of 0017569
2013-03-24 14:56 Martin Friebe Relationship added duplicate of 0021061
2013-03-24 14:58 Sven Barth Note Added: 0066522
2013-03-24 14:58 Martin Friebe Note Added: 0066523
2013-03-24 15:00 Martin Friebe Note Added: 0066524
2013-03-24 15:00 Martin Friebe Status assigned => feedback
2013-03-24 21:50 Felipe Monteiro de Carvalho Note Added: 0066534
2013-03-24 21:50 Felipe Monteiro de Carvalho Status feedback => assigned
2013-03-24 21:50 Felipe Monteiro de Carvalho Status assigned => resolved
2013-03-24 21:50 Felipe Monteiro de Carvalho Resolution open => duplicate