View Issue Details

IDProjectCategoryView StatusLast Update
0024226LazarusLCLpublic2013-04-06 16:51
ReporterBernard MarcellyAssigned ToBart Broersma 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
PlatformWindowsOSXPOS VersionSP3
Product Version1.0.8Product Build 
Target VersionFixed in Version1.1 (SVN) 
Summary0024226: TShellListView ViewStyle does not follow design-time setting
DescriptionAt runtime, the ShellListView.ViewStyle is not initialized to the design setting.
Steps To ReproducePut a TShellTreeView and TShellListView on a form.
In the IDE, set TShellListView ViewStyle to : vsList.

Compile and run : the displayed viewStyle is vsReport. It should be vsList.

In the IDE add a button that sets the ViewStyle to vsList.
Compile and run : click the button, the displayed ViewStyle changes to vsList.
TagsNo tags attached.
Fixed in Revisionr40723
LazTarget-
WidgetsetWin32/Win64
Attached Files

Activities

Bart Broersma

2013-04-04 15:58

developer   ~0066800

Confirmed on Lazarus 1.1 r40594 FPC 2.6.2 i386-win32-win32/win64.

Bart Broersma

2013-04-04 16:00

developer   ~0066801

Also, if you set ViewStyle to vsSmallIcon at designtime, and at runtime you switch to vsReport, then Name, Size and Type colums width are set to almost zero.

Bart Broersma

2013-04-04 16:19

developer   ~0066802

Last edited: 2013-04-04 16:25

View 2 revisions

vsList isn't streamed to LFM because it is declared as default for TCustomListView.ViewStyle.
In TCustomShellListView.Create ViewStyle is set to vsReport.

Should we remove the "default vsList" form TCustomListview.ViewStyle property declaration?

Bart Broersma

2013-04-06 16:51

developer   ~0066836

Please test and close if OK.

Issue History

Date Modified Username Field Change
2013-04-04 08:34 Bernard Marcelly New Issue
2013-04-04 15:58 Bart Broersma LazTarget => -
2013-04-04 15:58 Bart Broersma Note Added: 0066800
2013-04-04 15:58 Bart Broersma Status new => confirmed
2013-04-04 16:00 Bart Broersma Note Added: 0066801
2013-04-04 16:19 Bart Broersma Note Added: 0066802
2013-04-04 16:25 Bart Broersma Note Edited: 0066802 View Revisions
2013-04-06 16:51 Bart Broersma Fixed in Revision => r40723
2013-04-06 16:51 Bart Broersma Note Added: 0066836
2013-04-06 16:51 Bart Broersma Status confirmed => resolved
2013-04-06 16:51 Bart Broersma Fixed in Version => 1.1 (SVN)
2013-04-06 16:51 Bart Broersma Resolution open => fixed
2013-04-06 16:51 Bart Broersma Assigned To => Bart Broersma