View Issue Details

IDProjectCategoryView StatusLast Update
0024254FPCCompilerpublic2013-04-10 16:55
ReporterMaciej Izak Assigned ToSven Barth  
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version2.7.1 
Summary0024254: Generics methods/class methods syntax error
DescriptionI can't compile attached code (in Delphi it's working):

{$MODE DELPHI}
type
  TX = class
    procedure Foo<T>; // Fatal: Syntax error, ";" expected but "<" found
    class procedure Foo2<T>;
  end;

{ TX }

class procedure TX.Foo2<T>;
begin

end;

procedure TX.Foo<T>;
begin

end;

var
  x: TX;
begin
  TX.Foo2<Int32>;
  x := TX.Create;
  x.Foo<string>;
  x.Free;
end.
Tagsgenerics
Fixed in Revision
FPCOldBugId
FPCTarget
Attached Files

Relationships

duplicate of 0020503 acknowledged Generics does not support parameterized method 

Activities

Maciej Izak

2013-04-10 12:21

reporter  

project8.lpr (370 bytes)

Sven Barth

2013-04-10 16:55

manager   ~0066906

This was already reported.

Regards,
Sven

Issue History

Date Modified Username Field Change
2013-04-10 12:21 Maciej Izak New Issue
2013-04-10 12:21 Maciej Izak File Added: project8.lpr
2013-04-10 12:21 Maciej Izak Tag Attached: generics
2013-04-10 16:55 Sven Barth Note Added: 0066906
2013-04-10 16:55 Sven Barth Relationship added duplicate of 0020503
2013-04-10 16:55 Sven Barth Status new => resolved
2013-04-10 16:55 Sven Barth Resolution open => duplicate
2013-04-10 16:55 Sven Barth Assigned To => Sven Barth