View Issue Details

IDProjectCategoryView StatusLast Update
0024260LazarusLazReportpublic2013-04-15 06:10
ReporterchristiangAssigned ToJesus Reyes 
PrioritylowSeverityminorReproducibilityunable to reproduce
Status resolvedResolutionfixed 
PlatformWindowsOSWindowsOS Version7
Product Version1.0.6Product Build40119 
Target Version1.2.0Fixed in Version1.1 (SVN) 
Summary0024260: Corrupted LazReport embedded in LFM
DescriptionThe report embedded in the "unit1.lfm" seems to be corrupt in some way. In bug 0024249 Jesus Reyes asked me to report this issue. Unfortunately I cannot reproduce the problem on my side. Everything works fine for me.

I'm using the official Lazarus 1.0.6 release:
---------------------
Lazarus version: 1.0.6
Lazarus svn revision: 40119
Lazarus build date: 2013/03/13
Lazarus was compiled for i386-win32
Lazarus was compiled with fpc 2.6.0
---------------------
(I haven't found a way to display the SVN revision of fpc)
TagsNo tags attached.
Fixed in Revision40808, 40809
LazTarget1.2
WidgetsetWin32/Win64
Attached Files

Activities

christiang

2013-04-12 10:06

reporter  

test.zip (129,819 bytes)

christiang

2013-04-12 10:07

reporter  

test.lrf (5,276 bytes)

christiang

2013-04-12 10:08

reporter   ~0066934

"test.zip" is the original project with the embedded report. "test.lrf" is the extracted report.

Jesus Reyes

2013-04-15 06:10

developer   ~0066961

What happened was that newer FPC has fixed a bug about the size of enumerated types, as the binary report included in the project was compiled with a previous FPC version when I tried to open with FPC trunk version appeared as if report was corrupt. This is a disadvantage of binary formats, they are sensible to changes in FPC versions and changes in report structures. Because of this, in r40808 for Lazarus trunk and r40809 for Lazarus fixes (together with Lazarus 1.0.6 and Lazarus 1.0.8) the binary format used to store the report in form has changed to XML, the property StoreInDFM was replaced by StoreInForm.

Issue History

Date Modified Username Field Change
2013-04-12 10:06 christiang New Issue
2013-04-12 10:06 christiang File Added: test.zip
2013-04-12 10:07 christiang File Added: test.lrf
2013-04-12 10:08 christiang Note Added: 0066934
2013-04-12 18:44 Jesus Reyes Assigned To => Jesus Reyes
2013-04-12 18:44 Jesus Reyes Status new => assigned
2013-04-15 06:10 Jesus Reyes Fixed in Revision => 40808, 40809
2013-04-15 06:10 Jesus Reyes LazTarget => 1.2
2013-04-15 06:10 Jesus Reyes Note Added: 0066961
2013-04-15 06:10 Jesus Reyes Status assigned => resolved
2013-04-15 06:10 Jesus Reyes Fixed in Version => 1.1 (SVN)
2013-04-15 06:10 Jesus Reyes Resolution open => fixed
2013-04-15 06:10 Jesus Reyes Target Version => 1.2.0