View Issue Details

IDProjectCategoryView StatusLast Update
0024273LazarusLCLpublic2014-01-18 15:09
ReporterwpAssigned ToJesus Reyes 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionfixed 
PlatformOSWindowsOS VersionWin7 32bit
Product Version1.1 (SVN)Product Build 
Target Version1.2.0Fixed in Version1.1 (SVN) 
Summary0024273: Misplaced cell editor in ValueListEditor
DescriptionThe situation is as follows:
- A custom cell editor (a picklist) is used for one or more cells of a TValueListEditor.
- A cell (# 1) with such a custom editor is selected. This shows the combobox of the picklist.
- Then another cell (# 2) using the default cell editor is selected.
- The combobox is drawn underneath the selected cell # 2. There should not be any combobox at all.
- If a third cell (# 3) using the default cell editor is selected the combobox appears in cell # 2. It is not possible to use the default cell editor for cell # 2 any more.
- The error is related with the fix of grids.pas in issue 024245. If I undo these changes the behavior of the ValueListEditor is normal.
Steps To ReproduceThe attached program demonstrates the issue:
- Compile
- Select the empty cell in column 1 next to "Month" which uses a picklist editor.
- Select the cell above (line "Year") - the combobox of the picklist editor is peeking underneath the selected cell.
- Select the first cell (line "Name", column 1). The picklist combo is now fully visible in the previously selected cell.
TagsNo tags attached.
Fixed in Revision40831
LazTarget1.2
WidgetsetWin32/Win64
Attached Files

Activities

wp

2013-04-15 00:22

developer  

ValueListEditor_Issues.zip (2,808 bytes)

wp

2013-04-15 00:25

developer   ~0066958

Sorry for the strike-through text - I was using the hash character to refer to "cell number 1", "cell number 2" etc. Don't know how to edit my bug report...

wp

2013-04-15 00:29

developer   ~0066959

Ah, and I forgot to mention that it is necessary to have the ValueListEditor on a PageControl.

Bart Broersma

2013-04-15 14:10

developer   ~0066966

So, basically it's a grids issue, which you seen in TValueListEditor because you can define custom editors per cell?

wp

2013-04-15 15:47

developer   ~0066970

I just had observed the issue with a TValueListEditor and wrote the attached demo for this component, not for a StringGrid. But I am sure that you are right - it is a grid issue. It was introduced in grids.pas in 0024245 because it disappears when I go back to the previous version.

Jesus Reyes

2013-04-17 02:46

developer   ~0066989

please test.

wp

2013-04-17 16:53

developer   ~0067001

Thanks - works perfectly.

Issue History

Date Modified Username Field Change
2013-04-15 00:22 wp New Issue
2013-04-15 00:22 wp File Added: ValueListEditor_Issues.zip
2013-04-15 00:25 wp Note Added: 0066958
2013-04-15 00:29 wp Note Added: 0066959
2013-04-15 01:18 Maxim Ganetsky LazTarget => -
2013-04-15 01:18 Maxim Ganetsky Description Updated View Revisions
2013-04-15 01:18 Maxim Ganetsky Description Updated View Revisions
2013-04-15 14:10 Bart Broersma Note Added: 0066966
2013-04-15 15:47 wp Note Added: 0066970
2013-04-15 21:15 Bart Broersma Assigned To => Jesus Reyes
2013-04-15 21:15 Bart Broersma Status new => assigned
2013-04-17 02:46 Jesus Reyes Fixed in Revision => 40831
2013-04-17 02:46 Jesus Reyes LazTarget - => 1.2
2013-04-17 02:46 Jesus Reyes Note Added: 0066989
2013-04-17 02:46 Jesus Reyes Status assigned => resolved
2013-04-17 02:46 Jesus Reyes Fixed in Version => 1.1 (SVN)
2013-04-17 02:46 Jesus Reyes Resolution open => fixed
2013-04-17 02:46 Jesus Reyes Target Version => 1.2.0
2013-04-17 16:53 wp Note Added: 0067001
2014-01-18 15:09 wp Status resolved => closed