View Issue Details

IDProjectCategoryView StatusLast Update
0024282FPCCompilerpublic2014-03-18 21:10
ReporterMaciej Izak Assigned ToSven Barth  
PriorityhighSeverityblockReproducibilityalways
Status closedResolutionduplicate 
Product Version2.7.1 
Summary0024282: Generics forward declaration not solved
DescriptionI can't compile attached code:

{$mode delphi}{$H+}
type
  TA<T> = class
    class function Foo: T; // Error: Forward declaration not solved "class procedure Foo:AnsiString;"
  end;

  TB<T> = class
    constructor Create;
  end;

class function TA<T>.Foo: T;
begin

end;

constructor TB<T>.Create;
begin
  TA<T>.Foo;
end;

var
  b: TB<string>;
Tagsgenerics
Fixed in Revision
FPCOldBugId
FPCTarget
Attached Files

Relationships

duplicate of 0021051 resolvedSven Barth Problem when using nested generic class descendant in a generic class method 

Activities

Maciej Izak

2013-04-16 12:53

reporter  

project9.lpr (298 bytes)

Marco van de Voort

2013-04-16 13:24

manager   ~0066982

XE3 compiles....

Sven Barth

2013-04-17 11:35

manager   ~0066995

Yes, that's the old topic about local specializations...

Regards,
Sven

Issue History

Date Modified Username Field Change
2013-04-16 12:53 Maciej Izak New Issue
2013-04-16 12:53 Maciej Izak File Added: project9.lpr
2013-04-16 12:53 Maciej Izak Tag Attached: generics
2013-04-16 13:24 Marco van de Voort Note Added: 0066982
2013-04-17 11:35 Sven Barth Note Added: 0066995
2013-09-26 09:36 Sven Barth Relationship added duplicate of 0021051
2013-09-26 09:36 Sven Barth Status new => resolved
2013-09-26 09:36 Sven Barth Resolution open => duplicate
2013-09-26 09:36 Sven Barth Assigned To => Sven Barth
2014-03-18 21:10 Maciej Izak Status resolved => closed