View Issue Details

IDProjectCategoryView StatusLast Update
0024284LazarusLCLpublic2013-04-19 06:17
ReporterAndre ChristianAssigned ToJesus Reyes 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
PlatformLinuxOSUbuntuOS Version12.04
Product VersionProduct Build 
Target Version1.2.0Fixed in Version1.1 (SVN) 
Summary0024284: Can't Read OnKeyPress On DBGrid and StringGrid
DescriptionI've put

if key=0000013 then ShowMessage('a');

on DBGRid and StringGrid KeyPress Event but nothing show when i run it and try to press "ENTER" key, but it works on TEdit.
I've tried to with OnKeyDown event on both with key=13 or key=VK_RETURN and it works.
TagsNo tags attached.
Fixed in Revision40834
LazTarget1.2
Widgetset
Attached Files

Activities

Bart Broersma

2013-04-16 21:51

developer   ~0066987

Maybe related to 0023983?

Andre Christian

2013-04-16 23:30

reporter   ~0066988

Last edited: 2013-04-16 23:34

View 3 revisions

i don't know precisely but i think yes, that problem is on OnKeyDown Event but mind is OnKeyPress Event with CR character ((#)13).

Jesus Reyes

2013-04-17 04:30

developer   ~0066990

do you want to handle the key=0000013 when typing in the editor? or when there is no editor?.

Andre Christian

2013-04-17 05:53

reporter   ~0066991

I didn't understand what's mean "in the editor" or "no editor", but when my application run and user press Enter button on StringGrid it can show some message like "a" or another process, with OnKeyPress Event.

Jesus Reyes

2013-04-18 00:42

developer   ~0067005

A stringgrid by default is not editable, you make it editable by including option goEditing. Once a grid is editable, well, it can edit. My question is: do you want to handle the key 0000013 once the editor is visible or when the editor is not visible?

From your answer it can be deduced that your grid is not editable and simply press the enter button (I guess you mean the ENTER key), in this case I can't reproduce the problem your report. Please attach a simple program that demonstrates the problem.

Andre Christian

2013-04-18 07:41

reporter  

StringGridOnKeyPress.rar (126,713 bytes)

Andre Christian

2013-04-18 07:42

reporter   ~0067007

I've set editable to True, please check my attachment. I put comment on OnKeyDown and uncomment on OnKeyPress.

Jesus Reyes

2013-04-18 09:17

developer   ~0067010

Please test and close this report if Ok.

Andre Christian

2013-04-18 10:08

reporter   ~0067012

Which one i must test?

Jesus Reyes

2013-04-18 16:46

developer   ~0067018

Sorry, mixed fix revision

Andre Christian

2013-04-19 06:17

reporter   ~0067034

Is that mean i must download lazarus new version at next update?

Issue History

Date Modified Username Field Change
2013-04-16 21:08 Andre Christian New Issue
2013-04-16 21:51 Bart Broersma Note Added: 0066987
2013-04-16 21:52 Bart Broersma Assigned To => Jesus Reyes
2013-04-16 21:52 Bart Broersma Status new => assigned
2013-04-16 23:30 Andre Christian Note Added: 0066988
2013-04-16 23:30 Andre Christian Note Edited: 0066988 View Revisions
2013-04-16 23:34 Andre Christian Note Edited: 0066988 View Revisions
2013-04-17 04:30 Jesus Reyes LazTarget => -
2013-04-17 04:30 Jesus Reyes Note Added: 0066990
2013-04-17 04:30 Jesus Reyes Status assigned => feedback
2013-04-17 05:53 Andre Christian Note Added: 0066991
2013-04-17 05:53 Andre Christian Status feedback => assigned
2013-04-18 00:42 Jesus Reyes Note Added: 0067005
2013-04-18 00:45 Jesus Reyes Status assigned => feedback
2013-04-18 07:41 Andre Christian File Added: StringGridOnKeyPress.rar
2013-04-18 07:42 Andre Christian Note Added: 0067007
2013-04-18 07:42 Andre Christian Status feedback => assigned
2013-04-18 09:17 Jesus Reyes Fixed in Revision => 40833
2013-04-18 09:17 Jesus Reyes LazTarget - => 1.2
2013-04-18 09:17 Jesus Reyes Note Added: 0067010
2013-04-18 09:17 Jesus Reyes Status assigned => resolved
2013-04-18 09:17 Jesus Reyes Fixed in Version => 1.1 (SVN)
2013-04-18 09:17 Jesus Reyes Resolution open => fixed
2013-04-18 09:17 Jesus Reyes Target Version => 1.2.0
2013-04-18 10:08 Andre Christian Note Added: 0067012
2013-04-18 16:46 Jesus Reyes Fixed in Revision 40833 => 40834
2013-04-18 16:46 Jesus Reyes Note Added: 0067018
2013-04-19 06:17 Andre Christian Note Added: 0067034